Bug 170379 - RHEL3: losetup (and mount -o loop) wrap at 2GB
RHEL3: losetup (and mount -o loop) wrap at 2GB
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: util-linux (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Ben Levenson
:
: 171200 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-11 04:17 EDT by Karel Zak
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-21 06:30:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix losetup wrap at 2GB (1.87 KB, patch)
2006-02-17 19:37 EST, Alex Butcher
no flags Details | Diff

  None (edit)
Description Karel Zak 2005-10-11 04:17:33 EDT
+++ This bug was initially created as a clone of Bug #168989 +++

Description of problem:
If you specify an offset value larger than 2GB (2^32) for losetup or mount -o
loop you will not get the expected result (i.e. it will wrap).

-- Additional comment from kzak@redhat.com on 2005-09-21 17:15 EST --
Ah.. good catch. The offset option in losetup in FC3, RHEL3 and RHEL4 is based
on "int" datetype. The problem is fixed in FC4. 

In FC3 it will be fixed in next util-linux update.
Comment 2 Karel Zak 2005-10-20 04:39:25 EDT
*** Bug 171200 has been marked as a duplicate of this bug. ***
Comment 4 Alex Butcher 2006-02-17 19:37:16 EST
Created attachment 124843 [details]
patch to fix losetup wrap at 2GB
Comment 7 Bob Johnson 2006-04-11 11:51:07 EDT
This issue is on Red Hat Engineering's list of planned work items 
for the upcoming Red Hat Enterprise Linux 3.8 release.  Engineering 
resources have been assigned and barring unforeseen circumstances, Red 
Hat intends to include this item in the 3.8 release.

Note You need to log in before you can comment on or make changes to this bug.