Bug 170418 - nvsetenv is hangs on Cell machines with 1.0 firmware
nvsetenv is hangs on Cell machines with 1.0 firmware
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ppc64-utils (Show other bugs)
4
powerpc Linux
medium Severity low
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-11 11:39 EDT by Arnd Bergmann
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-25 12:13:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
stop scanning nvram when obviously broken content is found (350 bytes, patch)
2005-10-11 11:39 EDT, Arnd Bergmann
no flags Details | Diff

  None (edit)
Description Arnd Bergmann 2005-10-11 11:39:26 EDT
Description of problem:  
  
nvsetenv hangs on Cell Blades because of broken firmware, this causes 
ybin and therefore kernel rpm install to fail 
  
Version-Release number of selected component (if applicable):  
  
0.7-12  
  
How reproducible:  
  
# strace nvsetenv --version  
  
Actual results:  
  
strace shows that nvsetenv keeps reading the same bytes.  
  
Expected results:  
  
Error message 'No common Block found'  
  
Additional info:  
  
Bug fix patch is attached, use  
%patch -p1
Comment 1 Arnd Bergmann 2005-10-11 11:39:27 EDT
Created attachment 119806 [details]
stop scanning nvram when obviously broken content is found

Note You need to log in before you can comment on or make changes to this bug.