Bug 170421 - Starting slapd fails: Berkeley DB library configured to support only DB_PRIVATE environments
Starting slapd fails: Berkeley DB library configured to support only DB_PRIVA...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openldap (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jay Fenlason
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-11 11:50 EDT by Jarkko
Modified: 2014-08-31 19:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-12 04:11:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jarkko 2005-10-11 11:50:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20040910

Description of problem:
# KRB5_KTNAME=/etc/openldap/ldap.keytab /usr/sbin/slapd -u ldap -h "ldap:/// ldaps:///" -d 256
@(#) $OpenLDAP: slapd 2.2.13 (Aug 19 2004 21:22:15) $

root@porky.build.redhat.com:/usr/src/build/440386-i386/BUILD/openldap-2.2.13/openldap-2.2.13/build-servers/servers/slapd
bdb_initialize: Sleepycat Software: Berkeley DB 4.2.52: (December  3, 2003)
bdb_initialize: Sleepycat Software: Berkeley DB 4.2.52: (December  3, 2003)
bdb_db_init: Initializing BDB database
bdb(dc=example,dc=com): Berkeley DB library configured to support only DB_PRIVATE environments
bdb_db_open: dbenv_open failed: Invalid argument (22)
backend_startup: bi_db_open(0) failed! (22)
bdb(dc=example,dc=com): txn_checkpoint interface requires an environment configured for the transaction subsystem
bdb_db_destroy: txn_checkpoint failed: Invalid argument (22)
slapd stopped.
connections_destroy: nothing to destroy.


Version-Release number of selected component (if applicable):
openldap-servers-2.2.13-2

How reproducible:
Always

Steps to Reproduce:
1. Install openldap-servers
2. Try to start ldap (default configuration should be enough)
3. Check if ldap is running - it is not
  

Actual Results:  Then I started ldap manually and with debug as 256. There is was; Berkeley DB library configured to support only DB_PRIVATE environments.

Expected Results:  Berkeley DB should have been configured to support the needed environment. (If bundled, openldap spec needs to be changed to configure the required Berkeley DB. If opeldap uses the db packages, the db packages should have been built correctly.)

Additional info:

I'm running the server in a virtual environment (user mode linux). Perhaps that is related to the problem..?
Comment 1 Nalin Dahyabhai 2005-10-11 19:10:31 EDT
The bdb backend requires features (process-shared mutexes) which are only
available if your kernel and glibc both with NPTL.  It appears that your UML
environment does not.  You'll have to use the ldbm backend if that is indeed
what's going on.
Comment 2 Jarkko 2005-10-12 04:11:42 EDT
Yes, that is going on. Changing to ldbm helped.

So the problem is that the UML kernel this host is running does not have NPTL. 
But this is not a stock kernel, which apparently has NPTL, so closing as 
NOTABUG.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.