Bug 170443 - fail to mount iso file system
fail to mount iso file system
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Ben Levenson
:
: 170442 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-11 15:26 EDT by Thomas Zine
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-10 02:03:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Zine 2005-10-11 15:26:18 EDT
Description of problem:
mount -o loop -t iso9660 ./file.iso /mountpoint
mount: Not a directory

Version-Release number of selected component (if applicable):
util-linux-2.12p-9.12

How reproducible:
always

Steps to Reproduce:
1. mount -o loop -t iso9660 ./file.iso /mountpoint
  
Actual results:
mount: Not a directory

Expected results:
Happy iso filesystem

Additional info:
strace -t mount -o loop ./RHEL4-U2-i386-AS-disc1.iso ./1
14:27:35 execve("/bin/mount", ["mount", "-o", "loop",
"./RHEL4-U2-i386-AS-disc1.iso", "./1"], [/* 24 vars */]) = 0
14:27:35 brk(0)                         = 0x9f5a000
14:27:35 old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS,
-1, 0) = 0xb7f03000
14:27:35 access("/etc/ld.so.preload", R_OK) = -1 ENOENT (No such file or directory)
14:27:35 open("/etc/ld.so.cache", O_RDONLY) = 3
14:27:35 fstat64(3, {st_mode=S_IFREG|0644, st_size=166775, ...}) = 0
14:27:35 old_mmap(NULL, 166775, PROT_READ, MAP_PRIVATE, 3, 0) = 0xb7eda000
14:27:35 close(3)                       = 0
14:27:35 open("/lib/libblkid.so.1", O_RDONLY) = 3
14:27:35 read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0 \336\20"...,
512) = 512
14:27:35 fstat64(3, {st_mode=S_IFREG|0755, st_size=33616, ...}) = 0
14:27:35 old_mmap(0x10c000, 30964, PROT_READ|PROT_EXEC,
MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0x10c000
14:27:35 old_mmap(0x113000, 4096, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x7000) = 0x113000
14:27:35 close(3)                       = 0
14:27:35 open("/lib/libuuid.so.1", O_RDONLY) = 3
14:27:35 read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\220z\20"...,
512) = 512
14:27:35 fstat64(3, {st_mode=S_IFREG|0755, st_size=10648, ...}) = 0
14:27:35 old_mmap(0x107000, 12144, PROT_READ|PROT_EXEC,
MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0x107000
14:27:35 old_mmap(0x109000, 4096, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x1000) = 0x109000
14:27:35 close(3)                       = 0
14:27:35 open("/lib/libc.so.6", O_RDONLY) = 3
14:27:35 read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\212\256"...,
512) = 512
14:27:35 fstat64(3, {st_mode=S_IFREG|0755, st_size=1485672, ...}) = 0
14:27:35 old_mmap(0x8d6000, 1215452, PROT_READ|PROT_EXEC,
MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0x8d6000
14:27:35 old_mmap(0x9f9000, 16384, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x123000) = 0x9f9000
14:27:35 old_mmap(0x9fd000, 7132, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x9fd000
14:27:35 close(3)                       = 0
14:27:35 old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS,
-1, 0) = 0xb7ed9000
14:27:35 set_thread_area({entry_number:-1 -> 6, base_addr:0xb7ed99e0,
limit:1048575, seg_32bit:1, contents:0, read_exec_only:0, limit_in_pages:1,
seg_not_present:0, useable:1}) = 0
14:27:35 mprotect(0x9f9000, 8192, PROT_READ) = 0
14:27:35 mprotect(0x8d2000, 4096, PROT_READ) = 0
14:27:35 munmap(0xb7eda000, 166775)     = 0
14:27:35 brk(0)                         = 0x9f5a000
14:27:35 brk(0x9f7b000)                 = 0x9f7b000
14:27:35 open("/usr/lib/locale/locale-archive", O_RDONLY|O_LARGEFILE) = 3
14:27:35 fstat64(3, {st_mode=S_IFREG|0644, st_size=49614592, ...}) = 0
14:27:35 mmap2(NULL, 2097152, PROT_READ, MAP_PRIVATE, 3, 0) = 0xb7cd9000
14:27:35 close(3)                       = 0
14:27:35 umask(022)                     = 022
14:27:35 open("/dev/null", O_RDWR|O_LARGEFILE) = 3
14:27:35 close(3)                       = 0
14:27:35 getuid32()                     = 0
14:27:35 geteuid32()                    = 0
14:27:35 getgid32()                     = 0
14:27:35 getegid32()                    = 0
14:27:35 prctl(0x3, 0x20, 0xbf902a38, 0x5, 0xbf902be4) = 1
14:27:35 open("/etc/blkid.tab", O_RDONLY) = 3
14:27:35 fstat64(3, {st_mode=S_IFREG|0644, st_size=753, ...}) = 0
14:27:35 fcntl64(3, F_GETFL)            = 0 (flags O_RDONLY)
14:27:35 fstat64(3, {st_mode=S_IFREG|0644, st_size=753, ...}) = 0
14:27:35 mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1,
0) = 0xb7f02000
14:27:35 _llseek(3, 0, [0], SEEK_CUR)   = 0
14:27:35 read(3, "<device DEVNO=\"0x0301\" TIME=\"112"..., 4096) = 753
14:27:35 read(3, "", 4096)              = 0
14:27:35 close(3)                       = 0
14:27:35 munmap(0xb7f02000, 4096)       = 0
14:27:35 getuid32()                     = 0
14:27:35 geteuid32()                    = 0
14:27:35 lstat64("/etc/mtab", {st_mode=S_IFREG|0644, st_size=496, ...}) = 0
14:27:35 stat64("./RHEL4-U2-i386-AS-disc1.iso", {st_mode=S_IFREG|0664,
st_size=172092054, ...}) = 0
14:27:35 stat64("/dev/loop0", {st_mode=S_IFBLK|0640, st_rdev=makedev(7, 0),
...}) = 0
14:27:35 open("/dev/loop0", O_RDONLY|O_LARGEFILE) = 3
14:27:35 ioctl(3, 0x4c03, 0xbf9025e4)   = -1 ENXIO (No such device or address)
14:27:35 close(3)                       = 0
14:27:35 open("./RHEL4-U2-i386-AS-disc1.iso", O_RDWR|O_LARGEFILE) = 3
14:27:35 open("/dev/loop0", O_RDWR|O_LARGEFILE) = 4
14:27:35 mlockall(MCL_CURRENT|MCL_FUTURE) = 0
14:27:35 ioctl(4, 0x4c00, 0x3)          = 0
14:27:35 close(3)                       = 0
14:27:35 ioctl(4, 0x4c04, 0xbf902574)   = 0
14:27:35 close(4)                       = 0
14:27:35 rt_sigprocmask(SIG_BLOCK, ~[TRAP SEGV RTMIN RT_1], NULL, 8) = 0
14:27:35 time(NULL)                     = 1129058855
14:27:35 open("/dev/loop0", O_RDONLY)   = 3
14:27:35 fstat64(3, {st_mode=S_IFBLK|0640, st_rdev=makedev(7, 0), ...}) = 0
14:27:35 lseek(3, 32768, SEEK_SET)      = 32768
14:27:35 read(3, "\1CD001\1\0LINUX                   "..., 1024) = 1024
14:27:35 time(NULL)                     = 1129058855
14:27:35 close(3)                       = 0
14:27:35 stat64("/sbin/mount.iso9660", 0xbf902660) = -1 ENOENT (No such file or
directory)
14:27:35 mount("/dev/loop0", "./1", "iso9660",
MS_POSIXACL|MS_ACTIVE|MS_NOUSER|0xec0000, 0x9f5b578) = -1 ENOTDIR (Not a directory)
14:27:35 open("/dev/loop0", O_RDONLY|O_LARGEFILE) = 3
14:27:35 ioctl(3, 0x4c01, 0)            = 0
14:27:35 close(3)                       = 0
14:27:35 rt_sigprocmask(SIG_UNBLOCK, ~[TRAP SEGV RTMIN RT_1], NULL, 8) = 0
14:27:35 stat64("./1", {st_mode=S_IFDIR|0775, st_size=4096, ...}) = 0
14:27:35 stat64("/dev/loop0", {st_mode=S_IFBLK|0640, st_rdev=makedev(7, 0),
...}) = 0
14:27:35 dup(2)                         = 3
14:27:35 fcntl64(3, F_GETFL)            = 0x2 (flags O_RDWR)
14:27:35 fstat64(3, {st_mode=S_IFCHR|0620, st_rdev=makedev(136, 0), ...}) = 0
14:27:35 mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1,
0) = 0xb7f02000
14:27:35 _llseek(3, 0, 0xbf902188, SEEK_CUR) = -1 ESPIPE (Illegal seek)
14:27:35 open("/usr/share/locale/locale.alias", O_RDONLY) = 4
14:27:35 fstat64(4, {st_mode=S_IFREG|0644, st_size=2528, ...}) = 0
14:27:35 mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1,
0) = 0xb7f01000
14:27:35 read(4, "# Locale name alias data base.\n#"..., 4096) = 2528
14:27:35 read(4, "", 4096)              = 0
14:27:35 close(4)                       = 0
14:27:35 munmap(0xb7f01000, 4096)       = 0
14:27:35 open("/usr/share/locale/en_US.UTF-8/LC_MESSAGES/libc.mo", O_RDONLY) =
-1 ENOENT (No such file or directory)
14:27:35 open("/usr/share/locale/en_US.utf8/LC_MESSAGES/libc.mo", O_RDONLY) = -1
ENOENT (No such file or directory)
14:27:35 open("/usr/share/locale/en_US/LC_MESSAGES/libc.mo", O_RDONLY) = -1
ENOENT (No such file or directory)
14:27:35 open("/usr/share/locale/en.UTF-8/LC_MESSAGES/libc.mo", O_RDONLY) = -1
ENOENT (No such file or directory)
14:27:35 open("/usr/share/locale/en.utf8/LC_MESSAGES/libc.mo", O_RDONLY) = -1
ENOENT (No such file or directory)
14:27:35 open("/usr/share/locale/en/LC_MESSAGES/libc.mo", O_RDONLY) = -1 ENOENT
(No such file or directory)
14:27:35 write(3, "mount: Not a directory\n", 23mount: Not a directory
) = 23
14:27:35 close(3)                       = 0
14:27:35 munmap(0xb7f02000, 4096)       = 0
14:27:35 stat64("/etc/blkid.tab", {st_mode=S_IFREG|0644, st_size=753, ...}) = 0
14:27:35 access("/etc/blkid.tab", W_OK) = 0
14:27:35 gettimeofday({1129058855, 706044}, NULL) = 0
14:27:35 getpid()                       = 6479
14:27:35 open("/etc/blkid.tab-8c6ckf", O_RDWR|O_CREAT|O_EXCL, 0600) = 3
14:27:35 fcntl64(3, F_GETFL)            = 0x2 (flags O_RDWR)
14:27:35 fstat64(3, {st_mode=S_IFREG|0600, st_size=0, ...}) = 0
14:27:35 mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1,
0) = 0xb7f02000
14:27:35 _llseek(3, 0, [0], SEEK_CUR)   = 0
14:27:35 fchmod(3, 0644)                = 0
14:27:35 write(3, "<device DEVNO=\"0x0301\" TIME=\"112"..., 753) = 753
14:27:35 close(3)                       = 0
14:27:35 munmap(0xb7f02000, 4096)       = 0
14:27:35 unlink("/etc/blkid.tab.old")   = 0
14:27:35 link("/etc/blkid.tab", "/etc/blkid.tab.old") = 0
14:27:35 rename("/etc/blkid.tab-8c6ckf", "/etc/blkid.tab") = 0
14:27:35 exit_group(32)                 = ?
Comment 1 Karel Zak 2005-10-11 16:24:47 EDT
I cannot reproduce it.

  # mount -o loop -t iso9660 ./image.iso /mnt/test
  # df | grep test
           670404    670404         0 100% /mnt/test
  # umount /mnt/test
  # rpm -q util-linux
  util-linux-2.12p-9.12


> 14:27:35 mount("/dev/loop0", "./1", "iso9660",
> MS_POSIXACL|MS_ACTIVE|MS_NOUSER|0xec0000, 0x9f5b578) = -1 ENOTDIR (Not a 
> directory)

man mount(2):

  ENOTDIR  The second argument, or a prefix of the first 
            argument, is not a directory.

Are you really sure that your /mountpoint directory or /dev/loop0 are OK?
Do you have free loop device ("losetup -f")?
Comment 2 Thomas Zine 2005-10-11 16:50:10 EDT
Yes I am sure. 

losetup -f
/dev/loop0

uname -a
Linux linux 2.6.13-1.1526_FC4smp #1 SMP Wed Sep 28 19:30:04 EDT 2005 i686 i686
i386 GNU/Linux

rpm -qf /bin/mount
util-linux-2.12p-9.12

ls -lar
drwxr-xr-x   2 root  root       4096 Oct 11 14:00 2
drwxrwxr-x   2 tzine tzine      4096 Oct  6 14:23 1

is your machine running the latest updates?

Comment 3 Karel Zak 2005-10-12 03:39:10 EDT
Yes, the latest updates. I've tested it on other box too. By the way, there
hasn't been any change in the mount command since version 2.12p-9.7 (Jul 12 2005).

If you're right we can expect a lot of reports, but it doesn't happen now. It
seems that you're alone with this problem.

From my point of view it seems that you have a problem with mount(2) system
call. Maybe you can try different kernel or glibc version. I don't have any
other idea. Sorry.
Comment 4 Thomas Zine 2005-10-12 09:08:24 EDT
I have already tried different kernel versions. This has occured on two machines
so far. kernel versions tried are 2.6.9-22.ELsmp 2.6.9-11.ELsmp 2.6.9-5.EL,
2.6.13-1.1526_FC4smp. I was hoping at first it would have been an issue with the
loop module and a different kernel version would resolve the issue.
here are the glibc versions on FC4 machine:
glibc-utils-2.3.5-10.3
glibc-2.3.5-10.3
glibc-headers-2.3.5-10.3
glibc-kernheaders-2.4-9.1.94
glibc-devel-2.3.5-10.3
glibc-profile-2.3.5-10.3
glibc-common-2.3.5-10.3

and gcc
gcc-4.0.1-4.fc4
gcc-objc-4.0.1-4.fc4
gcc-gfortran-4.0.1-4.fc4
compat-libgcc-296-2.96-132.fc4
compat-gcc-32-c++-3.2.3-47.fc4
gcc-c++-4.0.1-4.fc4
compat-gcc-32-3.2.3-47.fc4
gcc-gnat-4.0.1-4.fc4
compat-gcc-32-g77-3.2.3-47.fc4
libgcc-4.0.1-4.fc4
gcc-java-4.0.1-4.fc4

and libtool
libtool-ltdl-1.5.18-2.99_12.rhfc4.at
libtool-ltdl-devel-1.5.18-2.99_12.rhfc4.at
libtool-1.5.18-2.99_12.rhfc4.at

However, if it is not resolved in the next glibc version?? More instances will
show. I hoped the strace would reveal more.
Comment 5 Karel Zak 2005-10-12 10:43:52 EDT
# ls -la
total 181024
drwxr-xr-x   3 root root      4096 Oct 12 16:05 .
drwxr-x---  15 root root      4096 Oct 12 16:02 ..
drwxr-xr-x   2 root root      4096 Oct 12 16:05 mountpoint
-rw-r--r--   1 root root 185151488 Oct 12 00:24 RHEL4-U2-RC3-x86_64-AS-disc1-ftp.iso

#  mount -o loop -t iso9660 ./RHEL4-U2-RC3-x86_64-AS-disc1-ftp.iso ./mountpoint

# df | grep mountpoint
           180812    180812         0 100% /root/kzak/mountpoint

# rpm -q util-linux e2fsprogs glibc kernel
util-linux-2.12p-9.12
e2fsprogs-1.38-0.FC4.1
glibc-2.3.5-10.3
kernel-2.6.13-1.1526_FC4

Well, last difference is that I have single CPU and you're running SMP kernel.
Comment 6 Thomas Zine 2005-10-12 12:07:53 EDT
uname -a
Linux linux 2.6.13-1.1526_FC4smp #1 SMP Wed Sep 28 19:30:04 EDT 2005 i686 i686
i386 GNU/Linux

rpm -qf /bin/mount
util-linux-2.12p-9.12

rpm -qf /etc/ld.so.conf
glibc-2.3.5-10.3

ls /etc/ld.so.conf.d
mysqlclient10-i386.conf  octave-i386.conf  R-i386.conf
mysql-i386.conf          qt-i386.conf      xorg-x11-i386.conf

rpm -qf /lib/libblkid.so.1
e2fsprogs-1.38-0.FC4.1

ls -lar /lib |grep libc.so.6
lrwxrwxrwx   1 root root      13 Aug 24 08:21 libc.so.6 -> libc-2.3.5.so

ls -lar /lib |grep libblkid.so
-rwxr-xr-x   1 root root   33616 Sep  8 11:39 libblkid.so.1.0
lrwxrwxrwx   1 root root      15 Sep  9 15:59 libblkid.so.1 -> libblkid.so.1.0

rpm -qf /usr/lib/locale/locale-archive
glibc-common-2.3.5-10.3


more blkid.tab
<device DEVNO="0x0301" TIME="1126803018" LABEL="/boot"
UUID="a07e35dd-ef09-4844-953e-01630d917523" SEC_TYPE="ext2"
TYPE="ext3">/dev/hda1</device>
<device DEVNO="0x0302" TIME="1126803011" LABEL="/"
UUID="a58c0079-a3eb-4207-aa3f-514fca065132" SEC_TYPE="ext2"
TYPE="ext3">/dev/hda2</device>
<device DEVNO="0x0303" TIME="1126803018" LABEL="/home"
UUID="aa11e573-25d0-4fc6-9271-8c0dd1023d2c" TYPE="ext2">/dev/hda3</device>
<device DEVNO="0x0305" TIME="1126803013" TYPE="swap"
LABEL="\uffff\uffff\uffff\uffff\uffff\uffff\uffff\uffff\uffff\uffff\uffff\uffff\uffff\uffff\uffff"
UUID="65d4f711-df52-4e47-8599-7bb2b31d4187">/dev/hda5</device>
<device DEVNO="0x0811" TIME="1128626675" UUID="1A76-12F1" LABEL="ZINE"
SEC_TYPE="msdos" TYPE="vfat">/dev/sdb1</device>
<device DEVNO="0x0700" TIME="1129123156" TYPE="iso9660">/dev/loop0</device>

cat mtab
/dev/hda2 / ext3 rw 0 0
/dev/proc /proc proc rw 0 0
/dev/sys /sys sysfs rw 0 0
/dev/devpts /dev/pts devpts rw,gid=5,mode=620 0 0
/dev/hda1 /boot ext3 rw 0 0
/dev/shm /dev/shm tmpfs rw 0 0
/dev/hda3 /home ext2 rw 0 0
none /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0
sunrpc /var/lib/nfs/rpc_pipefs rpc_pipefs rw 0 0
automount(pid2161) /misc autofs rw,fd=4,pgrp=2161,minproto=2,maxproto=4 0 0
automount(pid2191) /net autofs rw,fd=4,pgrp=2191,minproto=2,maxproto=4 0 0
nfsd /proc/fs/nfsd nfsd rw 0 0

rpm -qf /usr/lib/autofs/mount_bind.so
autofs-4.1.4-5

and the rest of the strace shows failure:
10:27:55 lstat64("/etc/mtab", {st_mode=S_IFREG|0644, st_size=496, ...}) = 0
10:27:55 stat64("/dev/loop0", {st_mode=S_IFBLK|0640, st_rdev=makedev(7, 0), ...}
) = 0
10:27:55 open("/dev/loop0", O_RDONLY|O_LARGEFILE) = 3
10:27:55 ioctl(3, 0x4c03, 0xbf8867f4)   = -1 ENXIO (No such device or address)
10:27:55 close(3)                       = 0
10:27:55 open("./RHEL4-U2-i386-AS-disc1.iso", O_RDWR|O_LARGEFILE) = 3
10:27:55 open("/dev/loop0", O_RDWR|O_LARGEFILE) = 4
10:27:55 mlockall(MCL_CURRENT|MCL_FUTURE) = 0
10:27:55 ioctl(4, 0x4c00, 0x3)          = 0
10:27:55 close(3)                       = 0
10:27:55 ioctl(4, 0x4c04, 0xbf886784)   = 0
10:27:55 close(4)                       = 0
10:27:55 stat64("/sbin/mount.iso9660", 0xbf886870) = -1 ENOENT (No such file or
directory)
10:27:55 rt_sigprocmask(SIG_BLOCK, ~[TRAP SEGV RTMIN RT_1], NULL, 8) = 0
10:27:55 mount("/dev/loop0", "./1", "iso9660", MS_POSIXACL|MS_ACTIVE|MS_NOUSER|0
xec0000, 0x8fd7588) = -1 ENOTDIR (Not a directory)
10:27:55 open("/dev/loop0", O_RDONLY|O_LARGEFILE) = 3
10:27:55 ioctl(3, 0x4c01, 0)            = 0
10:27:55 close(3)                       = 0
10:27:55 rt_sigprocmask(SIG_UNBLOCK, ~[TRAP SEGV RTMIN RT_1], NULL, 8) = 0
10:27:55 stat64("./1", {st_mode=S_IFDIR|0775, st_size=4096, ...}) = 0
10:27:55 stat64("/dev/loop0", {st_mode=S_IFBLK|0640, st_rdev=makedev(7, 0), ...}
) = 0
10:27:55 dup(2)                         = 3
10:27:55 fcntl64(3, F_GETFL)            = 0x2 (flags O_RDWR)
10:27:55 fstat64(3, {st_mode=S_IFCHR|0620, st_rdev=makedev(136, 1), ...}) = 0
10:27:55 mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1,
0) = 0xb7f86000
10:27:55 _llseek(3, 0, 0xbf886398, SEEK_CUR) = -1 ESPIPE (Illegal seek)
10:27:55 open("/usr/share/locale/locale.alias", O_RDONLY) = 4

Comment 7 Karel Zak 2005-10-20 06:04:49 EDT
*** Bug 170442 has been marked as a duplicate of this bug. ***
Comment 8 Karel Zak 2005-10-20 06:21:04 EDT
Thomas, try it without a loop device initialization by the mount command.

1. determine a free device
   # losetup -f
   /dev/loop0

2. initlizalize the device
   # losetup /dev/loop0 /your/file.iso

3. check the device initialization
   # losetup /dev/loop0

4. mount it
   # mount /dev/loop0 /mountoint

Note, you have to call "losetup -d /dev/loop0" after umount.
Comment 9 Thomas Zine 2005-11-03 10:22:26 EST
went away after latest kernel and kernel plugins. Amazing how it could NOT be
duplicated. 

rpm -qa |grep kern

dlm-kernel-2.6.11.5-20050601.152643.FC4.9
kernel-2.6.12-1.1398_FC4
kernel-devel-2.6.12-1.1447_FC4
gnbd-kernel-smp-2.6.11.2-20050420.133124.FC4.45
kernel-devel-2.6.13-1.1532_FC4
cman-kernel-smp-2.6.11.5-20050601.152643.FC4.15
kernel-smp-2.6.12-1.1398_FC4
kernel-smp-devel-2.6.12-1.1447_FC4
dlm-kernel-smp-2.6.11.5-20050601.152643.FC4.12
kernel-smp-devel-2.6.12-1.1456_FC4
dlm-kernel-smp-2.6.11.5-20050601.152643.FC4.14
gnbd-kernheaders-2.6.11.2-20050420.133124.FC4.51
glibc-kernheaders-2.4-9.1.94
dlm-kernel-smp-2.6.11.5-20050601.152643.FC4.2
kernel-2.6.12-1.1387_FC4
dlm-kernel-smp-2.6.11.5-20050601.152643.FC4.10
cman-kernel-smp-2.6.11.5-20050601.152643.FC4.14
dlm-kernheaders-2.6.11.5-20050601.152643.FC4.15
kernel-smp-devel-2.6.12-1.1387_FC4
kernel-devel-2.6.12-1.1390_FC4
gnbd-kernel-smp-2.6.11.2-20050420.133124.FC4.42
cman-kernel-2.6.11.5-20050601.152643.FC4.9
dlm-kernel-2.6.11.5-20050601.152643.FC4.12
cman-kernheaders-2.6.11.5-20050601.152643.FC4.15
kernel-2.6.11-1.1369_FC4
kernel-smp-2.6.12-1.1390_FC4
kernel-smp-devel-2.6.12-1.1398_FC4
kernel-2.6.12-1.1447_FC4
GFS-kernel-2.6.11.8-20050601.152643.FC4.14
kernel-smp-2.6.12-1.1456_FC4
kernel-devel-2.6.13-1.1526_FC4
GFS-kernel-2.6.11.8-20050601.152643.FC4.17
cman-kernel-2.6.11.5-20050601.152643.FC4.15
gnbd-kernel-smp-2.6.11.2-20050420.133124.FC4.51
kernel-doc-2.6.13-1.1532_FC4
kernel-smp-2.6.12-1.1447_FC4
kernel-devel-2.6.12-1.1456_FC4
kernel-2.6.13-1.1526_FC4
kernel-devel-2.6.12-1.1387_FC4
kernel-smp-devel-2.6.12-1.1390_FC4
dlm-kernel-smp-2.6.11.5-20050601.152643.FC4.9
GFS-kernel-2.6.11.8-20050601.152643.FC4.9
dlm-kernel-2.6.11.5-20050601.152643.FC4.10
cman-kernel-2.6.11.5-20050601.152643.FC4.14
gnbd-kernel-smp-2.6.11.2-20050420.133124.FC4.47
dlm-kernel-smp-2.6.11.5-20050601.152643.FC4.15
kernel-smp-2.6.12-1.1387_FC4
cman-kernel-2.6.11.5-20050601.152643.FC4.8
kernel-devel-2.6.12-1.1398_FC4
cman-kernel-smp-2.6.11.5-20050601.152643.FC4.12
kernel-2.6.12-1.1456_FC4
kernel-smp-2.6.13-1.1526_FC4
kernel-smp-devel-2.6.13-1.1532_FC4
GFS-kernheaders-2.6.11.8-20050601.152643.FC4.18
dlm-kernel-2.6.11.5-20050601.152643.FC4.2
gnbd-kernel-2.6.11.2-20050420.133124.FC4.35
cman-kernel-smp-2.6.11.5-20050601.152643.FC4.9
gnbd-kernel-smp-2.6.11.2-20050420.133124.FC4.43
gnbd-kernel-2.6.11.2-20050420.133124.FC4.45
kernel-smp-devel-2.6.11-1.1369_FC4
kernel-smp-2.6.11-1.1369_FC4
GFS-kernel-2.6.11.8-20050601.152643.FC4.2
cman-kernel-smp-2.6.11.5-20050601.152643.FC4.2
gnbd-kernel-smp-2.6.11.2-20050420.133124.FC4.35
cman-kernel-smp-2.6.11.5-20050601.152643.FC4.8
cman-kernel-2.6.11.5-20050601.152643.FC4.12
gnbd-kernel-2.6.11.2-20050420.133124.FC4.51
dlm-kernel-2.6.11.5-20050601.152643.FC4.15
kernel-devel-2.6.11-1.1369_FC4
cman-kernel-2.6.11.5-20050601.152643.FC4.2
gnbd-kernel-2.6.11.2-20050420.133124.FC4.42
gnbd-kernel-2.6.11.2-20050420.133124.FC4.43
kernel-smp-devel-2.6.13-1.1526_FC4
dlm-kernel-2.6.11.5-20050601.152643.FC4.14
kernel-smp-2.6.13-1.1532_FC4
GFS-kernel-2.6.11.8-20050601.152643.FC4.18
kernel-2.6.12-1.1390_FC4
gnbd-kernel-2.6.11.2-20050420.133124.FC4.47
kernel-2.6.13-1.1532_FC4
Comment 10 Karel Zak 2005-11-10 02:03:52 EST
So I think we can close this bug as NOTABUG. Thanks for your feedback.

Note You need to log in before you can comment on or make changes to this bug.