Bug 170447 - Firefox crashes when starting up java page
Firefox crashes when starting up java page
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: java-1.4.2-ibm (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Fitzsimmons
: 170170 (view as bug list)
Depends On:
Blocks: 168429
  Show dependency treegraph
Reported: 2005-10-11 15:53 EDT by jonathan auerbach
Modified: 2007-11-30 17:07 EST (History)
10 users (show)

See Also:
Fixed In Version: RHBA-2006-0110
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-03-07 14:05:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
results from "strace firefox" (40.19 KB, text/plain)
2005-10-11 16:01 EDT, jonathan auerbach
no flags Details

  None (edit)
Description jonathan auerbach 2005-10-11 15:53:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050921 Red Hat/1.0.7-1.4.1 Firefox/1.0.7

Description of problem:
workstation was fully patched with all latest patches including all java-1.4.2-ibm-*- rpms and Firefox 1.0.7. Firefox 1.0.7 starts up just fine but when accessing a web page that has java (such as  http://time.gov/timezone.cgi?Mountain/d/-7/java ), Firefox crashes.

Version-Release number of selected component (if applicable):
java-1.4.2-ibm-*-; firefox-1.0.7-1.4.1

How reproducible:

Steps to Reproduce:
1. install java-1.4.2-ibm-*- patches for RHEL4
2. start Firefox
3. go to web page that has java

Actual Results:  Firefox crashes.

Expected Results:  java based web page is displayed in Firefox.

Additional info:

To test and correct the problem, I manually removed all the  java-1.4.2-ibm-*- patches for RHEL4 and manually reinstalled the last known working version: 


As noted, after that, java based web pages display as expected without Firefox crashing.
Comment 1 jonathan auerbach 2005-10-11 16:01:52 EDT
Created attachment 119818 [details]
results from "strace firefox"

I tried running this since I saw it recommended somewhere but I have not tried
interpreting the output....
Comment 2 daryl herzmann 2005-10-12 11:57:15 EDT
Same thing here at Iowa State.  Both firefox & mozilla will crash with
java-plugin on fully patched EL3 and EL4 systems.
Comment 3 Panu Matilainen 2005-10-14 09:29:11 EDT
From the strace output.. it ends up looking for the java plugin in
/usr/lib/firefox-<version> although it seems to initially find and load it from
/usr/lib/mozilla and dies:

6952  stat64("/usr/lib/firefox-1.0.7/libjavaplugin_oji.so",  <unfinished ...>
6953  read(6,  <unfinished ...>
6952  <... stat64 resumed> 0xbfeaf188)  = -1 ENOENT (No such file or directory)
6952  stat64("/usr/lib/firefox-1.0.7/plugins/libjavaplugin_oji.so", 0xbfeaf188)
= -1 ENOENT (No such file or directory)
6952  stat64("/usr/local/lib/mre/mre-1.0.7/libjavaplugin_oji.so", 0xbfeaf188) =
-1 ENOENT (No such file or directory)
6952  stat64("/usr/lib/firefox-1.0.7/libjavaplugin_oji.so", 0xbfeaf188) = -1
ENOENT (No such file or directory)
6952  stat64("/usr/lib/firefox-1.0.7/plugins/libjavaplugin_oji.so", 0xbfeaf188)
= -1 ENOENT (No such file or directory)
6952  write(2, "Error: could not find libjavaplu"..., 43) = 43
6952  write(2, "Plugin: can\'t find plugins/../ja"..., 45) = 45
6952  write(2, "INTERNAL ERROR on Browser End: ", 31) = 31
6952  write(2, "Could not start JavaVM!\n", 24) = 24

..and to confirm that, this fixes it:
# cd /usr/lib/firefox-1.0.7/plugins
# ln -s /usr/lib/jvm/java-1.4.2-ibm-
Comment 4 jonathan auerbach 2005-10-14 10:18:19 EDT
I tried:

# cd /usr/lib/firefox-1.0.7/plugins
# ln -s /usr/lib/jvm/java-1.4.2-ibm-

and it sort of works...

This site comes up in Firefox:

But this site (which is supposed to test your java installation) crashes Firefox:


here's another that crashes:


Plus this adding a link fix does not help if trying to run Mozilla and, a SysAdm
should not have to add links to correct something that had worked all along... 

Comment 5 Panu Matilainen 2005-10-14 10:29:23 EDT
Of course it's a bug that needs to be fixed in the package, I was just offering
"this fixed it for my applications" workaround :)
Comment 6 jonathan auerbach 2005-10-14 10:36:01 EDT
Thanks Panu... I didnt really mean to rip on you! :-)  I just want to make sure
RH gets it fixed....

Have you tried a variery java sites (like the ones abore) and all have worked?

Comment 7 Panu Matilainen 2005-10-14 10:42:48 EDT
I only tried a couple of internal java-applications which were cured by the
symlink, will do more tests on Monday when back at work.
Comment 8 Panu Matilainen 2005-10-17 05:18:16 EDT
Those two "firefox crashes" links from comment 4 worked for me after creating
the symlink - did you restart firefox after making the link? Oh and the same
workaround works for Mozilla as well:

# cd /usr/lib/mozilla-1.7.12/plugins
# ln -s /usr/lib/jvm/java-1.4.2-ibm-
Comment 11 Suzanne Hillman 2005-11-04 10:40:16 EST
*** Bug 170170 has been marked as a duplicate of this bug. ***
Comment 13 Aleksandar Milivojevic 2005-11-09 10:58:16 EST
I've installed blackdown version of java-1.4.2 (not RPM), and it seems that
amd64 plugin works OK.  I tested all URLs mentioned so far in this bug report,
none of them crashed the browser. At
http://java.com/en/download/installed.jsp?detect=jre I got empty screen.  All
other applets worked correctly after I did:

# cd /usr/lib/mozilla/plugins
# ln -s
../../../local/java/j2sdk1.4.2/jre/plugin/amd64/mozilla/libjavaplugin_oji.so .

So I guess it could be used as temporary workaround for now...
Comment 14 Thomas Fitzsimmons 2005-11-29 20:12:48 EST
I investigated this further.  Here are the results:

Direct Symlink:
libjavaplugin_oji.so ->

Directory                         Firefox               Mozilla
/usr/lib/mozilla/plugins          crash 1               crash 1
/usr/lib/mozilla-1.7.12/plugins   not found             works
/usr/lib/firefox-1.0.7/plugins    works                 not found

Indirect Symlink:
libjavaplugin_oji.so -> 
/etc/alternatives/libjavaplugin.so ->

Directory                         Firefox               Mozilla
/usr/lib/mozilla/plugins          crash 1               crash 1
/usr/lib/mozilla-1.7.12/plugins   not found             crash 2
/usr/lib/firefox-1.0.7/plugins    crash 2               not found

crash 1:
Error: could not find libjavaplugin_oji.so
Plugin: can't find plugins/../java directory
INTERNAL ERROR on Browser End: Could not start JavaVM!

System error?:: No such file or directory

crash 2:
INTERNAL ERROR on Browser End: Exec of "java" failed: 2
System error?:: No such file or directory

** (Gecko:13313): WARNING **: Serious fd usage error 19

** (Gecko:13313): WARNING **: Serious fd usage error 17
INTERNAL ERROR on Browser End: Could not read ack from child process
System error?:: Resource temporarily unavailable

So it looks like there are problems with the IBM plugin and with
Mozilla/Firefox.  The IBM plugin doesn't work through a double symlink
(predictable, given the longstanding bug of IBM's java command not working
through a double symlink).  Mozilla/Firefox crash when trying to load a plugin
from /usr/lib/mozilla/plugins.

The only option for the next update is to remove the libjavaplugin.so
alternative and install direct symlinks in /usr/lib/mozilla-1.7.12/plugins/ and
/usr/lib/firefox-1.0.7/plugins/ along with triggers to keep these symlinks
updated for browser version changes.
Comment 17 Tom Kincaid 2006-01-10 11:08:57 EST
I tested a number of Java related web sites. All passed with flying colors.
Comment 19 Red Hat Bugzilla 2006-03-07 14:05:32 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.