Bug 170450 - only half of screen is seen during kernel boot
only half of screen is seen during kernel boot
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-11 16:41 EDT by Jason
Modified: 2015-01-04 17:22 EST (History)
4 users (show)

See Also:
Fixed In Version: 2.6.15-1.1843_FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-20 15:14:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason 2005-10-11 16:41:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
I updated to the development kernel and now during boot only the top of the text is visable. For example the monitor screen the is the lines and I can only see text in the asterik area.
---------------------
| ****************  |
| *              *  |
| *              *  |
| ****************  |
|                   |
|                   |
|                   |
---------------------

I have a Silicon Graphics 1600sw LCD panel with a Number Nine Revolution 4 video card.

Version-Release number of selected component (if applicable):
kernel-2.6.13-1.1600_FC5

How reproducible:
Always

Steps to Reproduce:
1.  install the kernel
2.  boot
3.
  

Actual Results:  I can only use a small part of the screen.

Expected Results:  I should be able to use all of the screen.

Additional info:
Comment 1 Jason 2005-10-17 14:12:51 EDT
Still happens with kernel 2.6.13-1.1615_FC5.
Comment 2 Jason 2005-10-18 09:45:01 EDT
Here is the output from lspci:

00:00.0 Host bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge
(rev 03)
00:01.0 PCI bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge
(rev 03)
00:07.0 ISA bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 02)
00:07.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corporation 82371AB/EB/MB PIIX4 USB (rev 01)
00:07.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 02)
00:10.0 USB Controller: NEC Corporation USB (rev 41)
00:10.1 USB Controller: NEC Corporation USB (rev 41)
00:10.2 USB Controller: NEC Corporation USB 2.0 (rev 02)
00:11.0 SCSI storage controller: Adaptec AHA-2930U2
00:12.0 Multimedia audio controller: Creative Labs SB Audigy LS
00:13.0 Ethernet controller: 3Com Corporation 3c905B 100BaseTX [Cyclone]
01:00.0 VGA compatible controller: Number 9 Computer Company Revolution 4 (rev 01)

Kernel 2.6.13-1.1526_FC4 does not have this problem.  

I am guessing this has something to do with the changes that were into affect on
September 9th, regarding the video driver mapping or maybe the framebuffer
module is being loaded?

Thanks,

Jason
Comment 3 Jason 2005-10-22 21:11:47 EDT
I have booted two different ways, once with vga=791 and once without any vga=.
If I boot without a vga= statement I get the following in the messages log
Oct 22 19:59:57 pcjason kernel: Console: colour VGA+ 80x25

If I boot with vga=791 I get the following in the messages log:
Oct 22 15:42:09 pcjason kernel: Console: colour dummy device 80x25
Oct 22 15:42:12 pcjason kernel: vesafb: framebuffer at 0xf2000000, mapped to
0xd0880000, using 3072k, total 32768k
Oct 22 15:42:12 pcjason kernel: vesafb: mode is 1024x768x16, linelength=2048,
pages=20
Oct 22 15:42:12 pcjason kernel: vesafb: protected mode interface info at c000:7bd0
Oct 22 15:42:12 pcjason kernel: vesafb: scrolling: redraw
Oct 22 15:42:12 pcjason kernel: vesafb: Truecolor: size=0:5:6:5, shift=0:11:5:0
Oct 22 15:42:13 pcjason kernel: vesafb: Mode is VGA compatible Oct 22 15:42:13
pcjason kernel: Console: switching to colour frame buffer device 128x48
Oct 22 15:42:13 pcjason kernel: fb0: VESA VGA frame buffer device

If I boot with vga=791 I can see everything on the screen, but since this is not
the normal resolution of the SGI 1600sw it is small and off center.  Where can I
find a list of valid vga=XXXX statements?

Thanks,
Jason
Comment 4 Jason 2005-10-27 15:14:22 EDT
Still only half a screen with kernel 2.6.13-1.1629_FC5.
Comment 5 Jason 2005-10-29 12:29:59 EDT
still only half a screen with kernel 2.6.14-1.1632_FC5.

Thanks,
Jason
Comment 6 Jason 2005-11-04 09:35:11 EST
To recap so far:

I updated to rawhide back in early October and since then during boot only the
top of the text is visable. For example the monitor screen the is the lines and
I can only see text in the asterik area.  The funny thing the line of text at
the border is cut in half, only the top half of the sentence shows.  It is like
someone took a piece of paper and taped in the middle of the screen.
---------------------
| ****************  |
| *              *  |
| *              *  |
| ****************  |
|                   |
|                   |
|                   |
---------------------

I have a Silicon Graphics 1600sw LCD panel with a Number Nine Revolution 4 video
card.  I think this has to due to the announcement here
https://www.redhat.com/archives/fedora-devel-list/2005-September/msg00179.html.

During boot I see this in my messages:  Oct 22 19:59:57 pcjason kernel: Console:
colour VGA+ 80x25

With test1 coming up fast I would really like to get this fixed before test1.  I
realize people are working to get modular X out the door and you might not have
time to get to this, but please try to fix before FC5 final.

Thanks,
Jason

PS.  If you need any information just ask.
Comment 7 Bill Nottingham 2005-11-04 11:49:59 EST
So, you have a 80x25 screen and only 12.5 lines show?
Comment 8 Jason 2005-11-04 14:19:31 EST
That is the short of it.  The native resolution of the 1600sw is 800x512 or
1600x1024 (it has a 16:9 aspect ratio).  Xwindows works great at these
resolutions.  I was hoping to have the cli also work at 800x512 but I know that
is a large request and outside the scope of this bug.  I can live with 80x25,
but trying to do yum update at 80x12.5 is tricky.

Thanks,
Jason
Comment 9 Bill Nottingham 2005-11-04 14:26:11 EST
I'm assuming rerunning 'setsysfont' has no effect. I don't have any specific
ideas, although this is obviously something odd in vgacon land.
Comment 10 Jason 2005-11-04 15:42:18 EST
Correct, no change whatsoever.  I agree this is odd and that is why I wanted to
bring it to someones attention before any type of a freeze goes into effect.  

Thanks,
Comment 11 Chris Shoemaker 2005-11-23 12:45:30 EST
I've got the exact same problem here with exact same card/monitor combo.
Bug is not present in 2.6.13-1.1532_FC4 but is in 2.6.14-1.1637_FC4.

So this regression bites me even though I'm not tracking rawhide.

It seems that Jason and Samuel Thibault worked through this on LKML resulting in
this fix:
http://www.opensubscriber.com/message/linux-kernel@vger.kernel.org/2597456.html

I hope this can make it into an FC4 update soon.
Comment 12 Dave Jones 2005-12-01 02:09:29 EST
Jason, this seems to have got worked out upstream now ? Is current rawhide ok ?
Comment 13 Jason 2005-12-01 08:24:50 EST
Rawhide is not fixed yet.  The patch is in the mm series right now.  I don't
know when it will jump to the mainline.
Comment 14 Jason 2006-01-09 09:30:46 EST
The vgacon: fix doublescan mode patch from the mm tree has been merged into
linus's tree.  The issue is that since Fedora is not syncing with that tree
(until after test2 if I am reading the postings in fedora-devel right) this
patch will not be in test2 making it pretty much useless to me.  Can you please
add this patch to the fedora kernel for the test2 release so I can use it?

Thanks,
Comment 15 Chris Shoemaker 2006-01-09 10:05:13 EST
Test2?  I'm still hoping my FC4 box can be upgraded past 2.6.13-1.1532_FC4.  Am
I dreaming?  Jason, was it merged into -linus before or after 2.6.15?  Are there
any plans to package 2.6.15 for FC4?
Comment 16 Jason 2006-01-09 10:53:41 EST
I received an email this morning from Andrew saying the vgacon patch was dropped
from the mm tree.  This usually means that the patch was merged into Linus's
tree and it should be in 2.6.16rc1 whenever that gets released.  Not having a
working CLI for 3 months is a rather large problem and I hope it gets fixed soon
(for both FC4 and rawhide).  
Comment 17 Jason 2006-01-11 15:04:48 EST
The good news is I tried 2.6.15-1.1843_FC5 and now I have a full screen console
again.  I downloaded this kernel from
http://people.redhat.com/davej/kernels/Fedora/devel/RPMS.kernel/
The bad news is it does not look like this fix in for the test2 release so I
will be unable to test anaconda to see if it fixs the not writing grub to the
bootsector problem I had with test1.

Hopefully a FC4 kernel with the fix will be released shortly.
Comment 18 Jason 2006-01-15 18:53:03 EST
The doublescan patch is in the 2.6.15.1 kernel.  If a FC4 update kernel gets
released based on this kernel then FC4 will be fixed too.
Comment 19 Dave Jones 2006-01-17 01:22:05 EST
2.6.15.1 already in cvs.
2.6.15-1.1825_FC4 and higher will have it.

Note You need to log in before you can comment on or make changes to this bug.