Bug 1705023 - git-cola should require Qt5 instead of Qt4
Summary: git-cola should require Qt5 instead of Qt4
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: git-cola
Version: 30
Hardware: All
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Oliver Ilian
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1707039 1759352 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-01 07:07 UTC by Loïc Yhuel
Modified: 2020-04-15 21:01 UTC (History)
10 users (show)

Fixed In Version: git-cola-3.4-4.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-15 21:01:07 UTC
Type: Bug


Attachments (Terms of Use)

Description Loïc Yhuel 2019-05-01 07:07:57 UTC
git-cola chooses the Qt version at runtime, and defaults to PtQt5 if both are installed, so it makes more sense to require PyQt5 instead of PyQt4.

It also selects the web engine (only used for Help->Shortcuts) at runtime between :
 - QtWebEngine (Qt5 only)
 - QtWebKit (Qt4/Qt5)
 - nothing (open in a web browser)

For BuildRequires :
 - python3-PyQt4-devel is not needed
 - python3-devel doesn't seem to be needed either
For Requires :
 - python3-PyQt4 would be replaced by python3-qt5-base
 - python3-PyQt4-webkit could be either removed, or replaced by python3-qt5-webkit or python3-qt5-webengine (perhaps it could be a Recommends)

Comment 1 Damián Barberón 2019-05-01 22:57:13 UTC
It also has a missing dependency, b/C I have the error when I run git-cola: "No Qt bindings could be found" after clean install F30.

I resolved it by installing python3-PyQt5 pkg.

Comment 2 Loïc Yhuel 2019-05-02 00:10:34 UTC
(In reply to Damián Barberón from comment #1)
> It also has a missing dependency, b/C I have the error when I run git-cola:
> "No Qt bindings could be found" after clean install F30.
> 
> I resolved it by installing python3-PyQt5 pkg.
Strange, since the package requires python3-PyQt4, and it's supposed to work with it (if we believe the upstream README.md).

Also :
> We provide a copy of the qtpy module when installing git-cola so that you are not required to install QtPy separately.
> If you'd like to provide your own qtpy module, for example from the python-qtpy Debian package, then use make NO_VENDOR_LIBS=1 ... when invoking make, or export GIT_COLA_NO_VENDOR_LIBS=1 into the build environment.
Perhaps git-cola should depend on python3-QtPy (which doesn't pull any implementation, so it would still need python3-qt5-base) instead of using the bundled copy.

Comment 3 Damián Barberón 2019-08-11 03:08:52 UTC
I had to install python3-qt5 manually after installing git-cola, because otherwise it closes with the error mentioned above.
Fedora 30 clean install, up-to-date.

Comment 4 Damián Barberón 2019-08-11 03:11:07 UTC
Please, add python3-qt5 as dependency of git-cola.

Comment 5 Ben Boeckel 2019-10-30 03:30:18 UTC
*** Bug 1759352 has been marked as a duplicate of this bug. ***

Comment 6 Ben Boeckel 2019-10-30 03:30:30 UTC
*** Bug 1707039 has been marked as a duplicate of this bug. ***

Comment 7 Ben Boeckel 2019-10-30 03:46:04 UTC
PR filed to git-cola maintainer: https://src.fedoraproject.org/rpms/git-cola/pull-request/2

Trying to get a scratch build of it.

Comment 8 Massimiliano 2019-11-23 17:25:42 UTC
See also [1].

[1] https://github.com/git-cola/git-cola/issues/971

Comment 9 fab.mastr 2020-01-08 11:53:47 UTC
Similar problem has been detected:

Started git-cola after installing

reporter:       libreport-2.11.3
cmdline:        /usr/bin/python3 /usr/bin/git-cola --prompt
crash_function: module
exception_type: ModuleNotFoundError
executable:     /usr/bin/git-cola
interpreter:    python3-3.7.5-1.fc30.x86_64
kernel:         5.4.7-100.fc30.x86_64
package:        git-cola-3.4-1.fc30
reason:         __init__.py:178:<module>:qtpy.PythonQtError: No Qt bindings could be found
runlevel:       N 5
type:           Python3
uid:            1000

Comment 10 Fedora Update System 2020-04-06 19:15:14 UTC
FEDORA-2020-2f205f0830 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2020-2f205f0830

Comment 11 Fedora Update System 2020-04-07 03:46:50 UTC
FEDORA-2020-2f205f0830 has been pushed to the Fedora 30 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-2f205f0830`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-2f205f0830

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Fedora Update System 2020-04-15 21:01:07 UTC
FEDORA-2020-2f205f0830 has been pushed to the Fedora 30 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.