Bug 1705188 - httpd dependency on initscripts is unspecified
Summary: httpd dependency on initscripts is unspecified
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: httpd
Version: 30
Hardware: All
OS: All
unspecified
unspecified
Target Milestone: ---
Assignee: Luboš Uhliarik ✈
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-01 17:33 UTC by Brad Warren
Modified: 2019-05-05 02:19 UTC (History)
5 users (show)

Fixed In Version: httpd-2.4.39-4.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-05 02:19:39 UTC


Attachments (Terms of Use)

Description Brad Warren 2019-05-01 17:33:50 UTC
Description of problem: 

apachectl from the httpd package tries to use /usr/sbin/service, but httpd does not depend on the initscripts package that provides that executable.

Version-Release number of selected component (if applicable):

2.4.39-3.fc30

How reproducible:

always

Steps to Reproduce:

I initially hit this problem using Fedora Cloud AMIs at https://alt.fedoraproject.org/cloud/, however, it's probably easiest to reproduce this in Docker.

1. docker run --rm fedora:30 bash -c 'dnf install httpd -y; apachectl configtest'

Actual results:

# apachectl configtest
/usr/sbin/apachectl: line 52: /usr/sbin/service: No such file or directory

Expected results:

# apachectl configtest
AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using 172.17.0.4. Set the 'ServerName' directive globally to suppress this message
Syntax OK

Additional info:

After installing the initscripts package, in addition to the expected results, I also get the error output:

/usr/sbin/service: line 3: /etc/init.d/functions: No such file or directory

I'm not sure if this error is due to another problem (in another package) or if it is a limitation in Docker. I did not get a chance to test if I get the same result in AWS.

Comment 1 Fedora Update System 2019-05-02 17:11:00 UTC
httpd-2.4.39-4.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-1128777013

Comment 2 Fedora Update System 2019-05-03 04:12:29 UTC
httpd-2.4.39-4.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-1128777013

Comment 3 Fedora Update System 2019-05-05 02:19:39 UTC
httpd-2.4.39-4.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.