Bug 170562 - add audit message to pam_tally
add audit message to pam_tally
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: pam (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Jay Turner
:
Depends On: 170495
Blocks: 168429
  Show dependency treegraph
 
Reported: 2005-10-12 17:55 EDT by Steve Grubb
Modified: 2015-01-07 19:10 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2006-0093
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-07 13:49:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch adding extra audit messages to pam_tally (2.18 KB, patch)
2005-10-28 17:37 EDT, Steve Grubb
no flags Details | Diff

  None (edit)
Description Steve Grubb 2005-10-12 17:55:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
We need pam_tally to emit an audit record when it locks an account.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. do bad logins
2. look in audit records after account is locked

Actual Results:  No records other than mod to passwd file. This doesn't tell what account was affected.

Additional info:

I will provide a patch to provide this capability. This should be a very short patch 5-6 lines of code. open audit socket, send message, close socket.
Comment 2 Steve Grubb 2005-10-28 17:37:03 EDT
Created attachment 120524 [details]
patch adding extra audit messages to pam_tally

This is the current patch that I'm testing against rawhide. It will require
audit-libs >= 1.0.9 since the audit daemon doesn't understand the message type.
Comment 7 Red Hat Bugzilla 2006-03-07 13:49:46 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0093.html

Note You need to log in before you can comment on or make changes to this bug.