Bug 170566 - Dependancy issue updating ruby-1.6.8-9.EL3.3
Summary: Dependancy issue updating ruby-1.6.8-9.EL3.3
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: ruby   
(Show other bugs)
Version: 3.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Riek
QA Contact: Bill Huang
URL:
Whiteboard:
Keywords: Security
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-10-12 22:03 UTC by Ian Laurie
Modified: 2007-11-30 22:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-25 17:41:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ian Laurie 2005-10-12 22:03:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050921 Red Hat/1.7.12-1.1.3.2

Description of problem:
ruby-1.6.8-9.EL3.3 won't update because there isn't a corresponding ruby-tcltk-1.6.8-9.EL3.4 in the update set.

Version-Release number of selected component (if applicable):
ruby-1.6.8-9.EL3.3

How reproducible:
Always

Steps to Reproduce:
1. Launch up2date and try to update ruby.
2.
3.
  

Actual Results:  Failed dependancy.

Expected Results:  ruby-tcltk-1.6.8-9.EL3.4 should be in the channel.

Additional info:

Comment 1 Akira TAGOH 2005-10-13 15:26:50 UTC
The whole packages has been pushed again. thank you for your report.

Comment 4 mike ledoux 2005-10-18 16:17:47 UTC
This is still a problem with the packages in RHN today. 
ruby-tclck-1.6.8-9.EL3.4, ruby-docs-1.6.8-9.EL3.4 and irb-1.6.8-9.EL3.4 are not
available in the Red Hat Enterprise Linux AS (v. 3 for x86) channel.  I was able
to get the missing packages by pulling down and building ruby-1.6.8-9.EL3.4.src.rpm.

Comment 9 Need Real Name 2005-10-19 14:15:25 UTC
I'd opened this case up via normal support, and was linked this bug report this
morning.  I'm going to keep my support case open as well to make sure this bug
doesn't lose traction.

The missing packages are definitely produced from rebuilding the ruby SRPM.

Comment 10 Josh Bressers 2005-10-25 17:41:27 UTC
I have repushed the ruby errata which now contains the missing packages.


Note You need to log in before you can comment on or make changes to this bug.