This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 170576 - Anaconda dies during pSeries HTTP install
Anaconda dies during pSeries HTTP install
Status: CLOSED DUPLICATE of bug 160660
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
ppc64 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-12 19:12 EDT by George C. Wilson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-19 16:44:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George C. Wilson 2005-10-12 19:12:23 EDT
Description of problem:

For a number of weeks rawhide has not been installable by us on pSeries HV4
partition.  This is impeding our SELinux MLS development work.  The install used
to work flawlessly.

There appear to have been several flavors of problem.  The one today occurs
after setting the root password in a console-based (text) install.  Selecting
"OK" on the "Root Password" panel results in this trace:

               | An unhandled exception has occurred.        # |
               | This is most likely a bug.  Please save a   # |
               | copy of the detailed exception and file a   # |
               | bug report against anaconda at              # |
               | http://bugzilla.redhat.com/bugzilla/        # |
               |                                             # |
               | Traceback (most recent call last):          # |
               |   File "/usr/bin/anaconda", line 1177, in   # |
               | ?                                           # |
               |     intf.run(id, dispatch)                  # |
               |   File "/usr/lib/anaconda/text.py", line    # |
               | 493, in run
               |     dispatch.gotoNext()                     # |
               |   File "/usr/lib/anaconda/dispatch.py",     # |
               | line 154, in gotoNext                       # |
               |     self.moveStep()                         # |
               |   File "/usr/lib/anaconda/dispatch.py",     # |
               | line 225, in moveStep                       # |
               |     rc = apply(func, self.bindArgs(args))   # |
               |   File "/usr/lib/anaconda/backend.py",      # |
               | line 131, in doPreSelection                 # |
               |     backend.doPreSelection(intf, id,        # |
               | instPath)                                   # |
               |   File "/usr/lib/anaconda/yuminstall.py",   # |
               | line 253, in doPreSelection                 # |
               |     self.ayum.setup(fn="/tmp/yum.conf",     # |
               | root=instPath)                              # |
               |   File "/usr/lib/anaconda/yuminstall.py",   # |
               | line 222, in setup                          # |
               |     self.doConfigSetup(fn, root)            # |
               |   File                                      # |
               | "/usr/lib/python2.4/site-packages/yum/__in  # |
               | it__.py", line 82, in doConfigSetup         # |
               |     self.conf =                             # |
               | config.yumconf(configfile=fn, root=root)    # |
               |   File                                      # |
               | "/usr/lib/python2.4/site-packages/yum/conf  # |
               | ig.py", line 189, in __init__               # |
               |     configh = confpp(configfile)            # |
               |   File                                      # |
               | "/usr/lib/python2.4/site-packages/yum/conf  # |
               | ig.py", line 584, in __init__               # |
               |     fo = self._pushfile( url )              # |
               |   File                                      # |
               | "/usr/lib/python2.4/site-packages/yum/conf  # |
               | ig.py", line 675, in _pushfile              # |
               |     fo = self._urlresolver.urlopen(absurl)  # |
               |   File                                      # |
               | "/usr/lib/python2.4/site-packages/urlgrabb  # |
               | er/grabber.py", line 444, in urlopen        # |
               |     return default_grabber.urlopen(url,     # |
               | **kwargs)                                   # |
               |   File                                      # |
               | "/usr/lib/python2.4/site-packages/urlgrabb  # |
               | er/grabber.py", line 575, in urlopen        # |
               |     return self._retry(opts, retryfunc,     # |
               | url)                                        # |
               |   File                                      # |
               | "/usr/lib/python2.4/site-packages/urlgrabb  # |
               | er/grabber.py", line 547, in _retry         # |
               |     return apply(func, (opts,) + args, {})  # |
               |   File                                      # |
               | "/usr/lib/python2.4/site-packages/urlgrabb  # |
               | er/grabber.py", line 574, in retryfunc      # |
               |     return URLGrabberFileObject(url,        # |
               | filename=None, opts=opts)                   # |
               |   File                                      # |
               | "/usr/lib/python2.4/site-packages/urlgrabb  # |
               | er/grabber.py", line 728, in __init__       # |
               |     self._do_open()                         # |
               |   File                                      # |
               | "/usr/lib/python2.4/site-packages/urlgrabb  # |
               | er/grabber.py", line 820, in _do_open       # |
               |     fo, hdr = self._make_request(req,       # |
               | opener)                                     # |
               |   File                                      # |
               | "/usr/lib/python2.4/site-packages/urlgrabb  # |
               | er/grabber.py", line 891, in _make_request  # |
               |     fo = opener.open(req)                   # |
               |   File "/usr/lib/python2.4/urllib2.py",     # |
               | line 358, in open                           # |
               |     response = self._open(req, data)        # |
               |   File "/usr/lib/python2.4/urllib2.py",     # |
               | line 376, in _open                          # |
               |     '_open', req)                           # |
               |   File "/usr/lib/python2.4/urllib2.py",     # |
               | line 337, in _call_chain                    # |
               |     result = func(*args)                    # |
               |   File "/usr/lib/python2.4/urllib2.py",     # |
               | line 1119, in file_open                     # |
               |     return self.open_local_file(req)        # |
               |   File "/usr/lib/python2.4/urllib2.py",     # |
               | line 1131, in open_local_file               # |
               |     import email.Utils                      # |
               | ImportError: No module named email.Utils    # |

I also tried the same thing with the vnc install method.  It very quickly
aborted with this trace:

Running anaconda, the Fedora Core system installer - please wait...
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 721, in ?
    import xsetup
  File "/usr/lib/anaconda/xsetup.py", line 20, in ?
    import rhpxl.xserver as xserver
  File "/usr/lib/python2.4/site-packages/rhpxl/xserver.py", line 24, in ?
    import monitor
  File "/usr/lib/python2.4/site-packages/rhpxl/monitor.py", line 427, in ?
    read_modes("vesamodes")
  File "/usr/lib/python2.4/site-packages/rhpxl/monitor.py", line 404, in read_mo
des
    fd = open("/usr/share/rhpl/" + filename, 'r')
IOError: [Errno 2] No such file or directory: '/usr/share/rhpl/vesamodes'
install exited abnormally
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
        /mnt/runtime done
        disabling /dev/loop0
        /proc done
        /dev/pts done
        /sys done
        /tmp/ramfs done
        /selinux done
you may safely reboot your system

I am able to recreate these issues every time using today's (Oct. 12) ppc boot.iso.

Version-Release number of selected component (if applicable):

Fedora Rawhide, Oct 12, 2005, 12:30 PM

How reproducible:

Install today's rawhide on a pSeries partition with a boot.iso and HTTP
installation method.

Steps to Reproduce:
1. Boot a pSeries HV4 partition with todays's boot.iso.
2. Pass nothing on the boot: line.
3. Setup the network i/f to a static IP addr.
4. Select HTTP install (haven't tried FTP today).
5. Partition w/o LVMs.
6. Go on through to the "Root Password" panel.
7. Enter a root password and verification, and select OK.
8. Get an exception.
  
Actual results:

Installation fails with anaconda exception.

Expected results:

Installation succeeds.

Additional info:

This bug is similar to bug 161877 but does not look identical.
Comment 1 Paul Nasrat 2005-10-19 16:44:01 EDT

*** This bug has been marked as a duplicate of 160660 ***

Note You need to log in before you can comment on or make changes to this bug.