Bug 170654 - Some policycoreutils spec file cleanup
Summary: Some policycoreutils spec file cleanup
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: policycoreutils   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords: EasyFix
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-10-13 15:27 UTC by Robert Scheck
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: 1.27.18-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-25 17:26:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robert Scheck 2005-10-13 15:27:27 UTC
Description of problem:
Not really one, but the following changes should be done (we should use the 
macro %patch rather patch and the "p" seems to be wrong there).

Version-Release number of selected component (if applicable):
policycoreutils-1.27.7-1

Actual/expected results:
--- policycoreutils.spec        2005-10-13 17:25:29.000000000 +0200
+++ policycoreutils.spec.rsc    2005-10-13 17:25:46.000000000 +0200
@@ -32,10 +32,10 @@
 load_policy to load policies, setfiles to label filesystems, newrole
 to switch roles, and run_init to run /etc/init.d scripts in the proper
 context.
-p
+
 %prep
 %setup -q
-patch -p1 -b .rhat
+%patch -p1 -b .rhat

 %build
 make LIBDIR="%{_libdir}" CFLAGS="%{optflags}" all

Comment 1 Daniel Walsh 2005-10-13 17:46:09 UTC
Fixed in policycoreutils-1.27.1-2

Comment 2 Robert Scheck 2005-10-15 15:45:22 UTC
Nope, it's not really - only the half (even in 1.27.11-1):

[...]
load_policy to load policies, setfiles to label filesystems, newrole
to switch roles, and run_init to run /etc/init.d scripts in the proper
context.
p
^-- please, what's that "p" there in %description? ;-)

Comment 3 Robert Scheck 2005-10-25 17:26:35 UTC
Fixed at least in 1.27.18-1, thanks :)


Note You need to log in before you can comment on or make changes to this bug.