Bug 170660 - postscript pictures break ppt export in Impress
Summary: postscript pictures break ppt export in Impress
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org   
(Show other bugs)
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-10-13 16:59 UTC by Gregory Zornetzer
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-13 18:23:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
picture file that causes the breakage (7.74 KB, application/postscript)
2005-10-13 17:00 UTC, Gregory Zornetzer
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 55940 None None None Never

Description Gregory Zornetzer 2005-10-13 16:59:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
If you take a postscript file (name changed to eps), and import it as a picture into openoffice.org Impress, you can save the resulting file just fine in .odp format.  However, if you try to use the Microsoft Powerpoint XP/2003 export option, the program crashes

Version-Release number of selected component (if applicable):
openoffice.org-impress-1.9.125-1.1.0.fc4

How reproducible:
Always

Steps to Reproduce:
1.Start ooo impress
2.Create blank presentation
3.Import a postscript picture/figure
4.Save as file type Microsoft Powerpoint XP/2003
  

Actual Results:  Program seg faults

Expected Results:  The file should be saved as a ppt.  Definitely not a crash.

Additional info:

If you cannot reproduce, I can supply a postscript file that causes the problem (the files are from the molecular graphics package MOLMOL).

Comment 1 Gregory Zornetzer 2005-10-13 17:00:16 UTC
Created attachment 119928 [details]
picture file that causes the breakage

This is a picture file that causes the breakage

Comment 2 Caolan McNamara 2005-10-13 18:22:31 UTC
reproducable, now logged as http://www.openoffice.org/issues/show_bug.cgi?id=55940


Note You need to log in before you can comment on or make changes to this bug.