Bug 170664 - rhn-satellite-exporter needs a --step option
rhn-satellite-exporter needs a --step option
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
rhn410
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Wregglesworth
Fanny Augustin
:
Depends On:
Blocks: 128866
  Show dependency treegraph
 
Reported: 2005-10-13 13:21 EDT by John Wregglesworth
Modified: 2007-04-18 13:32 EDT (History)
1 user (show)

See Also:
Fixed In Version: rhn405
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-25 00:45:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Wregglesworth 2005-10-13 13:21:22 EDT
Description of problem: The new tool called rhn-satellite-exporter needs an
option called --step that will stop an export at a specific step in the export
process.
Comment 1 John Wregglesworth 2005-11-14 10:49:46 EST
Test Plan:
1. Run rhn-satellite-exporter with the --list-steps option to get a list of the
available steps.
      
      rhn-satellite-exporter --list-steps

2. Try running rhn-satellite-exporter with the --step option, using one of the
steps listed in #1.

      rhn-satellite-exporter --step=channels

3. rhn-satellite-exporter should perform the steps up to but not including the
step you included with the --step option. 
Comment 2 John Wregglesworth 2005-11-14 10:57:39 EST
The example command in step 2 is incomplete. It should look something like this:

      rhn-satellite-exporter --step=channels --dir=exports-dir -crhel-i386-as-4
Comment 3 Fanny Augustin 2005-11-22 12:43:53 EST
The tool is broken.  Please see the two tracebacks below:


[root@rlx-3-14 ~]# rhn-satellite-exporter --channel=rhel-i386-as-4 --dir=myexports
Traceback (most recent call last):
  File "/usr/bin/rhn-satellite-exporter", line 5, in ?
    from satellite_tools.intersat_sync import iss
  File "/usr/share/rhn/satellite_tools/intersat_sync/iss.py", line 8, in ?
    import dumper
  File "/usr/share/rhn/satellite_tools/intersat_sync/dumper.py", line 20, in ?
    from string_buffer import StringBuffer
ImportError: No module named string_buffer


[root@rlx-3-14 ~]# rhn-satellite-exporter --help
Traceback (most recent call last):
  File "/usr/bin/rhn-satellite-exporter", line 5, in ?
    from satellite_tools.intersat_sync import iss
  File "/usr/share/rhn/satellite_tools/intersat_sync/iss.py", line 8, in ?
    import dumper
  File "/usr/share/rhn/satellite_tools/intersat_sync/dumper.py", line 20, in ?
    from string_buffer import StringBuffer
ImportError: No module named string_buffer


ISO: rhn-satellite-4.0.5-2-redhat-linux-as-i386-4-embedded-oracle.iso
Comment 4 John Wregglesworth 2005-11-29 12:46:26 EST
The reason it failed was because I missed a file in the Makefile and spec file.
string_buffer.py has been added and the rhns packages rebuilt. The changes are
in the 4.0.5-28 or later rhns-satellite-tools package.
Comment 5 Fanny Augustin 2005-12-05 15:53:43 EST
Looks good on QA
Comment 6 Todd Warner 2006-01-25 00:45:20 EST
Released.

Note You need to log in before you can comment on or make changes to this bug.