Bug 170669 - rhn-satellite-exporter needs a --no-errata option
rhn-satellite-exporter needs a --no-errata option
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
rhn410
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Wregglesworth
Fanny Augustin
:
Depends On:
Blocks: 128866
  Show dependency treegraph
 
Reported: 2005-10-13 13:31 EDT by John Wregglesworth
Modified: 2007-04-18 13:32 EDT (History)
1 user (show)

See Also:
Fixed In Version: rhn405
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-25 00:42:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Wregglesworth 2005-10-13 13:31:03 EDT
Description of problem: The rhn-satellite-exporter tool needs a --no-errata
tool, which will prevent errata information from being placed in a satellite export.
Comment 1 John Wregglesworth 2005-11-14 11:23:50 EST
Test Plan:

1. Export a channel with rhn-satellite-exporter while using the --no-errata
option. I would create a new directory for this dump to avoid confusion when
examining the  dump directory. Also, make sure that the channel you are
exporting actually has some errata in it.

      rhn-satellite-exporter --dir=test-exports -crhel-i386-as-4 --no-errata

2. Watch the output from the above command and make sure that it doesn't say
that it is exporting errata.

3. ls the directory you included with the --dir option and make sure that the
errata directory is not included. For example:

[root@fjs-0-05 ~]# ls test3/
arches/  blacklists/  channel_families/  channels/  kickstart_files/ 
kickstart_trees/  packages/  packages_short/  rpms/
Comment 2 Fanny Augustin 2005-11-22 12:43:27 EST
The tool is broken.  Please see the two tracebacks below:


[root@rlx-3-14 ~]# rhn-satellite-exporter --channel=rhel-i386-as-4 --dir=myexports
Traceback (most recent call last):
  File "/usr/bin/rhn-satellite-exporter", line 5, in ?
    from satellite_tools.intersat_sync import iss
  File "/usr/share/rhn/satellite_tools/intersat_sync/iss.py", line 8, in ?
    import dumper
  File "/usr/share/rhn/satellite_tools/intersat_sync/dumper.py", line 20, in ?
    from string_buffer import StringBuffer
ImportError: No module named string_buffer


[root@rlx-3-14 ~]# rhn-satellite-exporter --help
Traceback (most recent call last):
  File "/usr/bin/rhn-satellite-exporter", line 5, in ?
    from satellite_tools.intersat_sync import iss
  File "/usr/share/rhn/satellite_tools/intersat_sync/iss.py", line 8, in ?
    import dumper
  File "/usr/share/rhn/satellite_tools/intersat_sync/dumper.py", line 20, in ?
    from string_buffer import StringBuffer
ImportError: No module named string_buffer


ISO: rhn-satellite-4.0.5-2-redhat-linux-as-i386-4-embedded-oracle.iso
Comment 3 John Wregglesworth 2005-11-29 12:46:06 EST
The reason it failed was because I missed a file in the Makefile and spec file.
string_buffer.py has been added and the rhns packages rebuilt. The changes are
in the 4.0.5-28 or later rhns-satellite-tools package.
Comment 4 Fanny Augustin 2005-12-05 15:53:22 EST
Looks good on QA
Comment 5 Todd Warner 2006-01-25 00:42:19 EST
Released.

Note You need to log in before you can comment on or make changes to this bug.