Bug 170672 - rhn-satellite-exporter needs a --channel option
rhn-satellite-exporter needs a --channel option
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
rhn410
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Wregglesworth
Fanny Augustin
:
Depends On:
Blocks: 128866
  Show dependency treegraph
 
Reported: 2005-10-13 13:34 EDT by John Wregglesworth
Modified: 2007-04-18 13:32 EDT (History)
1 user (show)

See Also:
Fixed In Version: rhn405
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-25 00:53:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Wregglesworth 2005-10-13 13:34:58 EDT
Description of problem: rhn-satellite-exporter needs a --channel command-line
option, which tells it what channels to include in a satellite export.
Comment 1 John Wregglesworth 2005-11-14 12:09:46 EST
Test Plan:

1. Try exporting stuff without including either -c or --channel. You should get
a an error like this: --channel not included!

      rhn-satellite-exporter --dir=test3

2. Try exporting a non-existant channel. You should get a message that looks
like this: 11:55:11 Error: Channel foo not found.

      rhn-satellite-exporter --dir=test3 -cfoo

3. Try exporting a channel for real this time. After it is exported verify that
the channel you said to export is actually the channel that was exported. You
can do that by cd'ing into the channels directory in the export directory and
making sure it contains a directory for the channel that you exported.
Additionally, you can open up the channel.xml file in that directory and verify
that the 'label' attribute of the rhn-channel tag points to the correct channel.

      rhn-satellite-exporter --dir=test3 -crhn-tools

4. Try exporting more than one channel. After they have been exported, verify
that the channels you said to export are actually the channels that were
exported. You can do that by cd'ing into the channels directory in the export
directory and making sure it contains directories for both of the channels that
you exported. Additionally, you can open up the channel.xml file in both of
those directories and verify that the 'label' attribute of the rhn-channel tag
points to the correct channels.
Comment 2 Fanny Augustin 2005-11-22 12:43:44 EST
The tool is broken.  Please see the two tracebacks below:


[root@rlx-3-14 ~]# rhn-satellite-exporter --channel=rhel-i386-as-4 --dir=myexports
Traceback (most recent call last):
  File "/usr/bin/rhn-satellite-exporter", line 5, in ?
    from satellite_tools.intersat_sync import iss
  File "/usr/share/rhn/satellite_tools/intersat_sync/iss.py", line 8, in ?
    import dumper
  File "/usr/share/rhn/satellite_tools/intersat_sync/dumper.py", line 20, in ?
    from string_buffer import StringBuffer
ImportError: No module named string_buffer


[root@rlx-3-14 ~]# rhn-satellite-exporter --help
Traceback (most recent call last):
  File "/usr/bin/rhn-satellite-exporter", line 5, in ?
    from satellite_tools.intersat_sync import iss
  File "/usr/share/rhn/satellite_tools/intersat_sync/iss.py", line 8, in ?
    import dumper
  File "/usr/share/rhn/satellite_tools/intersat_sync/dumper.py", line 20, in ?
    from string_buffer import StringBuffer
ImportError: No module named string_buffer


ISO: rhn-satellite-4.0.5-2-redhat-linux-as-i386-4-embedded-oracle.iso
Comment 3 John Wregglesworth 2005-11-29 12:46:19 EST
The reason it failed was because I missed a file in the Makefile and spec file.
string_buffer.py has been added and the rhns packages rebuilt. The changes are
in the 4.0.5-28 or later rhns-satellite-tools package.
Comment 4 Fanny Augustin 2005-12-05 15:53:36 EST
Looks good on QA
Comment 5 Todd Warner 2006-01-25 00:53:44 EST
Released.

Note You need to log in before you can comment on or make changes to this bug.