Bug 170673 - rhn-satellite-exporter needs a --dir option
rhn-satellite-exporter needs a --dir option
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
rhn410
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Wregglesworth
Fanny Augustin
:
Depends On:
Blocks: 128866
  Show dependency treegraph
 
Reported: 2005-10-13 13:37 EDT by John Wregglesworth
Modified: 2007-04-18 13:32 EDT (History)
1 user (show)

See Also:
Fixed In Version: rhn405
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-25 00:42:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Wregglesworth 2005-10-13 13:37:29 EDT
Description of problem: rhn-satellite-exporter needs a --dir command-line option
that tells it what directory to dump the satellite export into.
Comment 1 John Wregglesworth 2005-11-14 12:18:07 EST
Test Plan:

1. First try to leave off the --dir option from an rhn-satellite-exporter
command. It should give you an error that looks like this: --dir not included!

      rhn-satellite-exporter -crhel-i386-as-4

2. Next try using a directory that doesn't exist with the --dir option. You
should get this error: can't access output directory

      rhn-satellite-exporter --dir=foo -crhel-i386-as-4

3. Next try performing a correct export. All of the data should show up in the
directory you specify and not in some weird location.

      rhn-satellite-exporter --dir=test1
Comment 2 Fanny Augustin 2005-11-22 12:43:35 EST
The tool is broken.  Please see the two tracebacks below:


[root@rlx-3-14 ~]# rhn-satellite-exporter --channel=rhel-i386-as-4 --dir=myexports
Traceback (most recent call last):
  File "/usr/bin/rhn-satellite-exporter", line 5, in ?
    from satellite_tools.intersat_sync import iss
  File "/usr/share/rhn/satellite_tools/intersat_sync/iss.py", line 8, in ?
    import dumper
  File "/usr/share/rhn/satellite_tools/intersat_sync/dumper.py", line 20, in ?
    from string_buffer import StringBuffer
ImportError: No module named string_buffer


[root@rlx-3-14 ~]# rhn-satellite-exporter --help
Traceback (most recent call last):
  File "/usr/bin/rhn-satellite-exporter", line 5, in ?
    from satellite_tools.intersat_sync import iss
  File "/usr/share/rhn/satellite_tools/intersat_sync/iss.py", line 8, in ?
    import dumper
  File "/usr/share/rhn/satellite_tools/intersat_sync/dumper.py", line 20, in ?
    from string_buffer import StringBuffer
ImportError: No module named string_buffer


ISO: rhn-satellite-4.0.5-2-redhat-linux-as-i386-4-embedded-oracle.iso
Comment 3 John Wregglesworth 2005-11-29 12:46:12 EST
The reason it failed was because I missed a file in the Makefile and spec file.
string_buffer.py has been added and the rhns packages rebuilt. The changes are
in the 4.0.5-28 or later rhns-satellite-tools package.
Comment 4 Fanny Augustin 2005-12-05 15:53:29 EST
Looks good on QA
Comment 5 Todd Warner 2006-01-25 00:42:49 EST
Released.

Note You need to log in before you can comment on or make changes to this bug.