Bug 170677 - rhn-satellite-exporter needs a --db option
Summary: rhn-satellite-exporter needs a --db option
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend   
(Show other bugs)
Version: rhn410
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John Wregglesworth
QA Contact: Fanny Augustin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 128866
TreeView+ depends on / blocked
 
Reported: 2005-10-13 17:48 UTC by John Wregglesworth
Modified: 2007-04-18 17:32 UTC (History)
1 user (show)

Fixed In Version: rhn405
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-25 05:55:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Wregglesworth 2005-10-13 17:48:06 UTC
Description of problem: rhn-satellite-exporter needs a --db command-line option
that tells it what database to connect to when retrieving info for the
satellite-export.

Comment 1 John Wregglesworth 2005-11-14 17:49:19 UTC
Test Plan:

1. Set up two satellites with different sets of channels.

2. Configure the database on one of the satellites to allow remote connections.

3. On the other satellite, add an entry to the /etc/tnsnames.ora file for the
database that is now accepting remote connections.

4. On the satellite with the altered /etc/tnsnames.ora file, try to export a
channel from the other satellite. You will need to give the --db option the
connection string for the database that is now accepting remote connections.
   
      rhn-satellite-exporter --db=rhnsat/rhnsat@rhnsat2 -crhel-i386-as-4 --dir=test1

The export will fail when it gets to the point where it's exporting RPMs because
it's trying to grab RPMs from under /var/satellite that don't exist. They're on
the other satellite. This is expected. This option is mostly used for debugging
purposes.

Comment 2 Fanny Augustin 2005-11-22 17:43:57 UTC
The tool is broken.  Please see the two tracebacks below:


[root@rlx-3-14 ~]# rhn-satellite-exporter --channel=rhel-i386-as-4 --dir=myexports
Traceback (most recent call last):
  File "/usr/bin/rhn-satellite-exporter", line 5, in ?
    from satellite_tools.intersat_sync import iss
  File "/usr/share/rhn/satellite_tools/intersat_sync/iss.py", line 8, in ?
    import dumper
  File "/usr/share/rhn/satellite_tools/intersat_sync/dumper.py", line 20, in ?
    from string_buffer import StringBuffer
ImportError: No module named string_buffer


[root@rlx-3-14 ~]# rhn-satellite-exporter --help
Traceback (most recent call last):
  File "/usr/bin/rhn-satellite-exporter", line 5, in ?
    from satellite_tools.intersat_sync import iss
  File "/usr/share/rhn/satellite_tools/intersat_sync/iss.py", line 8, in ?
    import dumper
  File "/usr/share/rhn/satellite_tools/intersat_sync/dumper.py", line 20, in ?
    from string_buffer import StringBuffer
ImportError: No module named string_buffer


ISO: rhn-satellite-4.0.5-2-redhat-linux-as-i386-4-embedded-oracle.iso

Comment 3 John Wregglesworth 2005-11-29 17:46:32 UTC
The reason it failed was because I missed a file in the Makefile and spec file.
string_buffer.py has been added and the rhns packages rebuilt. The changes are
in the 4.0.5-28 or later rhns-satellite-tools package.

Comment 4 Fanny Augustin 2005-12-05 20:53:50 UTC
Looks good on QA

Comment 5 Todd Warner 2006-01-25 05:55:05 UTC
Released.


Note You need to log in before you can comment on or make changes to this bug.