Bug 17068 - umount netfs upon suspend
umount netfs upon suspend
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: apmd (Show other bugs)
7.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-29 07:18 EDT by Gerald Teschl
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-30 05:48:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerald Teschl 2000-08-29 07:18:30 EDT
There should be an option NETFSRESTART be added to the apmscript, since in
most
cases it is definitely disirable to unmount nfs filesystems before the
computer is suspended.

E.g, if I forget to unmount a directory from the server before I suspend my
laptop and take
it home, I will have to press the restart button on both the laptop and our
server;-(

--- apmscript.orig      Tue Aug  8 11:27:20 2000
+++ apmscript   Tue Aug 29 13:16:42 2000
@@ -38,6 +38,7 @@
        fi
        sync
 
+       [ "$NETFSRESTART" = "yes" ] && /etc/rc.d/init.d/netfs stop
        [ "$PCMCIARESTART" = "yes" ] && /usr/sbin/cardctl suspend
        if [ "$PCMCIAWAIT" = "yes" ]; then
                until [ `grep "Socket .: empty" /var/run/stab|wc -l` =
`grep "Socket" /var/run/stab|wc -l` ]; do
@@ -152,6 +153,7 @@
        if [ "$PCMCIARESTART" = "yes" ] ; then
                /usr/sbin/cardctl resume
        fi
+       [ "$NETFSRESTART" = "yes" ] && /etc/rc.d/init.d/netfs start
        sync
 
        [ -f /etc/sysconfig/apm-scripts/apmcontinue ] && .
/etc/sysconfig/apm-scripts/apmcontinue
"$PROG"
Comment 1 Bernhard Rosenkraenzer 2000-08-30 05:48:13 EDT
Thanks, fixed in 3.0final-19.

Note You need to log in before you can comment on or make changes to this bug.