Bug 170754 - Version mismatch between latest kernel and latest version of wireless-tools
Version mismatch between latest kernel and latest version of wireless-tools
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: wireless-tools (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-14 09:20 EDT by Haakon Riiser
Modified: 2008-01-05 08:27 EST (History)
2 users (show)

See Also:
Fixed In Version: wireless-tools-28-4.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-05 08:27:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Haakon Riiser 2005-10-14 09:20:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

Description of problem:
When I updated from kernel-2.6.12-1.1456_FC4 to kernel-2.6.13-1.1526_FC4,
I started getting the following error from the various programs in
the latest version of wireless-tools (28-0.pre4.3):

  Warning: Driver for device eth1 has been compiled with version 18
  of Wireless Extension, while this program supports up to version 17.
  Some things may be broken...

My eth1 driver is ipw2200.

Version-Release number of selected component (if applicable):
wireless-tools-28-0.pre4.3

How reproducible:
Always

Steps to Reproduce:
1. iwconfig eth1
2. 
3.
  

Actual Results:  Everything appears to work as before, but I also get the above error message.

Additional info:
Comment 1 Bertho 2005-10-23 14:11:09 EDT
Same problem with the newest kernel 2.6.13-1.1532_FC4 and
wireless-tools-28-0.pre4.3.

It is broken now for me and I cannot enable the power on the wireless card
ipw2100 (Thinkpad T42p). However, I can scan the spectrum with "iwlist scan".

--
Greetings Bertho
Comment 2 Bertho 2005-10-23 14:27:00 EDT
Upgrading to wireless-tools-28-0.pre10.4 from update testing works for me. It
has the correct interface definitions and the card will communicate again. Sorry
for the noise of the previous message, should have tried testing before.

--
Greetings Bertho
Comment 3 Christian Iseli 2007-01-22 06:01:35 EST
This report targets the FC3 or FC4 products, which have now been EOL'd.

Could you please check that it still applies to a current Fedora release, and
either update the target product or close it ?

Thanks.
Comment 4 Bertho 2007-01-22 12:10:54 EST
On FC5 there is a version mismatch.

Installed:
 wireless-tools-28-0.pre13.5.1
 kernel   2.6.18-1.2257.fc5

running "iwlist eth1 scan" results in:
Warning: Driver for device eth1 has been compiled with version 20
of Wireless Extension, while this program supports up to version 19.
Some things may be broken...

A list of cells is generated though.

Eth1 is a ipw2100 with firmware "ipw2100-firmware-1.3-5.at".

There is basic functionality, but have not tested it very well.

--
Greetings Bertho
Comment 5 Bertho 2007-04-02 17:19:36 EDT
Hi all,

With the latest kernel on FC5 (2.6.20-1.2307.fc5) and wireless-tools
28-0.pre13.5.1 the mismatch extends to two versions:
# iwlist eth1 scan
 Warning: Driver for device eth1 has been compiled with version 21
 of Wireless Extension, while this program supports up to version 19.
 Some things may be broken...
...

The wireless-tools homepage indicated version 29-pre17, which should go up to
version 21. I also noticed that this version is neither tested in FC6 not
FC7beta, while both probably suffer from the same warning message.

Wireless-tools 29-pre17 works fine on my system so far and no warning is printed
anymore. Is there any plan of going to version 29-pre17?

--
Greetings Bertho
Comment 6 Till Maas 2008-01-05 08:27:43 EST
Fixed in Fedora 7

Note You need to log in before you can comment on or make changes to this bug.