Bug 170817 - TCP throughput of RHEL4 U1 is considerably slower compared to RHEL3 U5 when TCP Segmentation Offload (TSO) function is used.
TCP throughput of RHEL4 U1 is considerably slower compared to RHEL3 U5 when T...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Neil Horman
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-14 12:55 EDT by Neil Horman
Modified: 2010-10-21 23:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-01 15:38:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tcpip throughtput benchmarking code (9.58 KB, application/x-gzip)
2005-10-14 12:55 EDT, Neil Horman
no flags Details
patch to improve tcp throughput when tso is on (32.14 KB, patch)
2005-10-14 12:58 EDT, Neil Horman
no flags Details | Diff
KABI clean version of the upstream patch (30.44 KB, patch)
2005-10-17 13:07 EDT, Neil Horman
no flags Details | Diff

  None (edit)
Description Neil Horman 2005-10-14 12:55:56 EDT
Description of problem:
customer reports significant slowdowns in TCP stack when using TSO feature under
RHEL4:


Version-Release number of selected component (if applicable):


How reproducible:
consistently

Steps to Reproduce:
1.build and run the attached tcpip.tgz test case

  
Actual results:
iosize  RHEL4 U1(TSO=on)        RHEL4 U1(TSO=off)       RHEL3 U5
------------------------------------------------------------------
8KB     98.298844(MB/sec)       116.851708              117.147941
16KB    117.347097              117.177016              117.167851
32KB    90.932036               117.283542              117.365817
64KB    91.083576               117.372518              117.535555
128KB   82.256292               117.538039              117.613522
1MB     117.663261              117.660999              117.670151


Expected results:
Improved throughput when TSO is enabled

Additional info:
Comment 1 Neil Horman 2005-10-14 12:55:56 EDT
Created attachment 119990 [details]
tcpip throughtput benchmarking code
Comment 2 Neil Horman 2005-10-14 12:58:25 EDT
Created attachment 119991 [details]
patch to improve tcp throughput when tso is on

Customer has identified this patch as an upstream fix for the tso throughput
issue.	Its an ABI breaker so its a non-starter, but we may be able to put
together a non-abi breaking version
Comment 5 Neil Horman 2005-10-17 13:07:18 EDT
Created attachment 120065 [details]
KABI clean version of the upstream patch

Same patch as the origional, modified to be KABI safe.
Comment 6 Neil Horman 2005-10-17 13:09:28 EDT
I've provided the abi clean patch to the reporting customer and am waiting
feedback on its effectiveness.
Comment 10 Neil Horman 2005-11-01 15:33:55 EST
I've discussed this internally, and the consensus is that this should be a
WONTFIX, since the changes run the very real risk of creating highly bursty
transmit patterns, that will have a strong negative impact on performance for
the nominal system workload.  The better solution is to simply set the
tcp_tso_win_divisor to 3 for the appropriate cases in sysctl.conf, or to disable
tso in the affected driver entirely, using the ETHTOOL_OPTS define in the
network interface sysconfig files.

Note You need to log in before you can comment on or make changes to this bug.