Bug 170823 - Wrong text color
Wrong text color
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Directory Console (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Rich Megginson
Viktor Ashirov
:
: 172345 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-14 13:37 EDT by Lillian Angel
Modified: 2015-12-07 11:48 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 11:48:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix this problem (744 bytes, patch)
2005-10-14 13:38 EDT, Lillian Angel
no flags Details | Diff

  None (edit)
Description Lillian Angel 2005-10-14 13:37:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
When running the console on a freeVM, it appears the first input dialog that shows up is using the wrong text color. 

In AbstractDialog.java, it sets the foreground color to the default value "text", but "text" is used as the background color and "textText" is used as the foreground color.

See the attached patch.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Run on a freeVM (Classpath + jamvm)
  

Actual Results:  Text color in input dialog is white.

Expected Results:  Should be black.

Additional info:
Comment 1 Lillian Angel 2005-10-14 13:38:52 EDT
Created attachment 119993 [details]
Patch to fix this problem
Comment 3 Rich Megginson 2005-12-02 16:34:09 EST
/cvs/dirsec/console/build.xml,v  <--  build.xml
new revision: 1.9; previous revision: 1.8
done
Checking in console/src/com/netscape/management/client/AboutDialog.java;
/cvs/dirsec/console/src/com/netscape/management/client/AboutDialog.java,v  <--
AboutDialog.java
new revision: 1.4; previous revision: 1.3
done
Checking in console/src/com/netscape/management/client/ResourceCellRenderer.java;
/cvs/dirsec/console/src/com/netscape/management/client/ResourceCellRenderer.java,v
 <--  ResourceCellRenderer.java
new revision: 1.2; previous revision: 1.1
done
Removing console/src/com/netscape/management/client/comm/Handler.java;
/cvs/dirsec/console/src/com/netscape/management/client/comm/Handler.java,v  <--
 Handler.java
new revision: delete; previous revision: 1.1.1.1
done
Checking in console/src/com/netscape/management/client/console/Console.java;
/cvs/dirsec/console/src/com/netscape/management/client/console/Console.java,v 
<--  Console.java
new revision: 1.4; previous revision: 1.3
done
Checking in
console/src/com/netscape/management/client/util/AbstractDialog.java;/cvs/dirsec/console/src/com/netscape/management/client/util/AbstractDialog.java,v
 <--  AbstractDialog.java
new revision: 1.2; previous revision: 1.1
done
Checking in console/src/com/netscape/management/nmclf/SuiLookAndFeel.java;
/cvs/dirsec/console/src/com/netscape/management/nmclf/SuiLookAndFeel.java,v  <--
 SuiLookAndFeel.java
new revision: 1.2; previous revision: 1.1
done
Checking in console/src/com/netscape/management/nmclf/SuiTreeUI.java;
/cvs/dirsec/console/src/com/netscape/management/nmclf/SuiTreeUI.java,v  <-- 
SuiTreeUI.java
new revision: 1.2; previous revision: 1.1
done
Comment 4 To Ngan 2006-12-12 19:08:35 EST
*** Bug 172345 has been marked as a duplicate of this bug. ***
Comment 5 Michael Gregg 2007-11-20 13:27:28 EST
Verified aginst:
1195521753 redhat-ds-base-8.0.0-11.el5dsrv Mon Nov 19 2007 
1195521755 redhat-ds-admin-8.0.0-1.15.el5dsrv Mon Nov 19 2007 
1195521757 redhat-ds-console-8.0.0-8.el5dsrv Mon Nov 19 2007 
1195521758 redhat-admin-console-8.0.0-9.el5dsrv Mon Nov 19 2007

Note You need to log in before you can comment on or make changes to this bug.