This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 170854 - After implementing U2 via RHN, USB flash rams are not accessible via the Gnome desktop.
After implementing U2 via RHN, USB flash rams are not accessible via the Gnom...
Status: CLOSED DUPLICATE of bug 170064
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: selinux-policy-targeted (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-14 15:26 EDT by Doug Bunger
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-17 16:22:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Doug Bunger 2005-10-14 15:26:52 EDT
Description of problem:
After implementing U2 via RHN, USB flash rams are not accessible via the Gnome
desktop.  Errors seem to indicate an SELinux permissions issue.

Version-Release number of selected component (if applicable):


How reproducible:
On an i386 system in runlevel 5 at a Gnome desktop, plug a USB flash ram into a
USB port.

Steps to Reproduce:
1.  Plug USB flash ram in a USB port.
2.  From a terminal window, execute "ls /media" to find the target directory.
3.  Attempt to access files in the target directory.
  
Actual results:
Target directory is created under /media, but data is not accessible.

Expected results:
Target directory is created under /media, files are accessible, icon is created
on the desktop.

Additional info:
[root@shadex ~]# tail -f /var/log/messages
Oct 14 15:00:22 shadex dbus: Can't send to audit system: USER_AVC pid=2377
uid=81 loginuid=-1 message=avc:  denied  { send_msg } for 
scontext=user_u:system_r:unconfined_t tcontext=user_u:system_r:initrc_t tclass=dbus
Oct 14 15:00:27 shadex dbus: Can't send to audit system: USER_AVC pid=2377
uid=81 loginuid=-1 message=avc:  denied  { send_msg } for 
scontext=user_u:system_r:unconfined_t tcontext=user_u:system_r:initrc_t tclass=dbus
Oct 14 15:00:29 shadex su(pam_unix)[7024]: session opened for user root by
dbunger(uid=500)
Oct 14 15:00:32 shadex dbus: Can't send to audit system: USER_AVC pid=2377
uid=81 loginuid=-1 message=avc:  denied  { send_msg } for 
scontext=user_u:system_r:unconfined_t tcontext=user_u:system_r:initrc_t tclass=dbus
Oct 14 15:00:57 shadex last message repeated 5 times
Oct 14 15:01:01 shadex kernel: usb 2-2: USB disconnect, address 4
Oct 14 15:01:02 shadex dbus: Can't send to audit system: USER_AVC pid=2377
uid=81 loginuid=-1 message=avc:  denied  { send_msg } for 
scontext=user_u:system_r:unconfined_t tcontext=user_u:system_r:initrc_t tclass=dbus
Oct 14 15:01:17 shadex last message repeated 3 times
Oct 14 15:01:22 shadex kernel: usb 2-1: new full speed USB device using address 5
Oct 14 15:01:22 shadex kernel: scsi2 : SCSI emulation for USB Mass Storage devices
Oct 14 15:01:22 shadex kernel:   Vendor:           Model: USB DISK 20X      Rev:
PMAP
Oct 14 15:01:22 shadex kernel:   Type:   Direct-Access                      ANSI
SCSI revision: 02
Oct 14 15:01:22 shadex dbus: Can't send to audit system: USER_AVC pid=2377
uid=81 loginuid=-1 message=avc:  denied  { send_msg } for 
scontext=user_u:system_r:unconfined_t tcontext=user_u:system_r:initrc_t tclass=dbus
Oct 14 15:01:22 shadex kernel: SCSI device sda: 985088 512-byte hdwr sectors
(504 MB)
Oct 14 15:01:22 shadex kernel: sda: Write Protect is off
Oct 14 15:01:22 shadex kernel: sda: assuming drive cache: write through
Oct 14 15:01:22 shadex kernel:  sda: sda1
Oct 14 15:01:22 shadex kernel: Attached scsi removable disk sda at scsi2,
channel 0, id 0, lun 0
Oct 14 15:01:22 shadex scsi.agent[7213]: disk at
/devices/pci0000:00/0000:00:1d.1/usb2/2-1/2-1:1.0/host2/target2:0:0/2:0:0:0
Oct 14 15:01:25 shadex fstab-sync[7300]: added mount point /media/REDHATUSB for
/dev/sda1
Oct 14 15:01:27 shadex dbus: Can't send to audit system: USER_AVC pid=2377
uid=81 loginuid=-1 message=avc:  denied  { send_msg } for 
scontext=user_u:system_r:unconfined_t tcontext=user_u:system_r:initrc_t tclass=dbus
Oct 14 15:02:02 shadex last message repeated 7 times
Oct 14 15:03:07 shadex last message repeated 13 times
Comment 1 Daniel Walsh 2005-10-17 16:22:14 EDT
Please try 

*** This bug has been marked as a duplicate of 170064 ***

Note You need to log in before you can comment on or make changes to this bug.