Bug 170873 - Blank screen instead of login screen after update
Blank screen instead of login screen after update
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-14 16:37 EDT by Noel M.
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: FC4 + updates
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-09 01:20:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
1905FP display configuration (2.79 KB, text/plain)
2005-10-26 17:51 EDT, John Jorgensen
no flags Details
copy of the dmesg output (11.19 KB, text/plain)
2005-10-29 13:01 EDT, Dave
no flags Details
lspci output (991 bytes, text/plain)
2005-10-29 13:01 EDT, Dave
no flags Details
copy of /var/log/messages (775.15 KB, text/plain)
2005-10-29 13:03 EDT, Dave
no flags Details
output from the "top" command, note X taking up 99% of cpu (4.10 KB, text/plain)
2005-10-29 13:04 EDT, Dave
no flags Details
xorg log file (47.54 KB, text/plain)
2005-10-29 13:12 EDT, Dave
no flags Details
xorg.conf configuration file (2.76 KB, text/plain)
2005-10-29 13:13 EDT, Dave
no flags Details

  None (edit)
Description Noel M. 2005-10-14 16:37:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/412.7 (KHTML, like Gecko) Safari/412.5

Description of problem:
After doing a fresh install of FC4 I did a "yum update". This updated many packages. When I reboot the 
machine, I only get as far as the screen where all the services are started. At the point where the login 
screen is supposed to start, the screen goes blank and monitor goes into sleep mode. I can still ssh to the 
machine but a "reboot" command never seems to complete. (ssh session ends, but machine never reboots)
If the older kernel is selected during boot (2.6.11 vs. 2.6.12 or 2.6.13), the problem goes away.
However, I wiped my machine and redid the install. This time I only updated the kernel and nothing else 
and again I can proceed to the login screen and everything is ok. Seems like a combination of the more 
recent kernels and something else (again, my guess is xorg pkgs)


Version-Release number of selected component (if applicable):
kernel-2.6.12+ && xorg-6.8.2-37

How reproducible:
Always

Steps to Reproduce:
1.Install Fedora Core 4 from DVD
2.Do a "yum update" and update all packages
3.reboot. 
  

Actual Results:  After updating both the kernel to 2.6.12+ and xorg to 6.8.2-37 the screen goes blank and the monitor 
goes into sleep mode instead of bringing up the login screen. All the previous steps of the boot process 
run fine. No error messages during the bootup are seen. I can still SSH into the machine, however doing a 
reboot from the command line doesn't seem to work. Only a hard reboot.

Expected Results:  Should proceed to the login screen.

Additional info:

Hardware:
ATI Radeon 7000 --> I believe this to be the culprit. Another user on the Fedora-list mailing list had the 
same problem with the same card. Changing his card caused the problem to go away.
P4 Celeron 2.2Ghz
512 MB Ram
Comment 1 John Jorgensen 2005-10-26 17:51:31 EDT
Created attachment 120435 [details]
1905FP display configuration
Comment 2 John Jorgensen 2005-10-26 17:53:28 EDT
  I have a similar problem on a Dell Dimension 4700 (Intel 915(G)) with an
analog Dell 1905FP. Ssh works, and I got the display back by commenting out
"Load dri" in the /etc/X11/xorg.conf file. This happened after the recent
(26Oct2005) updates, and I also noticed in /var/log/messages the following:

Oct 26 14:43:52 voz gdm[11514]: gdm already running. Aborting!
Oct 26 14:43:52 voz gdm[11548]: gdm already running. Aborting!
Oct 26 14:43:52 voz gdm[11582]: gdm already running. Aborting!
Oct 26 14:43:52 voz gdm[11616]: gdm already running. Aborting!

I assume that the xorg drivers are at fault.

org-x11-Mesa-libGL-6.8.2-37.FC4.49.2
xorg-x11-deprecated-libs-6.8.2-37.FC4.49.2
fonts-xorg-75dpi-6.8.2-1
fonts-xorg-ISO8859-9-100dpi-6.8.2-1
xorg-x11-xauth-6.8.2-37.FC4.49.2
xorg-x11-tools-6.8.2-37.FC4.49.2
fonts-xorg-base-6.8.2-1
xorg-x11-font-utils-6.8.2-37.FC4.49.2
xorg-x11-6.8.2-37.FC4.49.2
xorg-x11-deprecated-libs-devel-6.8.2-37.FC4.49.2
xorg-x11-Mesa-libGLU-6.8.2-37.FC4.49.2
xorg-x11-xfs-6.8.2-37.FC4.49.2
fonts-xorg-100dpi-6.8.2-1
fonts-xorg-ISO8859-9-75dpi-6.8.2-1
xorg-x11-twm-6.8.2-37.FC4.49.2
fonts-xorg-cyrillic-6.8.2-1
xorg-x11-libs-6.8.2-37.FC4.49.2
xorg-x11-devel-6.8.2-37.FC4.49.2

  I suppose that I could try to reproduce this - but I need this machine for
work. Sorry.


Comment 3 Dave 2005-10-29 12:59:09 EDT
I'm getting the same problem with a recently up2date'd machine.

This machine was working fine, no updates for two-three weeks and then following
an update (yesterday with many updates including kernel and some xorg) the
machine will no longer start X.

If I change the display driver from radeon to vesa then X starts, but it's far
slower than using the native xorg radeon driver.

The card is a radeon 9000.

I've attached a few relevant logs and config files.
Comment 4 Dave 2005-10-29 13:01:06 EDT
Created attachment 120536 [details]
copy of the dmesg output
Comment 5 Dave 2005-10-29 13:01:49 EDT
Created attachment 120537 [details]
lspci output
Comment 6 Dave 2005-10-29 13:03:51 EDT
Created attachment 120538 [details]
copy of /var/log/messages
Comment 7 Dave 2005-10-29 13:04:50 EDT
Created attachment 120539 [details]
output from the "top" command, note X taking up 99% of cpu
Comment 8 Dave 2005-10-29 13:12:51 EDT
Created attachment 120540 [details]
xorg log file
Comment 9 Dave 2005-10-29 13:13:36 EDT
Created attachment 120541 [details]
xorg.conf configuration file
Comment 10 Dave 2005-10-29 13:15:34 EDT
output from uname -a and rpm -qa | grep xorg

[root@rincewind ~]# uname -a
Linux rincewind.darkglobe.int 2.6.13-1.1532_FC4 #1 Thu Oct 20 01:30:08 EDT 2005
i686 athlon i386 GNU/Linux

[root@rincewind ~]# rpm -qa | grep xorg
xorg-x11-doc-6.8.2-37.FC4.49.2
xorg-x11-Xnest-6.8.2-37.FC4.49.2
fonts-xorg-truetype-6.8.2-1
xorg-x11-Mesa-libGL-6.8.2-37.FC4.49.2
xorg-x11-xfs-6.8.2-37.FC4.49.2
xorg-x11-Xvfb-6.8.2-37.FC4.49.2
fonts-xorg-syriac-6.8.2-1
fonts-xorg-100dpi-6.8.2-1
xorg-x11-libs-6.8.2-37.FC4.49.2
xorg-x11-Mesa-libGLU-6.8.2-37.FC4.49.2
xorg-x11-twm-6.8.2-37.FC4.49.2
fonts-xorg-base-6.8.2-1
fonts-xorg-cyrillic-6.8.2-1
fonts-xorg-ISO8859-15-100dpi-6.8.2-1
xorg-x11-font-utils-6.8.2-37.FC4.49.2
xorg-x11-deprecated-libs-6.8.2-37.FC4.49.2
xorg-x11-Xdmx-6.8.2-37.FC4.49.2
xorg-x11-xdm-6.8.2-37.FC4.49.2
fonts-xorg-ISO8859-14-75dpi-6.8.2-1
xorg-x11-6.8.2-37.FC4.49.2
xorg-x11-sdk-6.8.2-37.FC4.49.2
fonts-xorg-ISO8859-9-100dpi-6.8.2-1
xorg-x11-tools-6.8.2-37.FC4.49.2
fonts-xorg-ISO8859-15-75dpi-6.8.2-1
fonts-xorg-75dpi-6.8.2-1
fonts-xorg-ISO8859-2-100dpi-6.8.2-1
xorg-x11-deprecated-libs-devel-6.8.2-37.FC4.49.2
fonts-xorg-ISO8859-9-75dpi-6.8.2-1
fonts-xorg-ISO8859-2-75dpi-6.8.2-1
xorg-x11-devel-6.8.2-37.FC4.49.2
fonts-xorg-ISO8859-14-100dpi-6.8.2-1
xorg-x11-xauth-6.8.2-37.FC4.49.2
Comment 11 Dave 2005-10-29 13:21:52 EDT
As a last ditch effort before I left the driver set to vesa, I tried disabling
DRI, and lo and behold X came up fine... so that's helped narrow down the
problem a bit further.

Section "Module"
        Load  "dbe"
        Load  "extmod"
        Load  "fbdevhw"
        Load  "glx"
        Load  "record"
        Load  "freetype"
        Load  "type1"
#       Load  "dri"
EndSection
Comment 12 Gene Czarcinski 2005-10-31 08:56:29 EST
Interesting!  I also had problems with and an a RADEON driver when I installed
FC4 and them yum updated to development.

Then, on Friday 10/28, I finally figured out what I was doing wrong and did a
clean/fresh install of development.  It came up using the vesa driver.  After
some work on Saturday or Sunday, I determined that system-config-display was
having problems with my ATI Radeon PCIE care.  I then tried copying over the
xorg.xonf file from a working FC4 installation and, to my surprise, it worked!
Comment 13 Noel M. 2006-03-08 18:45:41 EST
I just noticed that this bug got assigned today and I wanted to add anything I can.

The problem for me went away as well when I commented out the Load "dri" line in my xorg.conf file. 
However, since then I toasted my machine and reinstalled FC4. I now use smart as my update tool. 
I totally forgot about this problem until today, and I looked at my xorg.conf file. The Load "dri" line is no 
longer commented out (it is ACTIVE) and everything works beautifully.
From uname -a
Linux pc.mydomain.com 2.6.15-1.1833_FC4 #1 Wed Mar 1 23:41:37 EST 2006 i686 i686 i386 GNU/Linux
Comment 14 Mike A. Harris 2006-03-09 01:20:58 EST
Ok thanks, closing...

Note You need to log in before you can comment on or make changes to this bug.