Bug 170881 - Installer crashed with kernel panic at various stages of install
Installer crashed with kernel panic at various stages of install
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-14 18:06 EDT by Ken Gaul
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-18 08:25:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda Crash dump (70.36 KB, text/plain)
2005-10-14 18:08 EDT, Ken Gaul
no flags Details

  None (edit)
Description Ken Gaul 2005-10-14 18:06:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
Installer usually gets as far disk partitioning or even package installation but always crashes with no oppertunity to change screen to pick up logs. I have got an anaconda dump from when it fails gracefully.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install from DVD using linux +any combination of options from above text
2.Manual partitioning using ddruid select an exisiting partition for root (format)
3.select custom/everything 
4.Hold your breath till failure
  

Actual Results:  Some form of kernel panic garbage on screen sometimes sometimes jsut a complete halt

Expected Results:  Completed install sucessfully

Additional info:

Hardware
Asus K8V-E Deluxe Athlon64 3500+
Ati Radeon X600 All-in-Wonder
80Gb IDE HD -Installation Target (hda)
200Gb SATA HD - Doesn't seem to matter if this is installed or not
Panasonic DVD+-RW(DL) installation source (hdd)
Some cheap unknown CD-R (hdc) Which I have used to install core2 to in the past
Have seen posts about partition table problems and tried to do an identical install after a failure but it doesn't seem to work
tried installer with ide=nodma barrier=no noresume apm=no noacpi nofb
still no joy. Installer fails with a white screen just after starting X if I try the Graphical installer every time. Text installer seems to be much more random about where it fails. Did manage an install once but X wouldn't start, never managed it again even following same procedure.
Comment 1 Ken Gaul 2005-10-14 18:08:26 EDT
Created attachment 120005 [details]
Anaconda Crash dump
Comment 2 Jeremy Katz 2005-10-15 11:10:59 EDT
There are errors reading your CD in the log.  Please verify your media according
to the instructions at http://rhlinux.redhat.com/anaconda/mediacheck.html.
Comment 3 Ken Gaul 2005-10-16 17:42:55 EDT
Can there be any other cause? The media check passes every time I try the install.
Is it possible to have such a minor error that won't get picked up in the check
but that virtually guarantees a failed install?
Comment 4 Ken Gaul 2005-10-17 04:42:03 EDT
OK trying another install without typing garbage in the first boot prompt gave
me (appologies for the terseness but it doesn't stay on screen long)
/dev/hda2 VFS unable to mount ... unsupported optional features (04) immediately
after choosing linux text as install option.

Next selecting the same paritioning scheme but with a the format option gives me a
"bad page state at prep_new_page (in process mke2fs, page ffff...I presume the
rest is meaningless)
trying to fix it up, but a reboot is required.
It tries to continue but doesn't install any packages and looks pretty hung to me.

I did get another install to start installing packages and left it running over
night. It kernel paniced again and all there was in the install.log was DB4
errors. Do you want me to try and get that far again and post the install.log?
Is there any way of capturing console output from the installer into a file as
I'm guessing the meaningfull bit of any stack trace is near the beginning which
scrolls off the screen to quick for me to get?
Comment 5 Ken Gaul 2005-10-18 08:25:03 EDT
OK I don't think this is an anaconda bug. I think I have a hardware problem.
Managed to get enough Windows on it to flash the BIOS and things are a little
better in that I can nearly always complete an installation. The install will
not boot afterwards with a kernel panic at some point before I log in. It
appears to be hard disk related as it is usually when trying to mount the
filesystem with CRC errors or fstab claimed to be corrupt. (Booting to rescue
the fstab looks fine?)
Running Memtest86 for now, but I'm not convinced.

Note You need to log in before you can comment on or make changes to this bug.