Bug 170913 - USB kernel Module crashes at boot
USB kernel Module crashes at boot
Status: CLOSED DUPLICATE of bug 170909
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-15 11:19 EDT by Blacklotus
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-24 23:16:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Blacklotus 2005-10-15 11:19:11 EDT
From Bugzilla Helper:
User-Agent: Opera/8.5 (X11; Linux i686; U; en)

Description of problem:
I don't know what it is, but it crashes at boot and shows this kernel log. USB 
devices which are plugged in after this aren't working, but my USB mouse which 
is already attached works.

Version-Release number of selected component (if applicable):
kernel 2.6.13-1.1526_FC4 i686

How reproducible:
Always

Steps to Reproduce:
boot the PC
  

Actual Results:  the kernel shows the log and new USB devices aren't working

Expected Results:  USB devices should be working like with kernel 2.6.12

Additional info:

usb-storage: device scan complete
Unable to handle kernel NULL pointer dereference at virtual address 00000060
 printing eip:
c020f0fb
*pde = 15950067
Oops: 0000 [#1]
Modules linked in: ipt_REJECT ipt_state ip_conntrack iptable_filter ip_tables 
vfat fat usb_storage scsi_mod dm_mod video button battery ac joydev ohci_hcd 
ehci_hcd uhci_hcd dvb_ttpci dvb_core l64781 saa7146_vv video_buf saa7146 
v4l1_compat
v4l2_common videodev ves1820 stv0299 tda8083 stv0297 sp8870 ves1x93 ttpci_eeprom 
shpchp parport_pc parport i2c_viapro i2c_core emu10k1_gp gameport snd_emu10k1 
snd_rawmidi snd_ac97_codec snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq 
snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd_page_alloc 
snd_util_mem snd_hwdep snd soundcore 8139too mii floppy ext3 jbd
CPU:    0
EIP:    0060:[<c020f0fb>]    Not tainted VLI
EFLAGS: 00010286   (2.6.13-1.1526_FC4)
EIP is at sysfs_hash_and_remove+0xe/0x106
eax: 00000000   ebx: d493af2c   ecx: 00000000   edx: c0420279
esi: d493af24   edi: d8c5bb74   ebp: d8c5bae0   esp: d7976dc0
ds: 007b   es: 007b   ss: 0068
Process khubd (pid: 67, threadinfo=d7976000 task=d7972550)
Stack: c0420279 00000000 00000246 d493af2c d493af24 d8c5bb74 d8c5bae0 c02e951d
       d8c5bb7c d493af24 d493ac00 d663b858 d4f43e00 c02e9567 d663b800 d8c44367
       d493ac00 d663b800 d663b7f8 d8c44541 d5c5d07c 00000282 d7976e4c 00000282
Call Trace:
 [<c02e951d>] class_device_del+0x98/0xda
 [<c02e9567>] class_device_unregister+0x8/0x10
 [<d8c44367>] scsi_remove_device+0x4e/0x91 [scsi_mod]
 [<d8c44541>] __scsi_remove_target+0x197/0x56c [scsi_mod]
 [<d8c43134>] scsi_forget_host+0x149/0x4e1 [scsi_mod]
 [<c03ff867>] wait_for_completion+0x1f/0x52d
 [<d8c37c06>] scsi_remove_host+0x9/0x4b [scsi_mod]
 [<d8bdf168>] storage_disconnect+0x64/0x7e [usb_storage]
 [<c0332b18>] usb_unbind_interface+0x34/0x60
 [<c02e853a>] __device_release_driver+0x4c/0x64
 [<c02e857c>] device_release_driver+0x2a/0x38
 [<c02e7ef1>] bus_remove_device+0x52/0x60
 [<c02e73a0>] device_del+0x2b/0x5b
 [<c033efda>] usb_disable_device+0xbb/0x108
 [<c0335bfb>] usb_disconnect+0xaa/0x3b8
 [<c0336d6a>] hub_port_connect_change+0x51/0x857
 [<c0337a3e>] hub_events+0x4ce/0x764
 [<c0337cd4>] hub_thread+0x0/0xe2
 [<c0337ce8>] hub_thread+0x14/0xe2
 [<c01519c2>] autoremove_wake_function+0x0/0x37
 [<c01508ab>] kthread+0x87/0x8b
 [<c0150824>] kthread+0x0/0x8b
 [<c01012ed>] kernel_thread_helper+0x5/0xb
Code: 0c c7 44 24 08 d8 00 00 00 c7 44 24 04 95 8d 41 c0 c7 04 24 e8 f5 40 c0 e8 
76 8a f1 ff 55 57 56 53 83 ec 0c 89 44 24 04 89 14 24 <8b> 70 60 8b 58 20 85 db 
0f 84 87 00 00 00 ba 66 00 00 00 b8 90
Comment 1 Alexandre Oliva 2005-10-24 23:16:08 EDT

*** This bug has been marked as a duplicate of 170909 ***

Note You need to log in before you can comment on or make changes to this bug.