Bug 1709521 - FreeCAD crashes during startup
Summary: FreeCAD crashes during startup
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: freecad
Version: 30
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Shaw
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-13 18:15 UTC by Vaclav "sHINOBI" Misek
Modified: 2019-05-29 02:59 UTC (History)
4 users (show)

Fixed In Version: freecad-0.18.2-3.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-29 02:59:20 UTC
Type: Bug


Attachments (Terms of Use)

Description Vaclav "sHINOBI" Misek 2019-05-13 18:15:59 UTC
Description of problem:
freecad segfaults on startup

Version-Release number of selected component (if applicable):
freecad-0.18.2-1


Steps to Reproduce:
1. run FreeCAD



Actual results:
$ FreeCAD
FreeCAD 0.18, Libs: 0.18RUnknown
© Juergen Riegel, Werner Mayer, Yorik van Havre 2001-2019
  #####                 ####  ###   ####  
  #                    #      # #   #   # 
  #     ##  #### ####  #     #   #  #   # 
  ####  # # #  # #  #  #     #####  #   # 
  #     #   #### ####  #    #     # #   # 
  #     #   #    #     #    #     # #   #  ##  ##  ##
  #     #   #### ####   ### #     # ####   ##  ##  ##


Program received signal SIGSEGV, Segmentation fault.
#0  /lib64/libc.so.6(+0x37f40) [0x7fec84a6ef40]
#1  /lib64/libpython2.7.so.1.0(Py_InitModule4_64+0x42) [0x7fec7e00ce42]
#2  /usr/lib64/python3.7/site-packages/PySide/QtCore.so(PyInit_QtCore+0x51) [0x7fec4da939c1]
#3  /lib64/libpython3.7m.so.1.0(_PyImport_LoadDynamicModuleWithSpec+0x17f) [0x7fec8600634f]
#4  /lib64/libpython3.7m.so.1.0(+0x20865f) [0x7fec8600665f]
#5  /lib64/libpython3.7m.so.1.0(_PyMethodDef_RawFastCallDict+0x2d5) [0x7fec85f10445]
#6  /lib64/libpython3.7m.so.1.0(_PyCFunction_FastCallDict+0x23) [0x7fec85f10573]
#7  /lib64/libpython3.7m.so.1.0(_PyEval_EvalFrameDefault+0x6846) [0x7fec85f8c836]
#8  /lib64/libpython3.7m.so.1.0(_PyEval_EvalCodeWithName+0x2f0) [0x7fec85f35000]
#9  /lib64/libpython3.7m.so.1.0(_PyFunction_FastCallKeywords+0x2a2) [0x7fec85f36022]
#10  /lib64/libpython3.7m.so.1.0(+0x14af4f) [0x7fec85f48f4f]
#11  /lib64/libpython3.7m.so.1.0(_PyEval_EvalFrameDefault+0x58c2) [0x7fec85f8b8b2]
#12  /lib64/libpython3.7m.so.1.0(_PyFunction_FastCallKeywords+0x102) [0x7fec85f35e82]
#13  /lib64/libpython3.7m.so.1.0(+0x14af4f) [0x7fec85f48f4f]
#14  /lib64/libpython3.7m.so.1.0(_PyEval_EvalFrameDefault+0xaf5) [0x7fec85f86ae5]
#15  /lib64/libpython3.7m.so.1.0(_PyFunction_FastCallKeywords+0x102) [0x7fec85f35e82]
#16  /lib64/libpython3.7m.so.1.0(+0x14af4f) [0x7fec85f48f4f]
#17  /lib64/libpython3.7m.so.1.0(_PyEval_EvalFrameDefault+0xa50) [0x7fec85f86a40]
#18  /lib64/libpython3.7m.so.1.0(_PyFunction_FastCallKeywords+0x102) [0x7fec85f35e82]
#19  /lib64/libpython3.7m.so.1.0(+0x14af4f) [0x7fec85f48f4f]
#20  /lib64/libpython3.7m.so.1.0(_PyEval_EvalFrameDefault+0xa50) [0x7fec85f86a40]
#21  /lib64/libpython3.7m.so.1.0(_PyFunction_FastCallKeywords+0x102) [0x7fec85f35e82]
#22  /lib64/libpython3.7m.so.1.0(+0x14af4f) [0x7fec85f48f4f]
#23  /lib64/libpython3.7m.so.1.0(_PyEval_EvalFrameDefault+0xa50) [0x7fec85f86a40]
#24  /lib64/libpython3.7m.so.1.0(_PyFunction_FastCallDict+0x11a) [0x7fec85f364ea]
#25  /lib64/libpython3.7m.so.1.0(+0x1113a7) [0x7fec85f0f3a7]
#26  /lib64/libpython3.7m.so.1.0(_PyObject_CallMethodIdObjArgs+0xb9) [0x7fec85f317c9]
#27  /lib64/libpython3.7m.so.1.0(PyImport_ImportModuleLevelObject+0x29b) [0x7fec85f6345b]
#28  /lib64/libpython3.7m.so.1.0(+0x165ac8) [0x7fec85f63ac8]
#29  /lib64/libpython3.7m.so.1.0(PyCFunction_Call+0x7f) [0x7fec85f1060f]
#30  /lib64/libpython3.7m.so.1.0(_PyEval_EvalFrameDefault+0x6846) [0x7fec85f8c836]
#31  /lib64/libpython3.7m.so.1.0(_PyEval_EvalCodeWithName+0x2f0) [0x7fec85f35000]
#32  /lib64/libpython3.7m.so.1.0(_PyFunction_FastCallKeywords+0x2a2) [0x7fec85f36022]
#33  /lib64/libpython3.7m.so.1.0(+0x14af4f) [0x7fec85f48f4f]
#34  /lib64/libpython3.7m.so.1.0(_PyEval_EvalFrameDefault+0xa50) [0x7fec85f86a40]
#35  /lib64/libpython3.7m.so.1.0(_PyEval_EvalCodeWithName+0x2f0) [0x7fec85f35000]
#36  /lib64/libpython3.7m.so.1.0(_PyFunction_FastCallDict+0x2ee) [0x7fec85f366be]
#37  /lib64/libpython3.7m.so.1.0(+0x1113a7) [0x7fec85f0f3a7]
#38  /lib64/libpython3.7m.so.1.0(_PyObject_CallMethodIdObjArgs+0xb9) [0x7fec85f317c9]
#39  /lib64/libpython3.7m.so.1.0(PyImport_ImportModuleLevelObject+0x1f2) [0x7fec85f633b2]
#40  /lib64/libpython3.7m.so.1.0(_PyEval_EvalFrameDefault+0x317c) [0x7fec85f8916c]
#41  /lib64/libpython3.7m.so.1.0(_PyFunction_FastCallKeywords+0x102) [0x7fec85f35e82]
#42  /lib64/libpython3.7m.so.1.0(+0x14af4f) [0x7fec85f48f4f]
#43  /lib64/libpython3.7m.so.1.0(_PyEval_EvalFrameDefault+0x58c2) [0x7fec85f8b8b2]
#44  /lib64/libpython3.7m.so.1.0(_PyFunction_FastCallKeywords+0x102) [0x7fec85f35e82]
#45  /lib64/libpython3.7m.so.1.0(+0x14af4f) [0x7fec85f48f4f]
#46  /lib64/libpython3.7m.so.1.0(_PyEval_EvalFrameDefault+0xa50) [0x7fec85f86a40]
#47  /lib64/libpython3.7m.so.1.0(_PyEval_EvalCodeWithName+0x2f0) [0x7fec85f35000]
#48  /lib64/libpython3.7m.so.1.0(PyEval_EvalCodeEx+0x39) [0x7fec85f35d59]
#49  /lib64/libpython3.7m.so.1.0(PyEval_EvalCode+0x1b) [0x7fec85f35d7b]
#50  /lib64/libpython3.7m.so.1.0(+0x183094) [0x7fec85f81094]
#51  /lib64/libpython3.7m.so.1.0(_PyMethodDef_RawFastCallDict+0x2d5) [0x7fec85f10445]
#52  /lib64/libpython3.7m.so.1.0(_PyCFunction_FastCallDict+0x23) [0x7fec85f10573]
#53  /lib64/libpython3.7m.so.1.0(_PyEval_EvalFrameDefault+0x6846) [0x7fec85f8c836]
#54  /lib64/libpython3.7m.so.1.0(_PyEval_EvalCodeWithName+0x2f0) [0x7fec85f35000]
#55  /lib64/libpython3.7m.so.1.0(_PyFunction_FastCallKeywords+0x2a2) [0x7fec85f36022]
#56  /lib64/libpython3.7m.so.1.0(+0x14af4f) [0x7fec85f48f4f]
#57  /lib64/libpython3.7m.so.1.0(_PyEval_EvalFrameDefault+0x58c2) [0x7fec85f8b8b2]
#58  /lib64/libpython3.7m.so.1.0(_PyFunction_FastCallKeywords+0x102) [0x7fec85f35e82]
#59  /lib64/libpython3.7m.so.1.0(+0x14af4f) [0x7fec85f48f4f]
#60  /lib64/libpython3.7m.so.1.0(_PyEval_EvalFrameDefault+0xaf5) [0x7fec85f86ae5]
#61  /lib64/libpython3.7m.so.1.0(_PyFunction_FastCallKeywords+0x102) [0x7fec85f35e82]
#62  /lib64/libpython3.7m.so.1.0(+0x14af4f) [0x7fec85f48f4f]
#63  /lib64/libpython3.7m.so.1.0(_PyEval_EvalFrameDefault+0xa50) [0x7fec85f86a40]
#64  /lib64/libpython3.7m.so.1.0(_PyFunction_FastCallKeywords+0x102) [0x7fec85f35e82]
#65  /lib64/libpython3.7m.so.1.0(+0x14af4f) [0x7fec85f48f4f]
#66  /lib64/libpython3.7m.so.1.0(_PyEval_EvalFrameDefault+0xa50) [0x7fec85f86a40]
#67  /lib64/libpython3.7m.so.1.0(_PyFunction_FastCallDict+0x11a) [0x7fec85f364ea]
#68  /lib64/libpython3.7m.so.1.0(+0x1113a7) [0x7fec85f0f3a7]
#69  /lib64/libpython3.7m.so.1.0(_PyObject_CallMethodIdObjArgs+0xb9) [0x7fec85f317c9]
#70  /lib64/libpython3.7m.so.1.0(PyImport_ImportModuleLevelObject+0x29b) [0x7fec85f6345b]
#71  /lib64/libpython3.7m.so.1.0(_PyEval_EvalFrameDefault+0x317c) [0x7fec85f8916c]
#72  /lib64/libpython3.7m.so.1.0(_PyEval_EvalCodeWithName+0x2f0) [0x7fec85f35000]
#73  /lib64/libpython3.7m.so.1.0(PyEval_EvalCodeEx+0x39) [0x7fec85f35d59]
#74  /lib64/libpython3.7m.so.1.0(PyEval_EvalCode+0x1b) [0x7fec85f35d7b]
#75  /lib64/libpython3.7m.so.1.0(+0x183094) [0x7fec85f81094]
#76  /lib64/libpython3.7m.so.1.0(_PyMethodDef_RawFastCallDict+0x2d5) [0x7fec85f10445]
#77  /lib64/libpython3.7m.so.1.0(_PyCFunction_FastCallDict+0x23) [0x7fec85f10573]
#78  /lib64/libpython3.7m.so.1.0(_PyEval_EvalFrameDefault+0x6846) [0x7fec85f8c836]
#79  /lib64/libpython3.7m.so.1.0(_PyEval_EvalCodeWithName+0x2f0) [0x7fec85f35000]
#80  /lib64/libpython3.7m.so.1.0(_PyFunction_FastCallKeywords+0x2a2) [0x7fec85f36022]
#81  /lib64/libpython3.7m.so.1.0(+0x14af4f) [0x7fec85f48f4f]
#82  /lib64/libpython3.7m.so.1.0(_PyEval_EvalFrameDefault+0x58c2) [0x7fec85f8b8b2]
#83  /lib64/libpython3.7m.so.1.0(_PyFunction_FastCallKeywords+0x102) [0x7fec85f35e82]
#84  /lib64/libpython3.7m.so.1.0(+0x14af4f) [0x7fec85f48f4f]
#85  /lib64/libpython3.7m.so.1.0(_PyEval_EvalFrameDefault+0xaf5) [0x7fec85f86ae5]
#86  /lib64/libpython3.7m.so.1.0(_PyFunction_FastCallKeywords+0x102) [0x7fec85f35e82]
#87  /lib64/libpython3.7m.so.1.0(+0x14af4f) [0x7fec85f48f4f]
#88  /lib64/libpython3.7m.so.1.0(_PyEval_EvalFrameDefault+0xa50) [0x7fec85f86a40]
#89  /lib64/libpython3.7m.so.1.0(_PyFunction_FastCallKeywords+0x102) [0x7fec85f35e82]
#90  /lib64/libpython3.7m.so.1.0(+0x14af4f) [0x7fec85f48f4f]
#91  /lib64/libpython3.7m.so.1.0(_PyEval_EvalFrameDefault+0xa50) [0x7fec85f86a40]
#92  /lib64/libpython3.7m.so.1.0(_PyFunction_FastCallDict+0x11a) [0x7fec85f364ea]
#93  /lib64/libpython3.7m.so.1.0(+0x1113a7) [0x7fec85f0f3a7]
#94  /lib64/libpython3.7m.so.1.0(_PyObject_CallMethodIdObjArgs+0xb9) [0x7fec85f317c9]
#95  /lib64/libpython3.7m.so.1.0(PyImport_ImportModuleLevelObject+0x29b) [0x7fec85f6345b]
#96  /lib64/libpython3.7m.so.1.0(_PyEval_EvalFrameDefault+0x317c) [0x7fec85f8916c]
#97  /lib64/libpython3.7m.so.1.0(_PyEval_EvalCodeWithName+0x2f0) [0x7fec85f35000]
#98  /lib64/libpython3.7m.so.1.0(PyEval_EvalCodeEx+0x39) [0x7fec85f35d59]
#99  /lib64/libpython3.7m.so.1.0(PyEval_EvalCode+0x1b) [0x7fec85f35d7b]
#100  /lib64/libpython3.7m.so.1.0(+0x204093) [0x7fec86002093]
#101  /lib64/libpython3.7m.so.1.0(PyRun_StringFlags+0x7d) [0x7fec8600212d]
#102  /lib64/libpython3.7m.so.1.0(+0x18312b) [0x7fec85f8112b]
#103  /lib64/libpython3.7m.so.1.0(_PyMethodDef_RawFastCallKeywords+0x78) [0x7fec85f10748]
#104  /lib64/libpython3.7m.so.1.0(_PyCFunction_FastCallKeywords+0x23) [0x7fec85f10a63]
#105  /lib64/libpython3.7m.so.1.0(+0x14b063) [0x7fec85f49063]
#106  /lib64/libpython3.7m.so.1.0(_PyEval_EvalFrameDefault+0xa50) [0x7fec85f86a40]
#107  /lib64/libpython3.7m.so.1.0(_PyFunction_FastCallKeywords+0x102) [0x7fec85f35e82]
#108  /lib64/libpython3.7m.so.1.0(+0x14af4f) [0x7fec85f48f4f]
#109  /lib64/libpython3.7m.so.1.0(_PyEval_EvalFrameDefault+0xa50) [0x7fec85f86a40]
#110  /lib64/libpython3.7m.so.1.0(_PyEval_EvalCodeWithName+0x2f0) [0x7fec85f35000]
#111  /lib64/libpython3.7m.so.1.0(PyEval_EvalCodeEx+0x39) [0x7fec85f35d59]
#112  /lib64/libpython3.7m.so.1.0(PyEval_EvalCode+0x1b) [0x7fec85f35d7b]
#113  /lib64/libpython3.7m.so.1.0(+0x204093) [0x7fec86002093]
#114  /lib64/libpython3.7m.so.1.0(PyRun_StringFlags+0x7d) [0x7fec8600212d]
#115  0x7fec8631366e in Base::InterpreterSingleton::runString[abi:cxx11](char const*) from /usr/lib64/freecad/lib/libFreeCADBase.so+0xd8
#116  0x7fec8791584f in Gui::Application::runInitGuiScript() from /usr/lib64/freecad/lib/libFreeCADGui.so+0x37
#117  0x7fec87917403 in Gui::Application::runApplication() from /usr/lib64/freecad/lib/libFreeCADGui.so+0x1b9f
#118  FreeCAD(main+0xa17) [0x408033]
#119  /lib64/libc.so.6(__libc_start_main+0xf3) [0x7fec84a5af33]
#120  FreeCAD(_start+0x2e) [0x4074ee]

Comment 1 Alain V. 2019-05-18 07:36:25 UTC
I confirm the same problem.

$ FreeCAD
Program received signal SIGSEGV, Segmentation fault.

Comment 2 Richard Shaw 2019-05-19 12:26:56 UTC
It looks like Python 2 is still sneaking into the build somehow...

Comment 3 Richard Shaw 2019-05-19 22:59:37 UTC
Ok, so the python2 package of shiboken was being pulled in. I think I have it fixed and new builds going.

Comment 4 Fedora Update System 2019-05-20 20:32:40 UTC
freecad-0.18.2-3.fc29 python-pivy-0.6.5-0.1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-d8deac72f7

Comment 5 Fedora Update System 2019-05-20 20:32:45 UTC
freecad-0.18.2-3.fc29 python-pivy-0.6.5-0.1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-d8deac72f7

Comment 6 Richard Shaw 2019-05-20 20:35:51 UTC
Ok, please try the new builds when they get pushed to testing.

I went ahead and switched shiboken to be python3 by default instead of python2 in Rawhide and F30. The cmake config was defaulted to python2 and it was a PITA to make it pick the python3 config.

Comment 7 Fedora Update System 2019-05-21 04:53:20 UTC
freecad-0.18.2-3.fc29, python-pivy-0.6.5-0.1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-d8deac72f7

Comment 8 Richard Shaw 2019-05-21 12:20:53 UTC
Just tested the update and I can't get it to crash

Comment 9 Alain V. 2019-05-21 16:57:45 UTC
Yes, better, but I still have 
RuntimeError: Can't find converter for 'onStart7f07c9f5bd90()' to call Python meta method.
RuntimeError: Can't find converter for 'setCurrent7f07c9f5bae8()' to call Python meta method.
...
When running, 

and, after File->Exit

Program received signal SIGSEGV, Segmentation fault.
#0  /lib64/libc.so.6(+0x37f40) [0x7f07dc711f40]
#1  /lib64/libc.so.6(+0x15b9ac) [0x7f07dc8359ac]
#2  /lib64/libpyside.cpython-37m-x86_64-linux-gnu.so.1.2(+0x15d82) [0x7f07c9b62d82]
#3  0x7f07dcc7e70a in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) from /lib64/libQtCore.so.4+0x3da
#4  0x7f07dcc7f0a3 in QObject::destroyed(QObject*) from /lib64/libQtCore.so.4+0x43
#5  0x7f07dcc83a65 in QObject::~QObject() from /lib64/libQtCore.so.4+0xb5
#6  0x7f07dd074267 in QAction::~QAction() from /lib64/libQtGui.so.4+0x1c7
#7  /usr/lib64/python3.7/site-packages/PySide/QtGui.so(+0x27d19d) [0x7f07c910119d]
#8  0x7f07dcc82a54 in QObjectPrivate::deleteChildren() from /lib64/libQtCore.so.4+0x84
#9  0x7f07dd0d0379 in QWidget::~QWidget() from /lib64/libQtGui.so.4+0x349
#10  /usr/lib64/python3.7/site-packages/PySide/QtGui.so(+0x5537ad) [0x7f07c93d77ad]
#11  0x7f07dcc82a54 in QObjectPrivate::deleteChildren() from /lib64/libQtCore.so.4+0x84
#12  0x7f07dd0d0379 in QWidget::~QWidget() from /lib64/libQtGui.so.4+0x349
#13  /usr/lib64/python3.7/site-packages/PySide/QtGui.so(+0x5537ad) [0x7f07c93d77ad]
#14  0x7f07dcc82a54 in QObjectPrivate::deleteChildren() from /lib64/libQtCore.so.4+0x84
#15  0x7f07dd0d0379 in QWidget::~QWidget() from /lib64/libQtGui.so.4+0x349
#16  /usr/lib64/python3.7/site-packages/PySide/QtGui.so(+0x604a6d) [0x7f07c9488a6d]
#17  0x7f07dcc82a54 in QObjectPrivate::deleteChildren() from /lib64/libQtCore.so.4+0x84
#18  0x7f07dd0d0379 in QWidget::~QWidget() from /lib64/libQtGui.so.4+0x349
#19  0x7f07dd4d5d33 in QStatusBar::~QStatusBar() from /lib64/libQtGui.so.4+0x13
#20  0x7f07dcc82a54 in QObjectPrivate::deleteChildren() from /lib64/libQtCore.so.4+0x84
#21  0x7f07dd0d0379 in QWidget::~QWidget() from /lib64/libQtGui.so.4+0x349
#22  0x7f07df9e6396 in Gui::MainWindow::~MainWindow() from /usr/lib64/freecad/lib/libFreeCADGui.so+0x8c
#23  0x7f07df58fe56 in Gui::Application::runApplication() from /usr/lib64/freecad/lib/libFreeCADGui.so+0x25f2
#24  FreeCAD(main+0xa17) [0x408033]
#25  /lib64/libc.so.6(__libc_start_main+0xf3) [0x7f07dc6fdf33]
#26  FreeCAD(_start+0x2e) [0x4074ee]

Comment 10 Richard Shaw 2019-05-21 18:11:15 UTC
Are you on F30? My tests were on F29.

Comment 11 Alain V. 2019-05-21 20:35:22 UTC
Yes, sorry. F30.
Did you expect it will also fix the problem for Fedora 30 ?

Comment 12 Vaclav "sHINOBI" Misek 2019-05-21 21:17:59 UTC
For me under F30 it starts without errors with freecad-0.18.2-3.fc30.x86_64, but I can see seqfault when I exit FreeCAD.

Program received signal SIGSEGV, Segmentation fault.
#0  /lib64/libc.so.6(+0x37f40) [0x7f2dbb66ef40]
#1  /lib64/libc.so.6(+0x15b9ac) [0x7f2dbb7929ac]
#2  /lib64/libpyside.cpython-37m-x86_64-linux-gnu.so.1.2(+0x15d82) [0x7f2da403cd82]
#3  0x7f2dbbbdd70a in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) from /lib64/libQtCore.so.4+0x3da
#4  0x7f2dbbbde0a3 in QObject::destroyed(QObject*) from /lib64/libQtCore.so.4+0x43
#5  0x7f2dbbbe2a65 in QObject::~QObject() from /lib64/libQtCore.so.4+0xb5
#6  0x7f2dbbfd3267 in QAction::~QAction() from /lib64/libQtGui.so.4+0x1c7
#7  /usr/lib64/python3.7/site-packages/PySide/QtGui.so(+0x27d19d) [0x7f2d6b36619d]
#8  0x7f2dbbbe1a54 in QObjectPrivate::deleteChildren() from /lib64/libQtCore.so.4+0x84
#9  0x7f2dbc02f379 in QWidget::~QWidget() from /lib64/libQtGui.so.4+0x349
#10  /usr/lib64/python3.7/site-packages/PySide/QtGui.so(+0x5537ad) [0x7f2d6b63c7ad]
#11  0x7f2dbbbe1a54 in QObjectPrivate::deleteChildren() from /lib64/libQtCore.so.4+0x84
#12  0x7f2dbc02f379 in QWidget::~QWidget() from /lib64/libQtGui.so.4+0x349
#13  /usr/lib64/python3.7/site-packages/PySide/QtGui.so(+0x5537ad) [0x7f2d6b63c7ad]
#14  0x7f2dbbbe1a54 in QObjectPrivate::deleteChildren() from /lib64/libQtCore.so.4+0x84
#15  0x7f2dbc02f379 in QWidget::~QWidget() from /lib64/libQtGui.so.4+0x349
#16  /usr/lib64/python3.7/site-packages/PySide/QtGui.so(+0x604a6d) [0x7f2d6b6eda6d]
#17  0x7f2dbbbe1a54 in QObjectPrivate::deleteChildren() from /lib64/libQtCore.so.4+0x84
#18  0x7f2dbc02f379 in QWidget::~QWidget() from /lib64/libQtGui.so.4+0x349
#19  0x7f2dbc434d33 in QStatusBar::~QStatusBar() from /lib64/libQtGui.so.4+0x13
#20  0x7f2dbbbe1a54 in QObjectPrivate::deleteChildren() from /lib64/libQtCore.so.4+0x84
#21  0x7f2dbc02f379 in QWidget::~QWidget() from /lib64/libQtGui.so.4+0x349
#22  0x7f2dbe96e396 in Gui::MainWindow::~MainWindow() from /usr/lib64/freecad/lib/libFreeCADGui.so+0x8c
#23  0x7f2dbe517e56 in Gui::Application::runApplication() from /usr/lib64/freecad/lib/libFreeCADGui.so+0x25f2
#24  FreeCAD(main+0xa17) [0x408033]
#25  /lib64/libc.so.6(__libc_start_main+0xf3) [0x7f2dbb65af33]
#26  FreeCAD(_start+0x2e) [0x4074ee]

Comment 13 Richard Shaw 2019-05-22 02:18:03 UTC
F29 through Rawhide are all on the same version of PySide, so unless it's some obscure gcc 9 bug (or change) I'm not sure where to look. I could try doing a scratch build of PySide if you're willing to install and test it.

Comment 14 Richard Shaw 2019-05-22 15:42:07 UTC
Ok, I have completed a simple rebuild of python-pyside (at least for x86_64 and i686 at this time). If you would please download python3-pyside (hopefully it will update without forcing you to download other packages) and test FreeCAD again.

https://koji.fedoraproject.org/koji/taskinfo?taskID=34996238

Comment 15 Vaclav "sHINOBI" Misek 2019-05-22 22:13:53 UTC
With python3-pyside-1.2.4-8.fc30 it looks perfect for me. Thank you.

Comment 16 Richard Shaw 2019-05-22 22:18:12 UTC
Awesome. I’ll do real builds as soon as I can.

Comment 17 Fedora Update System 2019-05-29 02:59:20 UTC
freecad-0.18.2-3.fc29, python-pivy-0.6.5-0.1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.