Bug 170955 - logrotate segfaults
logrotate segfaults
Status: CLOSED DUPLICATE of bug 170904
Product: Fedora
Classification: Fedora
Component: logrotate (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-16 03:05 EDT by Lars G
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-17 02:59:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lars G 2005-10-16 03:05:08 EDT
cron keeps telling:

/etc/cron.daily/logrotate:
/etc/cron.daily/logrotate: line 3:  3004 Segmentation fault     
/usr/sbin/logrotate /etc/logrotate.conf

this is with logrotate-3.7.2-6
Comment 1 Robert Scheck 2005-10-16 06:16:50 EDT
Confirming the same problem, strace output follows:

stat64("/var/log/cron", {st_mode=S_IFREG|0600, st_size=16045, ...}) = 0
stat64("/var/log/yum.log", {st_mode=S_IFREG|0644, st_size=0, ...}) = 0
stat64("/var/log/wtmp", {st_mode=S_IFREG|0664, st_size=792576, ...}) = 0
open("/var/lib/logrotate.status", O_WRONLY|O_CREAT|O_TRUNC|O_LARGEFILE, 0666) = 
3
fstat64(3, {st_mode=S_IFREG|0644, st_size=0, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 
0xb7f53000
write(3, "logrotate state -- version 2\n\"/v"..., 1012) = 1012
close(3)                                = 0
munmap(0xb7f53000, 4096)                = 0
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++
Comment 2 Peter Vrabec 2005-10-17 02:55:57 EDT
fixed in logrotate-3.7.2-7
Comment 3 Peter Vrabec 2005-10-17 02:59:49 EDT

*** This bug has been marked as a duplicate of 170904 ***

Note You need to log in before you can comment on or make changes to this bug.