This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 170956 - Incompatibility between installation defaults and lvm capabilities
Incompatibility between installation defaults and lvm capabilities
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alasdair Kergon
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-16 06:55 EDT by bob mckay
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: FC5
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-30 04:15:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description bob mckay 2005-10-16 06:55:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/412.7 (KHTML, like Gecko) Safari/412.5

Description of problem:
The default installation procedures for core 4 use the whole disk for a single logical volume; this is 
extremely difficult to subsequently change, way beyond the level of users who choose the default 
installation. If the defaults are to continue to use the whole disk (however structured) then users need 
to have usable tools (ie not requiring high-level expertise) to shrink logical volumes - as nice for 
shrinking as the lvm manager currently is for expanding. I realise this is a big ask - however _that_ 
knowledge needs to feed back into the decisions on how to structure the default volume structure, and 
how to document it.

Related bugs:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=170482
this has been marked as a duplicate of 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=150670
however I believe it is actually a separate (though obviously related) issue

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=170728

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Set up the system using the default volume assignment
2. Attempt to change it subsequently
3.
  

Actual Results:  Installation created an inflexible volume structure, requiring too much expertise to fix (and far too 
dangerous for beginner users to adapt). The LVM manager GUI was unable to assist.

Expected Results:  Ideally, the LVM manager GUI would be able to shrink logical volumes (I realise this probalby isn't going to 
happen anytime soon).

Additional info:

Note You need to log in before you can comment on or make changes to this bug.