Bug 170989 - font not available when used with pdf application
font not available when used with pdf application
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xpdf (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Mike McLean
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-17 00:49 EDT by Lawrence Lim
Modified: 2014-03-25 20:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-09 06:22:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pdf file with TC content (207.11 KB, application/pdf)
2005-10-17 00:49 EDT, Lawrence Lim
no flags Details
strace from evince (1.00 MB, text/plain)
2005-10-17 00:50 EDT, Lawrence Lim
no flags Details
strace from xpdf (201.73 KB, text/plain)
2005-10-17 00:52 EDT, Lawrence Lim
no flags Details
patch for simplified (512 bytes, patch)
2005-11-09 01:31 EST, Akira TAGOH
no flags Details | Diff
patch for traditional (531 bytes, patch)
2005-11-09 01:32 EST, Akira TAGOH
no flags Details | Diff

  None (edit)
Description Lawrence Lim 2005-10-17 00:49:05 EDT
Description of problem:
Tried to read a few pdf documents from the web with TC using evince and xpdf,
both application were not able to display the information properly.

Version-Release number of selected component (if applicable):
taipeifonts-1.2-26
fonts-chinese-3.00.pre2-1
evince-0.4.0-2

How reproducible:
Always

Steps to Reproduce:
1.try to open the supplied file with evince or xpdf
2.
3.
  
Actual results:
scrambled text

Expected results:
display the content properly

Additional info:
pdf files are random files obtained from the web using google.
Comment 1 Lawrence Lim 2005-10-17 00:49:06 EDT
Created attachment 120039 [details]
pdf file with TC content
Comment 2 Lawrence Lim 2005-10-17 00:50:56 EDT
Created attachment 120040 [details]
strace from evince
Comment 3 Lawrence Lim 2005-10-17 00:52:34 EDT
Created attachment 120041 [details]
strace from xpdf
Comment 4 Lawrence Lim 2005-10-17 02:15:37 EDT
Adding the new entries into font.conf as suggested in Bug 165939 did not fix the
issue.
Comment 5 Leon Ho 2005-11-08 00:33:24 EST
I guess it is because of the ghostscript filename is not correct. please try now.
Comment 6 Lawrence Lim 2005-11-08 01:05:12 EST
Which packages needs update to complete the testing?? Only
fonts-chinese-3.00.pre2-1??
Comment 7 Akira TAGOH 2005-11-08 08:19:12 EST
perhaps this should be reassigned to xpdf since we had a new chinese fonts and
/usr/share/xpdf/chinese-{simplified,traditional}/add-to-xpdfrc has to be
modified anyway.
Than, can you update them for new Chinese fonts? although I can make a patch for
them, simply you can replace bsmi00lp.ttf and gbsn00lp.ttf to uming.ttf so that
new Chinese fonts are integrated for both of Simplified/Traditional Chinese fonts.
Comment 8 Lawrence Lim 2005-11-08 23:48:15 EST
Re #Comment #5

Updating to latest fonts-chinese pkg does not help for evince and xpdf.
Comment 9 Akira TAGOH 2005-11-09 01:32:00 EST
Created attachment 120835 [details]
patch for simplified
Comment 10 Akira TAGOH 2005-11-09 01:32:36 EST
Created attachment 120836 [details]
patch for traditional
Comment 11 Leon Ho 2005-11-09 01:34:33 EST
Comment #8:
fonts-chinese-3.00.pre2-1 is not the updated one. fonts-chinese-3.01-2 is.
Comment 12 Lawrence Lim 2005-11-09 01:54:03 EST
Re: Comment #11
Yup. That was the package used.

# rpm -q fonts-chinese
fonts-chinese-3.01-2
Comment 13 Ngo Than 2005-11-09 06:16:03 EST
Akira, are bsmi00lp.ttf and gbsn00lp.ttf now removed in the new fonts-chinese
package? and the replacement for that is uming.ttf ?
Comment 14 Ngo Than 2005-11-09 06:22:43 EST
there's a new xpdf package in rawhide which fixes this problem. Thanks
Comment 15 Akira TAGOH 2005-11-09 06:42:19 EST
Comment #13:
Yes, that's right. uming.ttf is a new Chinese font, which replaced
{bsmi,gbsn}00lp.ttf.

Note You need to log in before you can comment on or make changes to this bug.