Bug 171001 - Can't finish into Runlevel 3 from RunLevel 5 in RH4U2
Can't finish into Runlevel 3 from RunLevel 5 in RH4U2
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anacron (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-17 06:02 EDT by Tung Ying Chang
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-27 13:41:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tung Ying Chang 2005-10-17 06:02:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)

Description of problem:
We use RH4U2 in X-widnows mode. Then open termal windows to run "init 3" . The system hung up in aracorn services . But we use into Runlevel 3 after booting RH4U2 . Then into Runlevel 5 . Next into Runlevel 3 . It is ok .

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot into Redhat X-windows mode 
2. Open termial windows
3. Run init 3
4. The system will hung up in "aracron" serives .
  

Additional info:
Comment 1 Nils Philippsen 2006-03-07 03:41:21 EST
If it hangs in anacron, it most likely isn't a system-config-services bug.
Comment 2 Jason Vas Dias 2006-03-09 11:26:26 EST
There have been several reports of this problem before:
Bug 145716 - init 3 freezes at anacron program
Bug 112015 - runlevel 5 to 3 swithcing - ok till starting anacron 
             - system seemingly hangs

But this has always turned out to be simply because anacron is the last 
service to be checked for startup in runlevel 3, and because no 'login:'
prompt is printed in the VT until you actually press <RETURN> .

You should get a login: prompt after switching to runlevel 3 by pressing
<RETURN> .  

If not, ensure you are in the correct virtual terminal - press <ALT>+<F1>,
then press <RETURN> - do you then get a login: prompt ?
Comment 3 Jason Vas Dias 2006-03-27 13:41:39 EST
I really cannot reproduce this problem .

When you type 'init 3' in an X-Windows terminal, then X exits and you are left
in the Console (VT-7) which has no getty - then you need to switch to a getty
console (VT-1 to VT-6) by pressing the <ALT>+<F[1-6]> keys; then you may need
to press <RETURN> to get a login: prompt - I've been unable to get this to fail.
 

Note You need to log in before you can comment on or make changes to this bug.