Bug 171004 - error: rpmts_HdrFromFdno: MD5 digest: BAD when installing gcc-c++-3.2.3-53.i386.rpm
error: rpmts_HdrFromFdno: MD5 digest: BAD when installing gcc-c++-3.2.3-53.i3...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gcc (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-17 06:11 EDT by thewolf
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-17 06:20:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description thewolf 2005-10-17 06:11:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

Description of problem:
When installing the latest gcc-c++ package with the up2date tool on a fully updated RHEL3 U6 system, I got the folloing error message:


gcc-c++-3.2.3-53.i386.rpm:  ########################## Done.                   
error: rpmts_HdrFromFdno: MD5 digest: BAD Expected(83461c98bc05652ce52803cee06ae8ea) != (4a448d5e84c9bec9ea14ad149527a215)
########################## Done.


The package is installed anyway:


# rpm -q gcc-c++                                           gcc-c++-3.2.3-53


I didn't test it though.

I removed the package and re-installed it with the same results.

Version-Release number of selected component (if applicable):
gcc-c++-3.2.3-53

How reproducible:
Always

Steps to Reproduce:
1. up2date gcc-c++

Actual Results:  # up2date gcc-c++

Fetching Obsoletes list for channel: rhel-i386-es-3...

Fetching rpm headers...
########################################

Name                                    Version        Rel     
----------------------------------------------------------
gcc-c++                                 3.2.3          53                i386  


Testing package set / solving RPM inter-dependencies...
########################################
gcc-c++-3.2.3-53.i386.rpm:  ########################## Done.                   
error: rpmts_HdrFromFdno: MD5 digest: BAD Expected(83461c98bc05652ce52803cee06ae8ea) != (4a448d5e84c9bec9ea14ad149527a215)
########################## Done.                   
Preparing              ########################################### [100%]

Installing...
   1:gcc-c++                ########################################### [100%]

Expected Results:  No error message.

Additional info:

# uname -a
Linux isabella.coresecure.com 2.4.21-32.0.1.EL #1 Tue May 17 18:01:37 EDT 2005 i686 i686 i386 GNU/Linux


# cat /etc/redhat-release 
Red Hat Enterprise Linux ES release 3 (Taroon Update 6)
Comment 1 Jakub Jelinek 2005-10-17 06:20:09 EDT
This is not a bug in the package itself, probably there was a transmission
problem or something.  Please contact your support contact instead to resolve it.
Comment 2 Jakub Jelinek 2005-10-17 06:21:11 EDT
For official Red Hat Enterprise Linux support, please log into the Red
Hat support website at http://www.redhat.com/support and file a
support ticket, or alternatively contact Red Hat Global Support
Services at 1-888-RED-HAT1 to speak directly with a support associate
and escalate an issue.

Note You need to log in before you can comment on or make changes to this bug.