Bug 17104 - make segfault
make segfault
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: make (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-30 09:16 EDT by Tim Waugh
Modified: 2007-04-18 12:28 EDT (History)
0 users

See Also:
Fixed In Version: 3.80-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-01 06:41:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Here is the backtrace. (2.92 KB, text/plain)
2000-08-30 09:17 EDT, Tim Waugh
no flags Details
Here is a testcase. 'CFLAGS= make' to reproduce. (32 bytes, text/plain)
2000-08-31 09:16 EDT, Tim Waugh
no flags Details
make-assert.patch (329 bytes, patch)
2003-11-20 10:48 EST, Tim Waugh
no flags Details | Diff

  None (edit)
Description Tim Waugh 2000-08-30 09:16:48 EDT
I have a reproducable make segfault.  The test case is rather large, I'm
afraid, and it only seems to segfault when run from rpm (running the same
command from the shell completes fine).
Comment 1 Tim Waugh 2000-08-30 09:17:25 EDT
Created attachment 3099 [details]
Here is the backtrace.
Comment 2 Tim Waugh 2000-08-31 09:16:49 EDT
Created attachment 3119 [details]
Here is a testcase.  'CFLAGS= make' to reproduce.
Comment 3 Tim Waugh 2000-08-31 09:17:50 EDT
(touch test.c first).
Comment 4 Tim Waugh 2000-08-31 10:17:30 EDT
Vanilla 3.79 is also broken.
make-3.78.1-4 works fine.
Comment 5 Tim Waugh 2003-11-20 10:48:33 EST
Created attachment 96089 [details]
make-assert.patch

This fixes the problem.  No test suite regressions.
Comment 6 Tim Waugh 2003-12-01 06:41:17 EST
This seems to be fixed in 3.80.

Note You need to log in before you can comment on or make changes to this bug.