Bug 17104 - make segfault
Summary: make segfault
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: make   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-30 13:16 UTC by Tim Waugh
Modified: 2007-04-18 16:28 UTC (History)
0 users

Fixed In Version: 3.80-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-01 11:41:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Here is the backtrace. (2.92 KB, text/plain)
2000-08-30 13:17 UTC, Tim Waugh
no flags Details
Here is a testcase. 'CFLAGS= make' to reproduce. (32 bytes, text/plain)
2000-08-31 13:16 UTC, Tim Waugh
no flags Details
make-assert.patch (329 bytes, patch)
2003-11-20 15:48 UTC, Tim Waugh
no flags Details | Diff

Description Tim Waugh 2000-08-30 13:16:48 UTC
I have a reproducable make segfault.  The test case is rather large, I'm
afraid, and it only seems to segfault when run from rpm (running the same
command from the shell completes fine).

Comment 1 Tim Waugh 2000-08-30 13:17:25 UTC
Created attachment 3099 [details]
Here is the backtrace.

Comment 2 Tim Waugh 2000-08-31 13:16:49 UTC
Created attachment 3119 [details]
Here is a testcase.  'CFLAGS= make' to reproduce.

Comment 3 Tim Waugh 2000-08-31 13:17:50 UTC
(touch test.c first).

Comment 4 Tim Waugh 2000-08-31 14:17:30 UTC
Vanilla 3.79 is also broken.
make-3.78.1-4 works fine.

Comment 5 Tim Waugh 2003-11-20 15:48:33 UTC
Created attachment 96089 [details]
make-assert.patch

This fixes the problem.  No test suite regressions.

Comment 6 Tim Waugh 2003-12-01 11:41:17 UTC
This seems to be fixed in 3.80.


Note You need to log in before you can comment on or make changes to this bug.