Bug 17105 - tracebacks on install
tracebacks on install
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Depends On:
  Show dependency treegraph
Reported: 2000-08-30 09:23 EDT by Srepfler Srgjan
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-10-24 12:35:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Srepfler Srgjan 2000-08-30 09:23:44 EDT
machine: PII 300, Mother Board Soyo (forgot what model it is but i think 
its 6BA+ IV), tested with SB AWE 32+ modem+mouse and without all these 
periphelials.Graphic, text and expert mode failed.Tried boot from CD and 
boot image on floppy.Message was something like this (although I wrote 
this by hand)

traceback (innermost last)
File "/usr/bin/anaconda",line 197, in ?
     from todo import ToDo
File "usr/lib/anaconda/todo.py",line 23, in ?
     from mouse import Mouse
Value Error: bad marshall data

and then goes to shutdown,
basicly in console 3 it goes to the point of writing something about "USB 
mouse ..." although i'm not shure what is it attempting to do.
Q1:is it possible to make a boot disk which saves theses informatons (on 
all consoles) to a file/s?
Q2:is there a boot command that will explicitly prohibit to do the USB 
mouse step? (where is there a complete list of all expert commands?)
Also in the end I tryed to see if it is possible that changeing 
configurations in the BIOS would resolve the thing but results were 
Comment 1 Michael Fulbright 2000-08-30 11:22:02 EDT
Try doing the install while passing 'nousb' on the boot command line.
Comment 2 Srepfler Srgjan 2000-09-04 07:20:46 EDT
Original sender:

Tried the nousb switch, all it changes that it does not do the USB step on 
console 3 but it still blocks on the same place.Later I did other thing, loaded 
it as expert and specified to look for the install from hdb (I have 2 
HDD's),thing is that it started the anaconda i was able to do partitioning 
(although I deleted the windows partition by error (and the RedHat directory) 
and package selection but after it pops up again.Thank god I managed to save 
the deleted partition from revived disk #2, anyhow is it possible that I lack 
the virtual space for install?I have 64 MB of ram and have absolutely no other 
idea why woud anaconda go into tilt from the CD and not form HDD image, also 
wasn't it more easy to put some of the rpm's on disk 2 and to leave the 
stage2.img 'decompressed' as is on most distros (although I first liked the 
idea now I fear that it might be the root of all problems (but maybe not)).I 
recorded the iso image on a 650 MB CD (and the iso was about 670-680MB), is it 
possible that the image was intended for larger capacity CD's, or that older 
CD's have problems reading some part of the CD?
Comment 3 Michael Fulbright 2000-10-09 14:58:15 EDT
Could you please try the 7.0 final release and see if it helps?
Comment 4 Srepfler Srgjan 2000-10-10 06:49:13 EDT
Original Sender:

I downloaded the 2 basic ISO's from the official 7 release basicly on the first 
week of the release so I suppose it'll be erradicated bug also in eventual new 
releases,there were no problems reported on install, (actualy I liked it more 
than on the 6.2 version but i guess it's regular incremental impruvments as 
versions go on),only thing I had was that I am unable to compile the Build 0.9-
5 (latest) of the Nvidia TNT drivers for the XFree4.0.1 but I am not shure it 
is a compiler problem, driver problem, kernel incompatibility or XFree problem 
so I can't report it to bugzilla.Can I actualy put these comments here or is it 
Comment 5 Michael Fulbright 2000-10-24 12:35:14 EDT
Thanks for getting back to us, I will mark this bug as no longer being a

Note You need to log in before you can comment on or make changes to this bug.