Bug 171051 - ResourceCellRenderer.paint not implemented well
ResourceCellRenderer.paint not implemented well
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Directory Console (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rich Megginson
Viktor Ashirov
:
: 172346 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-17 14:31 EDT by Lillian Angel
Modified: 2015-12-07 11:30 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 11:30:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Better implementation for ResourceCellRenderer.paint (2.67 KB, patch)
2005-10-17 14:32 EDT, Lillian Angel
no flags Details | Diff

  None (edit)
Description Lillian Angel 2005-10-17 14:31:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
paint is not implemented the best way. Attached is a patch. It gets rid of most constants used.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Look at 
  ResourceCellRenderer.paint

Actual Results:  Too many constants, will run into problems with this.

Expected Results:  ...

Additional info:
Comment 1 Lillian Angel 2005-10-17 14:32:37 EDT
Created attachment 120072 [details]
Better implementation for ResourceCellRenderer.paint
Comment 3 Rich Megginson 2005-12-02 16:34:16 EST
/cvs/dirsec/console/build.xml,v  <--  build.xml
new revision: 1.9; previous revision: 1.8
done
Checking in console/src/com/netscape/management/client/AboutDialog.java;
/cvs/dirsec/console/src/com/netscape/management/client/AboutDialog.java,v  <--
AboutDialog.java
new revision: 1.4; previous revision: 1.3
done
Checking in console/src/com/netscape/management/client/ResourceCellRenderer.java;
/cvs/dirsec/console/src/com/netscape/management/client/ResourceCellRenderer.java,v
 <--  ResourceCellRenderer.java
new revision: 1.2; previous revision: 1.1
done
Removing console/src/com/netscape/management/client/comm/Handler.java;
/cvs/dirsec/console/src/com/netscape/management/client/comm/Handler.java,v  <--
 Handler.java
new revision: delete; previous revision: 1.1.1.1
done
Checking in console/src/com/netscape/management/client/console/Console.java;
/cvs/dirsec/console/src/com/netscape/management/client/console/Console.java,v 
<--  Console.java
new revision: 1.4; previous revision: 1.3
done
Checking in
console/src/com/netscape/management/client/util/AbstractDialog.java;/cvs/dirsec/console/src/com/netscape/management/client/util/AbstractDialog.java,v
 <--  AbstractDialog.java
new revision: 1.2; previous revision: 1.1
done
Checking in console/src/com/netscape/management/nmclf/SuiLookAndFeel.java;
/cvs/dirsec/console/src/com/netscape/management/nmclf/SuiLookAndFeel.java,v  <--
 SuiLookAndFeel.java
new revision: 1.2; previous revision: 1.1
done
Checking in console/src/com/netscape/management/nmclf/SuiTreeUI.java;
/cvs/dirsec/console/src/com/netscape/management/nmclf/SuiTreeUI.java,v  <-- 
SuiTreeUI.java
new revision: 1.2; previous revision: 1.1
done
Comment 4 To Ngan 2006-12-12 19:10:07 EST
*** Bug 172346 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.