Bug 171056 - /etc/init.d/xendomains not compatible with Fedora Core 4 /lib/lsb/init-functions
Summary: /etc/init.d/xendomains not compatible with Fedora Core 4 /lib/lsb/init-functions
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xen   
(Show other bugs)
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Veillard
QA Contact:
URL:
Whiteboard:
Keywords: Reopened
: 186226 (view as bug list)
Depends On:
Blocks: 179599 182926
TreeView+ depends on / blocked
 
Reported: 2005-10-17 19:37 UTC by Jonathan Abbey
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

Fixed In Version: xen-3.1.0-0.rc7.1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-20 20:01:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A modified version of the xendomains init script that tests for Red Hat environment before LSB (3.28 KB, text/plain)
2005-10-17 19:37 UTC, Jonathan Abbey
no flags Details

Description Jonathan Abbey 2005-10-17 19:37:34 UTC
Description of problem:

The /etc/init.d/xendomains script is not compatible with how Fedora/RedHat have
constructed /lib/lsb/init-functions.  That file is currently set up to use shell
aliasing to define the LSB init functions, and aliasing is quite fragile under
sh.  In particular, it seems not to be possible to define a shell function in
terms of an aliased command.

I've filed a bug on Fedora's lsb support (bug 171052), but in the meantime, it
should be possible to fix the xendomains script not to depend on the lsb
functions on a Red Hat system.

Version-Release number of selected component (if applicable):

xen-3.0-0.20050912.fc4

How reproducible:

Constantly.

Steps to Reproduce:
1. Install xen
2. Attempt to run /etc/init.d/xendomains start
3. Cry.
  
Actual results:

log_success_msg: command not found

Expected results:

Proper invocation of the Red Hat /etc/init.d/functions success routine.

Additional info:

Comment 1 Jonathan Abbey 2005-10-17 19:37:35 UTC
Created attachment 120075 [details]
A modified version of the xendomains init script that tests for Red Hat environment before LSB

Comment 2 Stephen Tweedie 2006-03-22 20:14:32 UTC
Problem persists in FC5.

Comment 3 Stephen Tweedie 2006-03-22 20:15:41 UTC
*** Bug 186226 has been marked as a duplicate of this bug. ***

Comment 4 Daniel Veillard 2006-03-30 21:18:48 UTC
Patch floating around in xen-devel:
 http://lists.xensource.com/archives/html/xen-devel/2006-03/msg01411.html


Comment 5 Daniel Veillard 2006-11-02 15:37:48 UTC
This was fixed in recent releases, in spring IIRC,

Daniel

Comment 6 Robert Story 2006-11-02 18:58:50 UTC
Problem persists in FC5...

# rpm -qf /etc/init.d/xendomains
xen-3.0.3-1.fc5

server # service xendomains satus
Usage: /etc/init.d/xendomains {start|stop|restart|reload|status}
/etc/init.d/xendomains: line 69: log_failure_msg: command not found


Comment 7 Jonathan Abbey 2006-11-02 19:05:58 UTC
I'll check this out when I get FC6 installed here.

Comment 8 Jonathan Abbey 2006-11-02 19:09:23 UTC
Even if this bug was fixed using the patch referenced by Daniel, above, I think
bug 171052 is really the underlying problem, and that bug is still marked as
'NEW' after over a year in Bugzilla.

Comment 9 Daniel Veillard 2006-11-03 00:36:09 UTC
Okay #4 is wrong, I fixed /etc/init.d/xend but not /etc/init.d/xendomains,
damn ... reopening :-(

Daniel

Comment 10 Jonathan Abbey 2006-11-13 23:23:08 UTC
I confirm that this bug (actually, the underlying bug, bug 171052) is still
active in Fedora Core 6.

Comment 11 Hugh Brock 2006-12-11 14:14:41 UTC
This is fixed for rhel5 with redhat-lsb-3.1-12.2.EL.i386.rpm -- the
/lib/lsb/init-functions use of aliases was wrong, it has been changed to use
functions.

Comment 13 Chris Langlands 2007-01-09 14:34:28 UTC
This bug is still present in xen-3.0.3-1.fc6 built 15-Nov-06, released to
updates on 29-Dec-06

Comment 14 Daniel Veillard 2007-06-20 20:01:14 UTC
Fixed in current releases, i.e. Fedora 7:

[root@paphio ~]# /etc/init.d/xendomains start
[root@paphio ~]# /etc/init.d/xendomains stop
Shutting down Xen domains:[done]                           [  OK  ]
[root@paphio ~]# 

  thanks,

Daniel


Note You need to log in before you can comment on or make changes to this bug.