Bug 171067 - man-pages-pl - 'pidof' page out of sync
man-pages-pl - 'pidof' page out of sync
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: man-pages-pl (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-17 17:10 EDT by Michal Jaegermann
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-09 10:18:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Update pidof.8 to -c option (738 bytes, patch)
2006-01-06 11:21 EST, Marcin Garski
no flags Details | Diff

  None (edit)
Description Michal Jaegermann 2005-10-17 17:10:38 EDT
Description of problem:

The current version of 'man pidof' from SysVinit-2.85-42 describes an option
'-c' - even if it was not there before and even if '.TH PIDOF 8 "01 Sep 1998"'
remains.  Sigh!  To make things more "interesting" '-c' is used in initscripts.
There is no mention of such option in /usr/share/man/pl/man8/pidof.8.gz.
No idea about other language specific versions.

Version-Release number of selected component (if applicable):
man-pages-pl-0.23-7
Comment 1 Ivana Varekova 2005-10-19 04:46:27 EDT
Polish language is not supported by RH so here is not any person who could fix
this problem or review a proposed patch.
Comment 2 Marcin Garski 2005-10-20 17:35:31 EDT
I'm a person who knows Polish language :) and I could help if you want, with
this bug and in future.
Comment 3 Ivana Varekova 2006-01-06 09:36:54 EST
Marcin, please could you translate/update pidof man page, it would be
appreciate. Our new colleague check you translation now. 
Thank you. 
Comment 4 Marcin Garski 2006-01-06 10:31:01 EST
OK, I will do that.

I have done little investigation and I know why pidof man page are out of sync.
SysVinit source rpm contain 'sysvinit-2.86-chroot.patch', that file add -c option.
So any man page outside this package is and probably will be outdated, because
upstream version don't have such option.

Conclusion :) all man-pages-* have pidof man page out of sync, unless someone
provide patch for Fedora Core.
Comment 5 Marcin Garski 2006-01-06 11:20:09 EST
Here you have patch for pidof.8 man page.

Ivana could you please change URL in spec file to:
http://dione.ids.pl/~pborys/PTM/
the old one isn't working any more.
Also note that you can update man-pages-pl to newer version from updated URL :)
Comment 6 Marcin Garski 2006-01-06 11:21:20 EST
Created attachment 122881 [details]
Update pidof.8 to -c option
Comment 7 Ivana Varekova 2006-01-09 10:18:13 EST
Thank you very much for your excelent help. 
man-pages-pl package was updated and your patch was added to this version. 
 

Note You need to log in before you can comment on or make changes to this bug.