Bug 171082 - 30+ seconds delay on mount smbfs (samba) with odd (manual) workaround curing the problem
30+ seconds delay on mount smbfs (samba) with odd (manual) workaround curing ...
Status: CLOSED DUPLICATE of bug 168280
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: util-linux (Show other bugs)
4.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Ben Levenson
https://bugzilla.redhat.com/bugzilla/...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-17 19:29 EDT by Chris
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-20 09:33:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris 2005-10-17 19:29:41 EDT
Description of problem:

This is the same as https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=168280

I posted it here because I think it might be a problem in util-linux-2.12a-
16.EL4.12 and not in samba (which 168280 is posted under).

Breifly - this causes a 30+ second delay:-

mount -w -t smbfs //192.168.0.11/xxx /x -o username=xxx 

However - if, instead of waiting 30 seconds, you hit Ctrl-Z and type "bg", it 
successfully completes immediately (wihtout having to wait 30 seconds).

Looks like the bug is related to some kind of waiting around for a signal that 
never arrives, and the Ctrl-Z+"bg" "hack" delivers whatever it's waiting for...

# rpm -q --whatprovides mount
util-linux-2.12a-16.EL4.12


# mount -w -t smbfs //192.168.0.11/xxx /x -o username=xxx 
Password: 

[1]+  Stopped                 mount -w -t smbfs //192.168.0.11/xxx /x -o 
username=xxx
# bg
[1]+ mount -w -t smbfs //192.168.0.11/xxx /x -o username=xxx &
# 
[1]+  Done                    mount -w -t smbfs //192.168.0.11/xxx /x -o 
username=xxx
# 




Version-Release number of selected component (if applicable):
util-linux-2.12a-16.EL4.12


How reproducible:
always


Steps to Reproduce:
1. mount -w -t smbfs //192.168.0.11/xxx /x -o username=xxx
2. wait 30+ seconds
3. mounts OK

-or-

1. mount -w -t smbfs //192.168.0.11/xxx /x -o username=xxx
2. Ctrl-Z (immediately)
3. bg (immediately)
4. hit enter (immediately)
5. mount works right away
  


Actual results:
delay

Expected results:
immediate


Additional info:
All my older Kernels work fine (ES3)

NB: this is posted here in the "Expert" bugzilla mode because the other 
bugzilla mode does not work right now (javascript "invalid syntax" error after 
collecting all my data)
Comment 1 Karel Zak 2005-10-20 05:06:21 EDT
Please, try it directly without the mount command:

 # /sbin/mount.smbfs //192.168.0.11/xxx /x -o username=xxx


BTW, https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=168280#c3 sounds
interesting.
Comment 2 Karel Zak 2005-10-20 09:33:47 EDT
Closing. It seems like a samba mount problem. See:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=168280#c5

*** This bug has been marked as a duplicate of 168280 ***
Comment 3 Chris 2005-10-20 20:05:28 EDT
Oops - I posted this reply in the wrong place - here it is again:-

The problem is identical using /sbin/mount.smbfs isntead of the "mount" 
command.

Below - I issued the command, waited 30 seconds (it still did not complete) so 
I hit Ctrl-Z, bg, and it completed immediately OK:-

[root@ca2 xxx]# date;/sbin/mount.smbfs //192.168.0.11/xxx /x -o 
username=xxx;date
Thu Oct 20 13:10:58 UTC 2005
Password: 

[1]+  Stopped                 /sbin/mount.smbfs //192.168.0.11/xxx /x -o 
username=xxx
Thu Oct 20 13:11:27 UTC 2005
[root@ca2 xxx]# bg
[1]+ /sbin/mount.smbfs //192.168.0.11/xxx /x -o username=xxx &
[root@ca2 xxx]# 
[1]+  Done                    /sbin/mount.smbfs //192.168.0.11/xxx /x -o 
username=xxx
[root@ca2 xxx]# 


Note You need to log in before you can comment on or make changes to this bug.