Bug 171108 - yum upgrade fc3 to fc4 flac dependency problem
yum upgrade fc3 to fc4 flac dependency problem
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-18 06:23 EDT by Eric Preston
Modified: 2014-01-21 17:52 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-19 16:13:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Preston 2005-10-18 06:23:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc3 Firefox/1.0.7

Description of problem:

trying to upgrade fc3 to fc4 with yum
reviewed wiki known problems list...
encountered one not listed...

demands flac.so > 4...

had to do the kernel upgrade from package and uninstall,
then manual upgrade of flac before yum update worked.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. have fc3 installed and updated to current updates
2. download fc4-release and upgrade, update kernel as well
3. try to yum upgrade
  

Actual Results:  
upgrade fails due to a whole bunch of packages depending on libflac.so >= .4


Expected Results:  
upgrade should have proceeded because FC4 contains libflac.so >= .4

Additional info:


work around... upgrade flac manually by downloading it from FC4 tree,
then upgrade proceeds.

maybe this should make it's way into the wiki?
Comment 1 Jeremy Katz 2006-04-19 16:13:28 EDT
Upgrades like this aren't supported

Note You need to log in before you can comment on or make changes to this bug.