Bug 171114 - libattr-devel provides .la file which creates dangling references to /lib/libattr.la
Summary: libattr-devel provides .la file which creates dangling references to /lib/lib...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: acl (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Thomas Woerner
QA Contact:
URL:
Whiteboard: RHEL4U3NAK
Keywords: EasyFix, Patch
: 195347 213625 (view as bug list)
Depends On: 154146
Blocks: 176344 185968
TreeView+ depends on / blocked
 
Reported: 2005-10-18 12:18 UTC by Jindrich Novy
Modified: 2013-07-02 23:10 UTC (History)
12 users (show)

Fixed In Version: RHBA-2007-0176
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 17:34:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0176 normal SHIPPED_LIVE acl bug fix update 2007-05-01 17:34:25 UTC

Comment 3 Rex Dieter 2005-12-02 15:05:18 UTC
FYI, 
libacl-devel-2.2.3-1  (from EL3)
libacl-devel-2.2.23-5 (from FC3)
libacl-devel-2.2.23-8 (from FC4) 

are all affected too (is it worth filing additional separate bug reports?)

For the record, the error one gets when trying to build/link against libacl (for
libtool aware apps) is:
grep: /lib/libattr.la: No such file or directory
/bin/sed: can't read /lib/libattr.la: No such file or directory


Comment 4 Rex Dieter 2005-12-02 15:19:04 UTC
IMO, since this bug has been around for so long (dating back to libacl-2.2.3,
Jan 2003), apparently no-one has been using these (broken) libtool archives
anyway, a reasonable fix is to simply remove/omit them from packaging.

Comment 5 Rex Dieter 2005-12-02 15:36:07 UTC
Re: comment #4, to implement omission, add something like the following to
%install section after the 'make install' bits:

# omit broken libtool archive(s) (#171114)
rm -f $RPM_BUILD_ROOT%{_libdir}/libacl.la
grep -v "%{_libdir}/libacl.la" $DIST_INSTALL_DEV > ${DIST_INSTALL_DEV}.new && \
  mv ${DIST_INSTALL_DEV}.new $DIST_INSTALL_DEV


Comment 6 Paul Leopardi 2006-03-08 08:57:49 UTC
Once the change suggested in #5 is done, would it then be possible to use 
Konstruct to build KDE 3.5.1 without root permission? Currently this build 
fails because of the dangling reference. All the suggested workarounds involve 
having root access. See also bug 170602. 
 

Comment 7 Rex Dieter 2006-03-08 15:06:34 UTC
As it stands now, kde-3.5.x (and any other app that uses libtool and links
against libattr) is not buildable.  Fix the bug, apps will build again.

I just noticed that I need to submit a new bug.  The title of this bug refers to
libattr, whereas the problems I'm talking about are with libacl.  Oops.

FYI, bug 170602 is completely independant of this.

Comment 12 RHEL Product and Program Management 2006-08-18 17:14:09 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 13 Matthew Miller 2006-11-27 19:18:57 UTC
Bug #195347 and bug #213625 are duplicates of this bug. I don't have the
bugzilla power to mark them as such, however.

Comment 14 Jindrich Novy 2006-11-27 19:28:07 UTC
*** Bug 195347 has been marked as a duplicate of this bug. ***

Comment 15 Jindrich Novy 2006-11-27 19:30:06 UTC
*** Bug 213625 has been marked as a duplicate of this bug. ***

Comment 20 Red Hat Bugzilla 2007-05-01 17:34:44 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0176.html



Note You need to log in before you can comment on or make changes to this bug.