Bug 171176 - Package initscripts needs kernel < 2.6.12, this is not available
Package initscripts needs kernel < 2.6.12, this is not available
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-18 23:04 EDT by Peter Ennis
Modified: 2015-01-04 17:22 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-01 02:12:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fc5list (187.00 KB, text/plain)
2005-10-19 02:06 EDT, Peter Ennis
no flags Details

  None (edit)
Description Peter Ennis 2005-10-18 23:04:04 EDT
Description of problem:

yum upgrade kernel
This does not work since > 2 weeks.
Google and bugzilla searches give some vague
hints about deleting the existing kernel
(while the system is running?)

Yum update manual, FAQ etc. is not much help.

The general message I get searching about this
is "you should be an expert and understand
about fixing kernels yourself ..."

Clear guidelines are hard to come by.

I have only the one Fedora box at the moment
and would rather not trash it.

Pointers would be appreciated.

Thanks,

PFE

[root@lfs developer]# uname  -r
2.6.11-1.1177_FC4
[root@lfs developer]# yum upgrade kernel
Setting up Upgrade Process
Setting up Repos
development               100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 1.0 MB    00:25
developmen: ################################################## 3736/3736
Added 298 new packages, deleted 300 old in 33.09 seconds
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for kernel to pack into transaction set.
kernel-2.6.13-1.1616_FC5. 100% |=========================| 192 kB    00:04
---> Package kernel.i686 0:2.6.13-1.1616_FC5 set to be installed
--> Running transaction check
--> Processing Conflict: kernel conflicts procps < 3.2.5-6.3
--> Processing Conflict: kernel conflicts jfsutils < 1.1.7-2
--> Processing Dependency: initscripts >= 8.11.1-1 for package: kernel
--> Processing Conflict: kernel conflicts nfs-utils < 1.0.7-12
--> Processing Conflict: kernel conflicts udev < 063-6
--> Processing Conflict: kernel conflicts isdn4k-utils < 3.2-32
--> Processing Dependency: mkinitrd >= 4.2.21-1 for package: kernel
--> Processing Conflict: kernel conflicts iptables < 1.3.2-1
--> Processing Conflict: kernel conflicts ppp < 2.4.3-3
--> Processing Conflict: kernel conflicts e2fsprogs < 1.37-4
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package isdn4k-utils.i386 0:3.2-32 set to be updated
---> Package iptables.i386 0:1.3.2-1 set to be updated
---> Package procps.i386 0:3.2.5-8 set to be updated
---> Package jfsutils.i386 0:1.1.7-2 set to be updated
---> Package ppp.i386 0:2.4.3-4 set to be updated
---> Package nfs-utils.i386 0:1.0.7-18.FC5 set to be updated
---> Package e2fsprogs.i386 0:1.38-1 set to be updated
---> Package udev.i386 0:069-10 set to be updated
---> Downloading header for mkinitrd to pack into transaction set.
mkinitrd-5.0.5-1.i386.rpm 100% |=========================|  38 kB    00:00
---> Package mkinitrd.i386 0:5.0.5-1 set to be updated
---> Package initscripts.i386 0:8.17-1 set to be updated
--> Running transaction check
--> Processing Dependency: e2fsprogs = 1.36 for package: e2fsprogs-devel
--> Processing Dependency: libpcap.so.0.9.3 for package: ppp
--> Processing Dependency: SysVinit >= 2.85-38 for package: initscripts
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: procps
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: ppp
--> Processing Dependency: libpcap.so.0.9.3 for package: isdn4k-utils
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: mkinitrd
--> Processing Conflict: initscripts conflicts kernel < 2.6.12
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: udev
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: nfs-utils
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: e2fsprogs
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: isdn4k-utils
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: initscripts
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package libpcap.i386 14:0.9.3-3 set to be updated
---> Package e2fsprogs-devel.i386 0:1.38-1 set to be updated
---> Downloading header for SysVinit to pack into transaction set.
SysVinit-2.85-42.i386.rpm 100% |=========================|  16 kB    00:00
---> Package SysVinit.i386 0:2.85-42 set to be updated
---> Package glibc.i686 0:2.3.90-14 set to be updated
--> Running transaction check
--> Processing Conflict: initscripts conflicts kernel < 2.6.12
--> Processing Dependency: glibc-common = 2.3.90-14 for package: glibc
--> Processing Conflict: glibc-common conflicts glibc > 2.3.4
--> Processing Dependency: libpcap.so.0.8.3 for package: ethereal
--> Processing Dependency: glibc = 2.3.4 for package: glibc-headers
--> Processing Dependency: glibc = 2.3.4 for package: glibc-devel
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package glibc-common.i386 0:2.3.90-14 set to be updated
---> Package glibc-devel.i386 0:2.3.90-14 set to be updated
---> Package glibc-headers.i386 0:2.3.90-14 set to be updated
---> Package ethereal.i386 0:0.10.12-9 set to be updated
--> Running transaction check
--> Processing Conflict: initscripts conflicts kernel < 2.6.12
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
--> Running transaction check
--> Processing Conflict: initscripts conflicts kernel < 2.6.12
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
--> Running transaction check
Error: Unable to satisfy dependencies
Error: Package initscripts needs kernel < 2.6.12, this is not available.
[root@lfs developer]#


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Dave Jones 2005-10-19 00:33:19 EDT
update fc4 to latest 2.6.13 kernel, and remove all < 2.6.13 kernels, then do the
update and it should work.

The 2.6.11 kernel you have installed is confusing the depsolver.
Anaconda ignores this dependancy on updates, so this won't cause any problems on
real upgrades.
Comment 2 Peter Ennis 2005-10-19 02:06:03 EDT
Created attachment 120152 [details]
fc5list
Comment 3 Dave Jones 2005-10-19 02:10:55 EDT
it looks like you're picking up some really out of date mirror.
The current FC5 kernel is 2.6.13-1.1615_FC5
Comment 4 Peter Ennis 2005-10-19 02:17:47 EDT
I am running rawhide.

Used following command:

[root@lfs developer]# uname -r
2.6.11-1.1177_FC4
[root@lfs developer]# yum update kernel
Setting up Update Process
Setting up Repos
development               100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package kernel.i686 0:2.6.13-1.1616_FC5 set to be installed
--> Running transaction check
--> Processing Conflict: kernel conflicts procps < 3.2.5-6.3
--> Processing Conflict: kernel conflicts jfsutils < 1.1.7-2
--> Processing Dependency: initscripts >= 8.11.1-1 for package: kernel
--> Processing Conflict: kernel conflicts nfs-utils < 1.0.7-12
--> Processing Conflict: kernel conflicts udev < 063-6
--> Processing Conflict: kernel conflicts isdn4k-utils < 3.2-32
--> Processing Dependency: mkinitrd >= 4.2.21-1 for package: kernel
--> Processing Conflict: kernel conflicts iptables < 1.3.2-1
--> Processing Conflict: kernel conflicts ppp < 2.4.3-3
--> Processing Conflict: kernel conflicts e2fsprogs < 1.37-4
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package isdn4k-utils.i386 0:3.2-32 set to be updated
---> Package iptables.i386 0:1.3.2-1 set to be updated
---> Package procps.i386 0:3.2.5-8 set to be updated
---> Package jfsutils.i386 0:1.1.7-2 set to be updated
---> Package ppp.i386 0:2.4.3-4 set to be updated
---> Package nfs-utils.i386 0:1.0.7-18.FC5 set to be updated
---> Package e2fsprogs.i386 0:1.38-1 set to be updated
---> Package udev.i386 0:069-10 set to be updated
---> Package mkinitrd.i386 0:5.0.5-1 set to be updated
---> Package initscripts.i386 0:8.17-1 set to be updated
--> Running transaction check
--> Processing Dependency: e2fsprogs = 1.36 for package: e2fsprogs-devel
--> Processing Dependency: libpcap.so.0.9.3 for package: ppp
--> Processing Dependency: SysVinit >= 2.85-38 for package: initscripts
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: procps
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: ppp
--> Processing Dependency: libpcap.so.0.9.3 for package: isdn4k-utils
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: mkinitrd
--> Processing Conflict: initscripts conflicts kernel < 2.6.12
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: udev
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: nfs-utils
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: e2fsprogs
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: isdn4k-utils
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: initscripts
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package libpcap.i386 14:0.9.3-3 set to be updated
---> Package e2fsprogs-devel.i386 0:1.38-1 set to be updated
---> Package SysVinit.i386 0:2.85-42 set to be updated
---> Package glibc.i686 0:2.3.90-14 set to be updated
--> Running transaction check
--> Processing Conflict: initscripts conflicts kernel < 2.6.12
--> Processing Dependency: glibc-common = 2.3.90-14 for package: glibc
--> Processing Conflict: glibc-common conflicts glibc > 2.3.4
--> Processing Dependency: libpcap.so.0.8.3 for package: ethereal
--> Processing Dependency: glibc = 2.3.4 for package: glibc-headers
--> Processing Dependency: glibc = 2.3.4 for package: glibc-devel
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package glibc-common.i386 0:2.3.90-14 set to be updated
---> Package glibc-devel.i386 0:2.3.90-14 set to be updated
---> Package glibc-headers.i386 0:2.3.90-14 set to be updated
---> Package ethereal.i386 0:0.10.12-9 set to be updated
--> Running transaction check
--> Processing Conflict: initscripts conflicts kernel < 2.6.12
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
--> Running transaction check
--> Processing Conflict: initscripts conflicts kernel < 2.6.12
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
--> Running transaction check
Error: Unable to satisfy dependencies
Error: Package initscripts needs kernel < 2.6.12, this is not available.
[root@lfs developer]#

Try to "remove all < 2.6.13 kernels" as follows:

[developer@lfs ~]$ sudo su root
[root@lfs developer]# ls
Desktop
[root@lfs developer]# cd /
[root@lfs /]# ls
adaept  dev      home    lost+found  mnt   root     srv     tmp    var
bin     etc      initrd  media       opt   sbin     static  tools
boot    fc5list  lib     misc        proc  selinux  sys     usr
[root@lfs /]# cd boot
[root@lfs boot]# ls
boot.b                        kernel.h     System.map-2.6.11-1.1177_FC4
chain.b                       lost+found   vmlinuz
config-2.6.11-1.1177_FC4      module-info  vmlinuz-2.6.11-1.1177_FC4
grub                          os2_d.b
initrd-2.6.11-1.1177_FC4.img  System.map

[root@lfs boot]# mkdir old
[root@lfs boot]# mv config-2.6.11-1.1177_FC4 old
[root@lfs boot]# mv System.map-2.6.11-1.1177_FC4 old
[root@lfs boot]# mv vmlinuz-2.6.11-1.1177_FC4 old
[root@lfs boot]# mv initrd-2.6.11-1.1177_FC4.img old
[root@lfs boot]# ls
boot.b   grub      lost+found   old      System.map
chain.b  kernel.h  module-info  os2_d.b  vmlinuz

All *FC4 files are moved away. Then try:

[root@lfs boot]# yum upgrade kernel
Setting up Upgrade Process
Setting up Repos
development               100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package kernel.i686 0:2.6.13-1.1616_FC5 set to be installed
--> Running transaction check
--> Processing Conflict: kernel conflicts procps < 3.2.5-6.3
--> Processing Conflict: kernel conflicts jfsutils < 1.1.7-2
--> Processing Dependency: initscripts >= 8.11.1-1 for package: kernel
--> Processing Conflict: kernel conflicts nfs-utils < 1.0.7-12
--> Processing Conflict: kernel conflicts udev < 063-6
--> Processing Conflict: kernel conflicts isdn4k-utils < 3.2-32
--> Processing Dependency: mkinitrd >= 4.2.21-1 for package: kernel
--> Processing Conflict: kernel conflicts iptables < 1.3.2-1
--> Processing Conflict: kernel conflicts ppp < 2.4.3-3
--> Processing Conflict: kernel conflicts e2fsprogs < 1.37-4
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package isdn4k-utils.i386 0:3.2-32 set to be updated
---> Package iptables.i386 0:1.3.2-1 set to be updated
---> Package procps.i386 0:3.2.5-8 set to be updated
---> Package jfsutils.i386 0:1.1.7-2 set to be updated
---> Package ppp.i386 0:2.4.3-4 set to be updated
---> Package nfs-utils.i386 0:1.0.7-18.FC5 set to be updated
---> Package e2fsprogs.i386 0:1.38-1 set to be updated
---> Package udev.i386 0:069-10 set to be updated
---> Package mkinitrd.i386 0:5.0.5-1 set to be updated
---> Package initscripts.i386 0:8.17-1 set to be updated
--> Running transaction check
--> Processing Dependency: e2fsprogs = 1.36 for package: e2fsprogs-devel
--> Processing Dependency: libpcap.so.0.9.3 for package: ppp
--> Processing Dependency: SysVinit >= 2.85-38 for package: initscripts
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: procps
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: ppp
--> Processing Dependency: libpcap.so.0.9.3 for package: isdn4k-utils
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: mkinitrd
--> Processing Conflict: initscripts conflicts kernel < 2.6.12
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: udev
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: nfs-utils
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: e2fsprogs
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: isdn4k-utils
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: initscripts
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package libpcap.i386 14:0.9.3-3 set to be updated
---> Package e2fsprogs-devel.i386 0:1.38-1 set to be updated
---> Package SysVinit.i386 0:2.85-42 set to be updated
---> Package glibc.i686 0:2.3.90-14 set to be updated
--> Running transaction check
--> Processing Conflict: initscripts conflicts kernel < 2.6.12
--> Processing Dependency: glibc-common = 2.3.90-14 for package: glibc
--> Processing Conflict: glibc-common conflicts glibc > 2.3.4
--> Processing Dependency: libpcap.so.0.8.3 for package: ethereal
--> Processing Dependency: glibc = 2.3.4 for package: glibc-headers
--> Processing Dependency: glibc = 2.3.4 for package: glibc-devel
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package glibc-common.i386 0:2.3.90-14 set to be updated
---> Package glibc-devel.i386 0:2.3.90-14 set to be updated
---> Package glibc-headers.i386 0:2.3.90-14 set to be updated
---> Package ethereal.i386 0:0.10.12-9 set to be updated
--> Running transaction check
--> Processing Conflict: initscripts conflicts kernel < 2.6.12
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
--> Running transaction check
--> Processing Conflict: initscripts conflicts kernel < 2.6.12
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
--> Running transaction check
Error: Unable to satisfy dependencies
Error: Package initscripts needs kernel < 2.6.12, this is not available.
[root@lfs boot]#

Also try:

[root@lfs boot]# yum update kernel
Setting up Update Process
Setting up Repos
development               100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package kernel.i686 0:2.6.13-1.1616_FC5 set to be installed
--> Running transaction check
--> Processing Conflict: kernel conflicts procps < 3.2.5-6.3
--> Processing Conflict: kernel conflicts jfsutils < 1.1.7-2
--> Processing Dependency: initscripts >= 8.11.1-1 for package: kernel
--> Processing Conflict: kernel conflicts nfs-utils < 1.0.7-12
--> Processing Conflict: kernel conflicts udev < 063-6
--> Processing Conflict: kernel conflicts isdn4k-utils < 3.2-32
--> Processing Dependency: mkinitrd >= 4.2.21-1 for package: kernel
--> Processing Conflict: kernel conflicts iptables < 1.3.2-1
--> Processing Conflict: kernel conflicts ppp < 2.4.3-3
--> Processing Conflict: kernel conflicts e2fsprogs < 1.37-4
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package isdn4k-utils.i386 0:3.2-32 set to be updated
---> Package iptables.i386 0:1.3.2-1 set to be updated
---> Package procps.i386 0:3.2.5-8 set to be updated
---> Package jfsutils.i386 0:1.1.7-2 set to be updated
---> Package ppp.i386 0:2.4.3-4 set to be updated
---> Package nfs-utils.i386 0:1.0.7-18.FC5 set to be updated
---> Package e2fsprogs.i386 0:1.38-1 set to be updated
---> Package udev.i386 0:069-10 set to be updated
---> Package mkinitrd.i386 0:5.0.5-1 set to be updated
---> Package initscripts.i386 0:8.17-1 set to be updated
--> Running transaction check
--> Processing Dependency: e2fsprogs = 1.36 for package: e2fsprogs-devel
--> Processing Dependency: libpcap.so.0.9.3 for package: ppp
--> Processing Dependency: SysVinit >= 2.85-38 for package: initscripts
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: procps
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: ppp
--> Processing Dependency: libpcap.so.0.9.3 for package: isdn4k-utils
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: mkinitrd
--> Processing Conflict: initscripts conflicts kernel < 2.6.12
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: udev
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: nfs-utils
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: e2fsprogs
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: isdn4k-utils
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: initscripts
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package libpcap.i386 14:0.9.3-3 set to be updated
---> Package e2fsprogs-devel.i386 0:1.38-1 set to be updated
---> Package SysVinit.i386 0:2.85-42 set to be updated
---> Package glibc.i686 0:2.3.90-14 set to be updated
--> Running transaction check
--> Processing Conflict: initscripts conflicts kernel < 2.6.12
--> Processing Dependency: glibc-common = 2.3.90-14 for package: glibc
--> Processing Conflict: glibc-common conflicts glibc > 2.3.4
--> Processing Dependency: libpcap.so.0.8.3 for package: ethereal
--> Processing Dependency: glibc = 2.3.4 for package: glibc-headers
--> Processing Dependency: glibc = 2.3.4 for package: glibc-devel
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package glibc-common.i386 0:2.3.90-14 set to be updated
---> Package glibc-devel.i386 0:2.3.90-14 set to be updated
---> Package glibc-headers.i386 0:2.3.90-14 set to be updated
---> Package ethereal.i386 0:0.10.12-9 set to be updated
--> Running transaction check
--> Processing Conflict: initscripts conflicts kernel < 2.6.12
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
--> Running transaction check
--> Processing Conflict: initscripts conflicts kernel < 2.6.12
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
--> Running transaction check
Error: Unable to satisfy dependencies
Error: Package initscripts needs kernel < 2.6.12, this is not available.
[root@lfs boot]#

fc5list is attached, if it helps. I do not know its
significance but it has lots of references to the .13 kernel.

I have not rebooted so obviously still have the .11 FC4 kernel
in memory. This is probably what one of the comments on the
devel list was referring to about "removing the ground that
you are standing on".

What am I not understanding?

I would like to get this resolved as a clear sequence of steps
that can be understood and repeated by others with
the same problem.

Thanks,

PFE
Comment 5 Dave Jones 2005-10-20 23:40:28 EDT
mv'ing the files away isn't enough, they still exist in the rpm database.
Only rpm -e'ing the 2.6.11 kernel will satisfy the dependancy.

Install the 2.6.12 FC4 kernel, boot it, and then erase the 2.6.11 kernel (with
rpm -e)

Note You need to log in before you can comment on or make changes to this bug.