Bug 171177 - bugzilla.redhat.com does not allow to enter cyrillic letters in "new bug" form fields
bugzilla.redhat.com does not allow to enter cyrillic letters in "new bug" for...
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: Simon Green
Kevin Baker
Depends On:
  Show dependency treegraph
Reported: 2005-10-18 23:08 EDT by CTAC
Modified: 2014-12-01 18:08 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-05-10 08:50:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description CTAC 2005-10-18 23:08:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.7.12-1.3.1

Description of problem:
many times I've try to enter some cyrillic letters in "Addtional Information", "Steps to reproduce" and "Actual results" fields of
Always I get "Internal Server Error"
even my mozilla-1.7.12-1.3.1 on FC3 use UTF8 encoding with your server.
for example, todays bugs 171172 and 171173 give me:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Create new bug and put some info in russian at 
"Steps to reproduce" field
For example "ÍÁÍÁ ÍÙÌÁ ÒÁÍÕ"
that will be enough

Expected Results:  Added bug.

Additional info:
Comment 1 CTAC 2005-10-18 23:08:45 EDT
Мама мыла раму
Comment 2 CTAC 2005-10-18 23:12:06 EDT
1. It's possible to add additional comments in russian into already existing bug
2. Here I've got not "Internal Server Error" but created bugreport with cyrillic
letters exchanged to set of ,' signs.
So, this bug is not always reproducible.
Comment 3 David Lawrence 2005-10-19 00:11:00 EDT
Seems to happen when using the Guided Bug entry page. I have made a change which
I think will help fix this. Can you try to enter a new bug with cyrillic
characters to test?

Comment 4 CTAC 2005-10-19 00:37:58 EDT
so I've try to enter new bug:
and got this:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to
complete your request.

Please contact the server administrator, bugzilla@redhat.com and inform them of
the time the error occurred, and anything you might have done that may have
caused the error.

More information about this error may be available in the server error log.
Apache/2.0.46 (Red Hat) Server at bugzilla.redhat.com Port 443
Comment 5 CTAC 2005-10-19 00:40:35 EDT
you may see what a bug I've create with server fail:
Comment 6 David Lawrence 2008-09-16 12:53:46 EDT
Red Hat Bugzilla is now using version 3.2 of the Bugzilla codebase and therefore this bug will need to be re-verified against the new release. With the updated code this bug may no longer be relevant or may have been fixed in the new code.
Updating bug version to 3.2.
Comment 7 Stanislav Sukholet 2008-09-23 03:50:24 EDT
can not create new bug report with new bugzilla.
It allows me just to find something and I can not CREATE A NEW BUGREPORT. sorry
Comment 8 David Lawrence 2010-01-15 11:54:53 EST
Red Hat Bugzilla is now using version 3.4 of the Bugzilla codebase and
therefore this bug will need to be re-verified against the new release. With
the updated code this bug may no longer be relevant or may have been fixed in
the new code. Updating bug version to 3.4.
Comment 9 David Lawrence 2010-08-25 17:42:37 EDT
Red Hat has now upgraded to Bugzilla 3.6 and this bug will now be reassigned to that version. It would be helpful to the Bugzilla Development Team if this bug is verified to still be an issue with the latest version. If it is no longer an issue, then feel free to close, otherwise please comment that it is still a problem and we will try to address the issue as soon as we can.

Bugzilla Development Team
Comment 11 Simon Green 2012-05-10 08:50:07 EDT
Just tried the link in comment 4 on our public staging server (and removing the priority and status since they aren't valid values any more), and it seems to have worked fine.


Bugzilla is fully UTF-8 aware now.

Please reopen if you are still experiencing problems.

  -- simon

Note You need to log in before you can comment on or make changes to this bug.