Bug 171190 - Can't cd into $HOME directory on a VMS server
Can't cd into $HOME directory on a VMS server
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: lftp (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks: 187539
  Show dependency treegraph
 
Reported: 2005-10-19 04:07 EDT by Bastien Nocera
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2006-0302
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-03 15:20:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lftp-use-setcwd-no-leading-slash.patch (855 bytes, patch)
2005-10-19 04:07 EDT, Bastien Nocera
no flags Details | Diff

  None (edit)
Description Bastien Nocera 2005-10-19 04:07:54 EDT
When using lftp to access a VMS server, setting the cwd fails because of the
missing leading slash. Upstream patch (from 2.6.7 attached).

$ lftp -f ftp.commands
---- Connecting to forge (198.186.18.30) port 21
<--- 220 FORGE FTP Server (Version 3.3) Ready.
---> AUTH TLS
<--- 502 AUTH is unimplemented.
---> USER compxfer
<--- 331 Username COMPXFER requires a Password.
---> PASS XXXXXXX
<--- 230 User logged in.
---> PWD
<--- 257 "CAD$USER:[COMPXFER]" is current directory.
---> CWD CAD$USER:[COMPXFER]/CAD$USER:[COMPXFER]/CAD$USER:[COMPXFER]
<--- 550 Failed to set default directory to
CAD$USER:[COMPXFER]/CAD$USER:[COMPXFER]/CAD$USER:[COMPXFER]
put: Access failed: 550 Failed to set default directory to
CAD$USER:[COMPXFER]/CAD$USER:[COMPXFER]/CAD$USER:[COMPXFER]
Comment 1 Bastien Nocera 2005-10-19 04:07:54 EDT
Created attachment 120153 [details]
lftp-use-setcwd-no-leading-slash.patch
Comment 5 Jason Vas Dias 2005-11-29 12:42:06 EST
Patch applied in lftp-2.9.3-6, a candidate for the next RHEL-3 update -
meanwhile, lftp-2.9.3-6 is available from: 
    http://people.redhat.com/~jvdias/lftp/RHEL-3
Please try out this package and let me know of any issues - thanks.
Comment 15 Red Hat Bugzilla 2006-05-03 15:20:13 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0302.html

Note You need to log in before you can comment on or make changes to this bug.