Bug 171249 - Unable to obtain cluster lock when starting rgmanager
Unable to obtain cluster lock when starting rgmanager
Status: CLOSED DUPLICATE of bug 171253
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: rgmanager (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lon Hohberger
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-19 18:11 EDT by Corey Marthaler
Modified: 2009-04-16 16:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-20 10:09:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2005-10-19 18:11:10 EDT
Description of problem:
I had a gulm cluster (link-10, link-11, link-12) serving up an IP service, I
rebooted all of the nodes at the same time and when they came back up, I
couldn't get rgmanager started. The gulm cluster appeared just fine though:

[root@link-10 ~]# gulm_tool getstats $(hostname)
I_am = Slave
Master = link-11.lab.msp.redhat.com
rank = 0
quorate = true
GenerationID = 1129740868201085
run time = 1161
pid = 3248
verbosity = Default
failover = enabled

[root@link-11 ~]# gulm_tool getstats $(hostname)
I_am = Master
quorum_has = 3
quorum_needs = 2
rank = 1
quorate = true
GenerationID = 1129740868201085
run time = 1161
pid = 3248
verbosity = Default
failover = enabled

[root@link-12 ~]# gulm_tool getstats $(hostname)
I_am = Slave
Master = link-11.lab.msp.redhat.com
rank = 2
quorate = true
GenerationID = 1129740868201085
run time = 1160
pid = 3248
verbosity = Default
failover = enabled

Oct 19 11:54:45 link-11 clurgmgrd[3275]: <info> State change: Local UP
Oct 19 11:54:45 link-11 clurgmgrd[3275]: <err> #33: Unable to obtain cluster
lock: Resource temporarily unavailable
Oct 19 11:54:45 link-11 clurgmgrd[3275]: <info> State change: link-12 UP
Oct 19 11:54:45 link-11 clurgmgrd[3275]: <err> #33: Unable to obtain cluster
lock: Resource temporarily unavailable
Oct 19 11:54:45 link-11 clurgmgrd[3275]: <info> State change: link-10 UP
Oct 19 11:54:45 link-11 clurgmgrd[3275]: <err> #33: Unable to obtain cluster
lock: Resource temporarily unavailable
Oct 19 11:55:22 link-11 lock_gulmd_core[3248]: "Magma::3304" is logged out. fd:12

[root@link-11 ~]# clustat
Member Status: Quorate, Group Member

  Member Name                              State      ID
  ------ ----                              -----      --
  link-12                                  Online     0xffff0000a2540f0a
  link-10                                  Online     0xffff0000a0540f0a
  link-11                                  Online     0xffff0000a1540f0a

  Service Name         Owner (Last)                   State
  ------- ----         ----- ------                   -----
  10.15.84.156         (none                        ) stopped

Version-Release number of selected component (if applicable):
[root@link-11 ~]# clustat -v
clustat version 1.9.38
Connected via: GuLM Plugin v1.0.1
Comment 1 Corey Marthaler 2005-10-20 10:09:41 EDT

*** This bug has been marked as a duplicate of 171253 ***

Note You need to log in before you can comment on or make changes to this bug.