Bug 171253 - magma_gulm returns -11 instead of -1,errno=EAGAIN
magma_gulm returns -11 instead of -1,errno=EAGAIN
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: magma-plugins (Show other bugs)
4
All Linux
medium Severity high
: ---
: ---
Assigned To: Lon Hohberger
Cluster QE
:
: 171249 (view as bug list)
Depends On:
Blocks: 164915
  Show dependency treegraph
 
Reported: 2005-10-19 19:08 EDT by Lon Hohberger
Modified: 2009-04-16 16:18 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2006-0172
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-06 15:30:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fixes lock brokenness (1.09 KB, patch)
2005-10-19 19:08 EDT, Lon Hohberger
no flags Details | Diff

  None (edit)
Description Lon Hohberger 2005-10-19 19:08:28 EDT
Created attachment 120178 [details]
Fixes lock brokenness
Comment 1 Lon Hohberger 2005-10-19 19:08:28 EDT
Description of problem:

This causes rgmanager to break under lock contention and raise "Resource
temporarily unavailable" messages if multiple instances boot at near or exactly
the same time.

Rgmanager calls clu_lock() which is supposed to wait until a successful lock
grant has been issued, or unrecoverable error has occurred.  Due to a bug in
magma_gulm.so, it returns immediately - with -11, errno=0.  It should return
EAGAIN so the clu_lock() function will correctly retry.
Comment 2 Corey Marthaler 2005-10-20 10:09:55 EDT
*** Bug 171249 has been marked as a duplicate of this bug. ***
Comment 3 Lon Hohberger 2005-11-14 15:14:58 EST
Fixes in CVS
Comment 5 Red Hat Bugzilla 2006-01-06 15:30:23 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0172.html

Note You need to log in before you can comment on or make changes to this bug.