Bug 171258 - Firefox hangs briefly the first time a dialog is opened
Firefox hangs briefly the first time a dialog is opened
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
: 173150 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-19 20:01 EDT by Patrick Barnes
Modified: 2007-11-30 17:11 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-17 14:28:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick Barnes 2005-10-19 20:01:57 EDT
Description of problem:
Firefox in Rawhide hangs for several seconds the first time a dialog is opened.
 For me, it seems to hang for 5-10 seconds, but I've heard others say it hangs
up to 15 seconds.  After the first dialog, there are no further delays.

Version-Release number of selected component (if applicable):
Last tested: firefox-1.5-0.5.0.beta2
Appears to have affected all Rawhide versions of Firefox for about the last week

How reproducible:
Always

Steps to Reproduce:
1. Close Firefox (if running)
2. Open a new instance
3. Visit a site that causes a dialog to appear
 * Password dialogs (HTTP Basic auth or Master Password) seem to be the best
examples
  
Actual results:
Firefox hangs for several seconds before accepting input.

Expected results:
The dialog should appear and immediately accept input.
Comment 1 Zuirdj 2005-11-03 22:49:20 EST
+1

Also when I select "save link as", the download dialog hangs depending on the
number of tabs opened or the size of them.
Comment 2 Patrick Barnes 2005-11-04 01:16:07 EST
That sounds like a different issue, and one that I am not seeing.  If this is a
problem you are continuing to see, and you can be more specific, you may need to
file a separate bug report.  You might want to see if anyone else is having the
same problem first.  I am not seeing it and have not heard any similar complaints.
Comment 3 Patrick Barnes 2005-11-04 01:17:33 EST
After reloading my system with a fresh devel install, the delay before the
dialogs are ready to accept input has decreased, but is still longer than it
should be.  I'd like to know if anyone can verify that this problem continues to
manifest itself.  I know I've heard other complaints, but not recently.
Comment 4 Thomas M Steenholdt 2005-11-04 07:47:55 EST
I have the same problem where the first dialog makes firefox unresponsive for at
~10-15 seconds. SSL domain mismatch, javascript popups, whatever pops up first
will cause firefox-bin to consume NEAR 100% CPU and become unresponsive for this
amount of time...

I just tried the same with a self-built version of RC1 under FC4 and it's
exactly the same problem.
Comment 5 Thomas M Steenholdt 2005-11-04 08:06:24 EST
The binary linux distribution of 1.5rc1 (compat-libstdc++ based) from
mozilla.org does NOT exhibit this behaviour.
Comment 6 Thomas J. Baker 2005-11-05 08:43:25 EST
firefox-1.5-0.5.0.rc1 just added to rawhide still exhibits this problem for me.
Comment 7 Thomas M Steenholdt 2005-11-15 17:58:32 EST
Just rebuilt rc2 on my FC4 which had this problem on rc1 and it appears that the
bug is gone... Can't wait to hear what kind of result you guys have.
Comment 8 Marius Andreiana 2005-11-16 14:03:29 EST
*** Bug 173150 has been marked as a duplicate of this bug. ***
Comment 9 Thomas M Steenholdt 2005-11-17 05:12:39 EST
strange.. problem has reappeared on my system and i can't think of why...
I'll try to figure out what's happening!
Comment 10 Lars G 2005-11-21 07:45:00 EST
-rc3 stalls here too.
Comment 11 Thomas M Steenholdt 2005-12-06 18:14:44 EST
firefox-bug305970.patch from the rawhide firefox-1.5-1 package resolves the issue.
Comment 12 Zuirdj 2005-12-13 09:13:22 EST
firefox-1.5-1.1 works OK for me. 
Comment 13 Patrick Barnes 2005-12-13 09:25:34 EST
Seems to be working fine here, too.

Any additional comments or observations before I close this bug?
Comment 14 Patrick Barnes 2005-12-17 14:28:34 EST
I'm closing this bug as RAWHIDE.  Thanks, everyone, for your attention to this.

Note You need to log in before you can comment on or make changes to this bug.