Bug 171294 - Openssl libica and libica OpenSSL Engine need update
Openssl libica and libica OpenSSL Engine need update
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: openssl (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
: FutureFeature
Depends On:
Blocks: 168429 170708
  Show dependency treegraph
 
Reported: 2005-10-20 10:40 EDT by Phil Knirsch
Modified: 2015-03-04 20:15 EST (History)
4 users (show)

See Also:
Fixed In Version: RHEA-2006-0069
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-07 13:32:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Phil Knirsch 2005-10-20 10:40:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b3) Gecko/20050818 Fedora/1.1-0.2.7.deerpark.alpha2.1 Firefox/1.0+

Description of problem:
IBM has requested an update for the openCryptoki library to openCryptoki-2.1.6-rc2. This updated requires an update of the libica in openssl as well because of build dependancies.

So in order for the openCryptoki update to take place libica in openssl needs to be updated first and together with openCryptoki.

Version-Release number of selected component (if applicable):
openssl-0.9.7a-43.3

How reproducible:
Always

Steps to Reproduce:
1. Update openCryptoki tarball to openCryptoki-2.1.6-rc2 in the srpm
2. Try to rebuild the package now with the old openssl
3. Watch it fail due to missing header tags among other things.
  

Actual Results:  Rebuild of the new openCrytoki package failed due to missing new header tags and features that get introduced with libica-1.3.6-rc2.

Expected Results:  That was actually expected behaviour as libica and openCrytoki are tied together fairly directly.

Additional info:
Comment 12 Red Hat Bugzilla 2006-03-07 13:32:25 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2006-0069.html

Note You need to log in before you can comment on or make changes to this bug.