Bug 171360 - evolution: symbol lookup error: /usr/lib/libcairo.so.2: undefined symbol: FT_GlyphSlot_Embolden
evolution: symbol lookup error: /usr/lib/libcairo.so.2: undefined symbol: FT_...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cairo (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-21 01:32 EDT by Radek Vokal
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-24 02:15:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Radek Vokal 2005-10-21 01:32:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b5) Gecko/20051008 Fedora/1.5-0.5.0.beta2 Firefox/1.4.1

Description of problem:
Evolution crashes on startup with

$ evolution
adding hook target 'source'

(evolution:31199): camel-WARNING **: camel_exception_get_id called with NULL parameter.

(evolution:31199): camel-WARNING **: camel_exception_get_id called with NULL parameter.

(evolution:31199): Gdk-CRITICAL **: gdk_gc_set_foreground: assertion `GDK_IS_GC (gc)' failed
evolution: symbol lookup error: /usr/lib/libcairo.so.2: undefined symbol: FT_GlyphSlot_Embolden


Last few lines from strace

mmap2(0xabe00000, 1048576, PROT_NONE, MAP_PRIVATE|MAP_ANONYMOUS|MAP_NORESERVE, -1, 0) = 0xabe00000
mprotect(0xabe00000, 135168, PROT_READ|PROT_WRITE) = 0
mprotect(0xabe21000, 8192, PROT_READ|PROT_WRITE) = 0
mprotect(0xabe23000, 4096, PROT_READ|PROT_WRITE) = 0
mprotect(0xabe24000, 4096, PROT_READ|PROT_WRITE) = 0
mprotect(0xabe25000, 4096, PROT_READ|PROT_WRITE) = 0
mprotect(0xabe26000, 4096, PROT_READ|PROT_WRITE) = 0
mprotect(0xabe27000, 4096, PROT_READ|PROT_WRITE) = 0
mprotect(0xabe28000, 4096, PROT_READ|PROT_WRITE) = 0
mprotect(0xabe29000, 4096, PROT_READ|PROT_WRITE) = 0
mprotect(0xabe2a000, 4096, PROT_READ|PROT_WRITE) = 0
mprotect(0xabe2b000, 4096, PROT_READ|PROT_WRITE) = 0
mprotect(0xabe2c000, 4096, PROT_READ|PROT_WRITE) = 0
mprotect(0xabe2d000, 4096, PROT_READ|PROT_WRITE) = 0
mprotect(0xabe2e000, 4096, PROT_READ|PROT_WRITE) = 0
mprotect(0xabe2f000, 4096, PROT_READ|PROT_WRITE) = 0
mprotect(0xabe30000, 4096, PROT_READ|PROT_WRITE) = 0
mprotect(0xabe31000, 4096, PROT_READ|PROT_WRITE) = 0
mprotect(0xabe32000, 53248, PROT_READ|PROT_WRITE) = 0
mprotect(0xabe3f000, 4096, PROT_READ|PROT_WRITE) = 0
writev(2, [{"evolution", 9}, {": ", 2}, {"symbol lookup error", 19}, {": ", 2}, {"/usr/lib/libcairo.so.2", 22}, {": ", 2}, {"undefined symbol: FT_GlyphSlot_E"..., 39}, {"", 0}, {"", 0}, {"\n", 1}], 10evolution: symbol lookup error: /usr/lib/libcairo.so.2: undefined symbol: FT_GlyphSlot_Embolden
) = 96
exit_group(127)    

Version-Release number of selected component (if applicable):
evolution-2.4.1-4

How reproducible:
Always

Steps to Reproduce:
1. start evolution
2.
3.
  

Additional info:

$ rpm -q evolution cairo
evolution-2.4.1-4
cairo-1.0.2-2
Comment 1 Dave Malcolm 2005-10-21 16:01:17 EDT
Works for me with those same two packages; lower-level problem?

Switching to cairo
Comment 2 Kristian Høgsberg 2005-10-21 16:22:46 EDT
Ah, we probably need a more specific requires for freetype... what version of
freetype does this fail with?
Comment 3 Radek Vokal 2005-10-24 02:15:56 EDT
Aha, it picks this symbol from new freetype. Updating freetype to 2.1.10-1 fixed
this issue, closing. 

Note You need to log in before you can comment on or make changes to this bug.