Bug 17138 - rpm -e doesn't give enough info.
rpm -e doesn't give enough info.
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-31 11:48 EDT by Harvey Stein
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-31 11:48:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harvey Stein 2000-08-31 11:48:58 EDT
rpm -e output is confusing and insufficient for cleanup.  Example:

   blinky# rpm -e howto-italian
   package README not listed in file index
   package README not listed in file index
   package README not listed in file index
   package INFO-SHEET-9.html not found in file index
   package README not listed in file index
   package README not listed in file index
   package INFO-SHEET-9.html not found in file index

It seems to be saying that it couldn't delete some files.  But it doesn't
call them files, it calls them packages.  And, it doesn't list the full
path to these files, so I have no way to find them to do cleanup by hand.

I haven't been able to check yet whether or not this also occurs in newer
releases.
Comment 1 Jeff Johnson 2000-09-05 09:57:23 EDT
This error can be ignored.  The message is warning (in very bad English) that
the
listed files names, which are keyed by using the basename of the file(s), which
would
be removed by the erase command, are already removed from the file name inverted
list.

Since the basename's have already been removed, there is no way to indicate the
entire file path.

FWIW, this bug has been in all of rpm-3.0.x and has, aside from the error
message itself,
no other known consequence.

Note You need to log in before you can comment on or make changes to this bug.