Bug 17139 - ssh-add / openssh-askpass problem
Summary: ssh-add / openssh-askpass problem
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: openssh (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-31 15:49 UTC by Gerald Teschl
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-08 07:57:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gerald Teschl 2000-08-31 15:49:03 UTC
The openssh-askpass dialog never accepts the passphrase the first time.
I always have to type it twice. I have tested different window managers.

No problems under RH6.2 and on the command-line.

Comment 1 Nalin Dahyabhai 2000-09-07 18:59:58 UTC
The version in the build tree appears to be working correctly.  It prints out
whatever I've typed the first time.

Comment 2 Gerald Teschl 2000-09-08 07:57:35 UTC
This is in fact a very weird problem! I just replaced the ssh-askpass by a
little wrapper
to figure out what is wrong:

#!/bin/sh
PASS=`/usr/lib/ssh/ssh-askpass.orig`
echo $PASS >> /tmp/pass.log
echo $PASS

And now it works!? If I remove the  wrapper it doesn't. This looks like quantum
mechanics to me:
Watching the experiment changes its outcome! Anyway, I hope this is gone in the
final
release.


Note You need to log in before you can comment on or make changes to this bug.